Writing automation on a Kontakt track with multiple articulations slots

Let me start by saying that I have owned Dorico Pro since version 2, but only for engraving, I never used it to play my scores. I always do my mockups in Cubase Pro.
Now, with Dorico 5.1, I’m trying to save some time and change my workflow so I can have a rough mockup with Dorico and then do some tweaks, mixing, and mastering in Cubase.

I usually use one Kontakt instance with multiple slots and different articulations for every instrument. For example, for Violin I, I have Slot 1 - Legato (Channel 1), Slot 2 - Longs (Channel 2), Slot 3 - Staccato (Channel 3), and so on.

I configured Expression Maps with Dorico, as with Cubase, which can trigger these articulations using the Abs. Ch option, and they work when playing the music. The problem is that when I try to record automation (like CC1 or CC11) it always affects slot 1 which is assigned to channel 1 (even if another articulation is being played in another channel).
In Cubase, the channel assigned to a track can be set to “Any” allowing to record data for any channel, but in Dorico there’s no such option and you must specify a channel in the track inspector.

I guess this wouldn’t happen if using a single slot for each instrument with a patch containing several articulations (with key switches to trigger them) but that is very limited.

So, how do you solve this automation issue?

Thanks for you help!

I just tested this quickly for myself, and I find that any MIDI CC data I enter in the Key Editor will be played to all the channels used by the instrument.

For example, in the attached trivial project I’ve modified the Default expression map to play the natural playback technique on channel 1, and the pizz. playback technique on channel 2, and have created a CC1 ramp in the Key Editor. Looking at the mod wheel controller in the HALion Sonic plug-in, I can see (and in the case of the electric piano patch, hear) the CC1 data being played back on both channels.

cc1-two-channels.dorico (339.1 KB)

I’m very sorry Daniel but I forgot to mention an important detail: this automation problem happens when recording in real-time with a MIDI controller (I have the Nektar Impact LX88 and Korg Nano Kontrol2 and have the same issue with both).

As you mentioned, if I manually draw automation in the key editor it works.

The only way I found to record the automation in real-time with a MIDI controller is by changing the channel in the track inspector to the channel assigned to the playback technique.
This produces an automation with “steps” and when I play the sound it has “bumps”.

The automation drawn with the pencil produces a straight line and a clear crescendo sound (CC1 controller):


There’s no way to record a smooth ramp that’s equivalent to using the line tool, I’m afraid.