Wrong audio SNAP markers which I can't get rid of FOR YEARS

Hello!

I record some audio - backing vocals, for example. A few tracks with audio clips.
I edit them.
I take the Selection tool, select the clips and copy them to the clipboard.
I then Paste them to my 2nd chorus, but Cubase doesn’t put them where I set my cursor.
It shifts the whole bunch of my clips somewhere before or after the necessary bar. Ignoring snapping to the grid.

Here’s the link to the video of how it looks
https://youtu.be/hF9MGbmkiQg
Usually the only way to deal with it - move the audio manually, which is unacceptable sometimes.

I’ve been coming across this issue for more than 6 years now - since version 7.5.
Am I missing something?

Hi,

These tracks are in a folder, right? Is there Group Editing enabled on the Folder track by any chance?

Hello!
No, Group Editing was off.
I also usually came across this issue with individual tracks, not with groups

I can only presume that within one of audio files you are selecting - most probably either of the two front ones, that the snap marker within the audio file is not on the beginning of the bar line.

This can happen occasionally when you drop into record from play, or record arm a track while playing and then drop into record - the snap marker is written at a point within a bar, not at the start of a bar where it normally is.

Then when copy pasting, Cubase is using this errant snap point which results in problem you see.

ok, but is there any way to turn this snap points off or edit them?

Hi,

You can move the Snap point in the Sample editor.

It is bit of a pain when these markers end up at a weird position - I’m not sure of the reasoning behind it.

As Martin says you can adjust from within the Sample Editor, OR, you could set Snap to ‘Grid Relative’ rather than just ‘Grid’ - this should sort you out.

thank you!