Wrong clef position in multiple line staff


I have only briefly researched, but did not find the topic.
It seems that in staves with multiple lines the clefs are positioned incorrectly. For 5 lines correctly as G2 clefs, for 6 between lines 2 and 3, for 7 as G3 (n+1/2 each) and for less than 5 lines n-1/2 (for 4 lines between 1 and 2) and so on. The notes themselves are always displayed correctly for a G2 clef (e on line 1).
It would be practical if there were a clef editor or if you could specify a reference line for all clefs in the instrument editor. However, the clef position can be corrected via the music symbol editor.
Am I doing something wrong with the settings in the instrument editor that would affect this behavior?

Best regards

Yes, at the moment this is how Dorico positions clefs for staves with more or less than five staff lines, and there’s nothing you can do to change this in the instrument editor. However, this is something we will correct in the next update when it comes along.