Wrong number of beats in bar, no idea how to fix


I’m new to Dorico and I am finding the control scheme horrendous.

I’m typing out a 3/4 time score. There are no time score changes in the whole piece. Why does this bar only have 2.5 beats in it and how can I fix it?

I should be able to select a range of notes and “reset bars”. How do I do that?

I have tried copying the notes into new bars and then deleting these, but there is some invisible glyph that seems to be adding an eighth.

Also, why is there a natural in bar 25 and how do I delete it (can’t unclick natural on the side panel?)

First off, welcome to the forum, @badmozart

  • What happens if you select and delete the barline between the two eighth notes?
  • What was the time signature before you applied 3/4?
  • Try selecting the F-natural and pressing zero (the Hot-key for “natural”).

You can post the Dorico file here (as soon as your forum permissions allow), which would give us a better idea of how to help.

Have you been to the resource page and worked through First Steps? That should be intuitive when starting a new program.

I get a mutant bar with phantom rests in the playback that don’t appear in the score even after I “delete all rests” from Edit.

It was a blank Solo Piano project that defaults to 4/4, which I changed before typing any notes

Nope, does nothing.

Have you at some point used Edit > Remove Rests?

For the natural, there’s probably an F with an accidental in a previous bar. Set Notation Options > Accidentals to give you the cautionaries you want, and then if need be you can override locally by selecting the relevant note and setting its Accidental property appropriately in the bottom panel.

Welcome to the forum @badmozart

Using the Edit > Remove Rests function essentially just hides rests, it doesn’t remove them from the “time stream” (i.e. the duration represented by those rests still exists between the notes on either side).

I would recommend making sure signposts are shown and checking for a red one positioned where one of those barlines is in your picture. These red signposts indicate hidden time signatures or barlines you’ve input manually.

When starting projects in the Hub, you can change the time signature then and there, in the area on the right:

Why do I ever need to Edit > Remove Rests?

Why doesn’t just pressing the delete key delete them?

The philosophy in Dorico is that normally rests aren’t “real”: they’re produced automatically where necessary to fill in the gaps between notes. Furthermore, in general, deleting rests is a bad idea: it can have the effect of leaving bars with the wrong numbers of beats, which we try to make difficult. So in the spirit of trying to help you not to make unintended mistakes, you can’t delete what we call an implicit rest, which is a rest that only exists to fill in the gaps between notes. However, you can force them not to appear by using Remove Rests, if that’s required.

…and if what you meant was to delete the gaps between notes, thus pulling the following music to the left, there’s Insert mode for that (see Insert mode)

Why does there need to be an Insert mode, and why does it need to have multiple different variants? Because Dorico doesn’t automatically know whether you want to add or remove time from a single voice, or a single stave, or the whole ensemble.

Sounds like an implementation detail bubbling up into the UX to make it confusing.

What if rests were real. Then I could just type what I wanted and what I typed would be what plays. Bars are a detail that don’t effect playback, if anything, those should be implicit (btw why aren’t bars with the wrong number of beats highlighted with a “grammar check”, since it seems to happen so often?)

Having hidden information under the sheet music is like how formatting in MS Word used to be. My score is very simple; I shouldn’t be running into problems like these.

No, it’s really the opposite: we think it’s desirable from the user’s point of view that rests aren’t real. Almost all of the time, you don’t need to input rests in Dorico, or indeed do anything much with them at all: Dorico creates them as needed, groups them automatically (according to your preferences as expressed in Notation Options), moves them out of the way of opposing voices automatically, and so on.

I realise that you’re bumping up against a few of Dorico’s concepts here in the early going, but I believe you will come to see the value in these design decisions.

1 Like

You really do need to use Dorico with an open mind. The program is brilliantly designed, if you’re willing to learn it.

I benefit constantly from the way that rests and ties are implemented.


This literally never happens unless one uses Edit > Remove Rests or sets the Starts Voice/Ends Voice properties (or imports MusicXML that contains hidden rests, and even then you can prevent Dorico from respecting that information at the import stage).

There is a comprehensive manual. There are well over 100 tutorial videos. There is this forum, plus a Facebook group.

If you don’t understand how a tool works, ask questions first. Don’t drive the car into a wall and then blame the manufacturer for not giving you driving lessons.


To be fair, it can also happen when changing a time signature earlier in a flow than another existing time signature, without Insert mode active. I personally think that the request for some sort of highlight/signpost mechanism to bring bars with fewer beats “than advertised” to a user’s attention has merit. (But goodness let’s not have that discussion here – I merely wanted to acknowledge that situation, in case badmozart found discussions about that whilst looking up this situation.)


Sure, but actually that’s a different situation. In the OP’s case all the beats are there, as playback would confirm, but the rests have been removed.

(Ah, you edited. Well yes, I agree.)

1 Like

badmozart have you tried Lily’s suggestion of showing the tempo sign posts? I have often experienced this issue when importing a mdid file with some bars not being in accordance with the valid time signature, It always shows the exact count in the signpost and if you delete it all is rearranged correctly.

I’ve also noticed the occasional beam-over-barline as the result of an XML import from Musescore that is later edited in Dorico. I wonder if there’s a similar issue here.