X-LFO Graphic to Macro Page

Loving the new X-LFO and the capabilities it brings.
I’d like to bring the XY graphics to my macro page. I noticed in the parameter list it does show the LiveViewDataX and the LiveViewDataY. So it seems like it can be done.
I’ve gone through the provided templates by Steinberg but didn’t’ see anything that accommodates these. Did I miss a template that provides this feature or would I have to script one?
If it needs scripting, I could use some much needed help. Any help is greatly appreciated!
Thanks!

You could try the Live Data View control.
Live Data View - HALion Macro Page - Steinberg Developer Help

You could add two of those controls to macro page and stack them on top of each other. If you set the background colour of the first one to transparent you should see the combined output of both X and Y. It does look a bit different compared to the xlfo editor view though.

Thanks for the response! Maybe I need to do a reinstall of HALion or something. I’m not finding that in my resources. Seems to be missing…I’ll see if I can do that soon.

An aside to that, you wouldn’t also happen to know the modulation source type for the XLFOx and XLFOy would you? Looking at this page (https://developer.steinberg.help/display/HSD/Modulation+Source+Types) by Steinberg, it hasn’t been updated to reflect the addition of these. I’ve tried every possible solution I could but haven’t gotten it to work yet.

It’s not a template. You need to create new element.

You are right. The documentation isn’t updated. Using index 39 and 40 should work for xlfox and xlfoy

Ah, got it!
To your knowledge, is there a way to get this to work with a ‘type:Zone’ in the address. I’ve got a multi sampled instrument here that each zone is within a layer and the X-LFO is inserted on the mod matrix of that layer. So attaching the XLFOX LiveViewData to the Live Data element, I’m editing the address to have ‘type:Zone’ instead of the specific sample name. Unfortunately, this appears to break it.

Curious, how are you finding the index numbers for the XLFOY and XLFOY? I tried finding that but obviously was looking in the wrong place. Also, Lua script is yelling at me when I do something like this
{ name = "X-LFO X", assignFunc = assignStandardSource, index = ModulationSource.39, bipolar = 1, smoothing = -1 }
I’m guessing there is a better way to write this?

Thanks for the help. You’re a life saver

I think I figured out the script issue. Just needed to get rid of “ModulationSource” and just put 39.

Yes, that’s what I meant by using index.

Not sure about type:Zone. Did you try to create a template or a group? If that doesn’t work could create a scope parameter. Something like the sample display in Skylab that shows the currently playing sample.

Hi Misohoza,
I hate to open this thread back up. But I’m getting back into this project for the moment.
Curious if you could (or anyone for that matter) shed some light on an issue related to this I’m having. If I can get this to work perhaps I can get the XLFO graphic to work too.
You brought up the sample display in skylab. I’ve used this in other instruments but even in this instrument it seems to break. The setup for this instrument is in the image:


But the sample displays just don’t work. The scope zone looks like this:

for i = 1, 4 do
  defineParameter("zoneScope"...i,nil,"")
end

function updateSampleDisplay(note)
  local zones = this.parent:findZones(true)
  for i, zone in pairs(zones) do
    if note >= zone.keyLow and note <= zone.keyHigh then
      zoneScope= "@layer:0/@0:"..zone.name.."/"
      break
    end
  end
end

The actual Zone Sample templates’ scopes are set to “@zoneScope”.

I’ve tried variations of this to no avail. Any suggestions? thanks!!