X-Touch Cubase12 faders change pitch

Setup Behringer X-Touch (full-size) as control surface using Mackie control. Seems to be working, faders jump, transport works, but WHEN I ADJUST THE FADER ON A MIDI TRACK IT CHANGES THE PITCH OF THE TRACK. I’m guessing the fader is somehow mapped to pitch and volume on MIDI. Is there a way to isolate the control surface MIDI messages from everything else ? My setup is Cubase12, Behringer X-Touch, Presonus Quantum 2626, and M-Audio Oxygen Pro 61.

As a first check, make sure that the Behringer MIDI Ins and Outs connected to the MCU are not included in ‘All MIDI Inputs’.
For further investigation (if the above didn’t help), a screenshot of your MIDI setup might help…

1 Like

Thanks for the quick reply. No, the MIDI ports are all set to “X-Touch”.

So close, I’m sure (hope) it’s something simple.

Oops, only one image per post.

Is it funny that there’s nothing in the Remote section ?

Under Remote Devices both Track and VST also have “X-Touch” selected. I have the X-Touch connected to the computer via USB cable. I can connect it to the MIDI Ports on the Quantum if needed.
Thanks again

These are quite some MIDI ports…
I’d uncheck all ports but those you need in the ‘Visible’ column. You’ll definitely need the ‘Oxygen Pro 61’ In port and the ‘X-Touch’ In and Out ports. Then uncheck the ‘X-Touch’ in the ‘In All MIDI Inputs’ column. That should solve your problem…

As for the additional Oxygen ports, check it’s manual (here’s a little excerpt)