X Touch + Extender but fader bank is only 8 channels

Hi Guys,

I just bought my X Touch + Extender and i’ve setup it in cubase and they are working well together but my fader bank has a size of 8 instead of 16. When im in channel 1, for example, my last fader is channel 16. If I press the fader bank once, my fader 1 is Channel 9 (instead of channel 16) and my last fader is Channel 24 instead of 32. I also briefly tried it with studio one and it seems to behave exactly as cubase. Is this the expected behavior of the Xtouch + Extender ? Does a “real” Mackie Controller works like that ?

Thanks

Hi,

I expect this device is based on Mackie Control protocol. Make sure you have 2 Mackie Control devices added in the Studio Setup, please.

HI Martin, thanks for the reply.

Yeah… I have 2 Mackie control devices in my studio setup One for the X Touch an the other for the X Touch Extender. I Even tried using one virtual mackie control app for iPad + my real extender (to make 16 channels) and it still goes in banks of 8. Any Idea ?

Hi,

Are you sure 2 different MIDI Ports are set? Could you share a screenshot of your Studio Setup?

Hi Martin,
Yeah, I’m using 2 different MIDI Ports.
These are the screen shots of my Studio setup.


Hi,

Do you also use 2 Generic Remote Devices? What are the MIDI Ports there, please?

Hi Martin,

I use one Generic Remote for my iPad with Touch OSC running on a network Midi Port… the 2nd one was just for testing and I already tried removing both Generic remotes and also my CMC CH Leaving just the 2 Mackie Controllers and still have 8 bank faders. Do you have any other suggestion ?
Thanks

Hi,

Do you see even the white line, which marks, which tracks are controlled right now, over 8 channels only?

Hi,

This white line is acting a bit strange… when I’m on the 1st channel, the white line goes from channel 1 to channel 16 (which it should be).
If I press fader bank up, the white line goes from channel 17 to channel 24 (8 channels only) but i’m controlling from channel 9 to 24 (again, 16 channels), If I keep pressing bank up, it only shows the last 8 channels i’m controlling, instead of the current 16 channels. What is strange is that if I press fader bank down, the white line starts showing the current 16 channels i’m controlling but with the bank size of 8, instead of 16!
I don’t know if I was clear! I made a small video showing this problem. In this video I’m always moving the 1st and the 16th fader. I think you will understand.
https://www.youtube.com/watch?v=APT14Mfogho

Thanks for all the help

I have a Qcon Pro X & 1 extender.
So 16 faders, and it’s only banking 8 at a time.
It’s not that big of a deal to me, I can live with that.
My guess is, that it’s a limitation in the protocol???
I know there are people on here with Mackie’s & several extenders, maybe one of them could chime in??

Hi Henry,
I didn’t got it to work with 16 channels using cubase. It was only 8. No matter what I tried. Mac, Windows, Laptop, Desktop, Different Cubase versions. All were just 8 channels.
What I did to solve this problem was create a MaxMSP (Or Puredata) patch that is now making the bank size of 16 and MANY more things like controlling plugins with just one click (no more rotating knobs to find the correct IFX Slot), channel strips with just one button, customizing the wheel to do whatever I want and many more… My workflow has never been better using a controller.

But everything started with this bank size of 8 that was driving me crazy!!
I made a video explaining in detail what I did and you can just download the files (in the description) and do the same thing on your system.
https://www.youtube.com/watch?v=esOnlGyvTs4&t

Let me know if it works for you!

PG