Yamaha keyboard midi usb "not connected"

Just downloaded were version of cubase Artist. Old version required the Yamaha driver to connect and link up my Yamaha s90. However, the prompts in Artist 11 suggest that I simply go to Studio; more options, keyboard device manager. From that point I not my keyboard is listed so I have clicked Install device. Now the midi device manager indicates my Yamaha s90 is an “installed device” however I have output as “not connected”. I have switched on my synth and connected with usb cable. In the older version I loaded the driver for the keyboard first then I could go in and add it as a midi device but the website here doesn’t have an updated manual so the instructions don’t match the software. Can someone help - do I install the Yamaha driver as I would in previous versions? very confusion assumptions.

First, you’ll have to use both a MIDI track and an audio one to get the sound from the S90. In your case, I wouldn’t install the driver, unless you want to use the S90 as a remote controller for Cubase (and even, it shouldn’t be necessary, in this case, using Cubase Generic Remote definitions feature).

IOW, either an USB or two MIDI cables for the MIDI part of the connection, and two audio ones for the audio (stereo) signals. At this stage, it would have helped to give us what audio/MIDI interface you are using and how do you connect the S90 to it…

Beside this, what makes me wondering is this :

Normally, in the Output routing drop down list of the MIDI track inspector, you should be able to set the MIDI output used to control the S90. Having no true experience of MIDI used with USB, I won’t suggest a choice option, but from what I see in the S90 manual, the driver is not mandatory, so the MIDI USB output should be direectly available. If not, I would get rid of the USB connection and use the ol’ and reliable MIDI connectors instead. Again, the specifications of your audio/MIDI interface are lacking, preventing us to help more…

At the end, make things as simple as possible : no driver unless truely needed and, if possible, use MIDI cables over an USB one. In all cases, don’t forget to set, on the S90, the Local on/off parameter to off.