Yamaha Steinberg USB driver v1.10.5 for macOS

We are pleased to announce the release of a new version of the Yamaha Steinberg USB driver for macOS. The version 1.10.5 resolves an issue with audio dropouts on Macs with slower USB transfer specs and OS X 10.11 or later. For detailed information, we ask you to refer to the corresponding version history on the download page.

Please find the updated version 1.10.5 here.

Please note that this new driver is not part of the recently released TOOLS for UR and an update of the Yamaha Steinberg driver is recommended after the TOOLS installation.

Cheers for this.

When running the update, do I need to disconnect my UR22mk2 from USB?

I thought I’d give it a try without disconnecting it and it seems to have worked…

I never do that :wink:
I am glad to hear that it seems to have improved the situation!

Updated the driver, still getting the annoying flashing “usb” led. I’ve been a Steinberg user since “Cubase Score” in 1995, so it pains me to say that these driver issues are very annoying. I think I will eventually move to the red device from the competition as everyone else…

Just heads up to folks that the Yamaha Steinberg USB drivers v1.10.4 and v1.10.5 don’t appear to function under Mac OS Catalina (v10.15) public beta. I upgraded my Mac and lost all connectivity to my UR242.

Is there a beta driver for Mac OS Catalina

Anyone had any luck with installing Mac OS Catalina yet?

No luck here. I upgraded to Mac OS Catalina yesterday and my UR44 is not working.

I’m also having the same issued after an upgrade to Catalina, note that also the firmware driver doesn’t even work.

I’m sorry but we warned several weeks ago that those who rely on our products should not perform the OS upgrade yet. I have been told that the UR44 seems to work with macOS Catalina if the rear CC Mode switch is set to ON. At least, that would be a workaround for a non-working device for the time being.

Regarding Catalina.

I Have successfully installed Catalina in combination with a UR 22 mk II.
Reinstalled the latest driver (v1.10.5) after upgrade to Catalina. That’s it.

https://www.steinberg.net/en/support/downloads_hardware/yamaha_steinberg_usb_driver.html

Cheers!

Catalina ur22mkII failure alert, calling for driver update

Thank you ifresel I tried your suggestion with one minor additional step.

  1. Uninstall the driver
  2. Reboot
  3. Reinstall the driver
  4. Reboot

And so far things are working smoothly.

Thanks

Thank you fmatar so very much, It worked on UR22.

Hi, the reinstall of the driver worked for me after installing catalina a few weeks back - but since the latest catalina patch i can’t get my UR22mkII to work with cubase.

The driver install seems to go ok but when checking in MAC settings ‘sound’ and Audio Midi Setup I am presented with Steinberg UR22mkII 1 and Steinberg UR22mkII 2

only one of these has type or icon USB - if I do nothing else other than set the output of the mac audio to the ‘usb’ type ur22mkII device i can hear sound.

If I try and open the preference app to open the control panel the device listed as usb type disappears and i lose the sound.

If i uninstall the driver i can open cubase and select the ur22 but i can hear no sounds. If i try that with the driver installed i get the same as when opening the pref app i.e. the usb device disappears and i get a pop up for one of the listed devices stating no driver loaded … then if i select the other i can open cubase but again no sound.

Why am i seeing 2 x Steinberg UR22mkII’s listed ? very odd… yeah yeah DONT UPGRADE !!! - i use my Mac for more than just cubase and i don’t appear to have issues with it elsewhere :frowning:

Any idea if there is an updated driver being delivered/worked on? I’m seriously considering throwing my UR22 in the bin and going for another manufacturer… i.e. is the ‘red’ one miles better than the UR22mkII ?

UPDATE:

I was playing around as i was baffled by the 2 devices showing when i plug in the device via USB.

So here’s what i have done to get it working for my scenario (i.e. when i plug in the device i see 2 x devices listed then one goes away when i start cubase)

On Mac i launched cubase and the device type USB (ur22mkII) disappeared leaving just the one of no type (as seen in settings>sound)

I then ran from terminal

sudo kextstat

to list the loaded extensions - i noticed the following was loaded jp.co.yamaha.driver.YamahaSteinbergUSBAudio so i unloaded it using the following

sudo kextunload -b jp.co.yamaha.driver.YamahaSteinbergUSBAudio

this resulted in there being no ur22mkII devices listed in settings>sound and when cubase offered me an interface to select there were no ur22mkII’s available so i continued without selecting any - then i returned to terminal and loaded the extension again

sudo kextload -b jp.co.yamaha.driver.YamahaSteinbergUSBAudio

which then showed the non usb type UR22mkII listed in settings>sound again and i navigated to cubase studio setup and selected the asio device ur22mkII from there and i could hear audio and my mixers were displaying activity.

i assume i’ll have to do this every time unless i can find out what is going on but at least i can use the ur22mkII again with cubase…

Its like the Mac doesn’t associate the device with the driver/ext or something…

Now it is working as required for me. I’ve done:

  1. Updated macOS Catalina to 10.15.1 (19B88)
  2. Unplugged Steinberg URxx (UR12 in my case) from USB.
  3. Removed Steinberg USB driver by app downloaded together with driver installer (Uninstall Yamaha Steinberg USB Driver)
  4. Rebooted
  5. Just plugged back URxx device and use as usual (tested in GarageBand). It use the AppleUSBDevice kext now.

In terminal “ioreg -p IOUSB -w0 -l”:

±o Steinberg UR12 @00510000 <class AppleUSBDevice, id 0x10000063c, registered, matched, active, busy 0 (1 ms), retain 16>
{
“sessionID” = 0000000000000
“idProduct” = 5898
“iManufacturer” = 1
“bDeviceClass” = 239
“bMaxPacketSize0” = 64
“bcdDevice” = 257
“iProduct” = 2
“iSerialNumber” = 0
“bNumConfigurations” = 2
“Bus Power Available” = 250
“USB Address” = 5
“Built-In” = No
“locationID” = xxxxxxx
“bDeviceSubClass” = 2
“bcdUSB” = 512
“USB Product Name” = "Steinberg UR12 "
“PortNum” = 1
“non-removable” = “yes”
“AppleUSBAlternateServiceRegistryID” = 0000000000
“bDeviceProtocol” = 1
“IOCFPlugInTypes” = {“xxxxxxxxxxxxxxx”=“IOUSBHostFamily.kext/Contents/PlugIns/IOUSBLib.bundle”}
“IOPowerManagement” = {“DevicePowerState”=0,“CurrentPowerState”=3,“CapabilityFlags”=65536,“MaxPowerState”=4,“DriverPowerState”=3}
“kUSBCurrentConfiguration” = 1
“Device Speed” = 2
“USB Vendor Name” = “Yamaha Corporation”
“idVendor” = 1177
“IOGeneralInterest” = “IOCommand is not serializable”
“IOClassNameOverride” = “IOUSBDevice”
}
(Some output changed to “x” or “0” since I’m not sure if it is ok to share them. :confused: )
Hope it helps to somebody else.

I did the same - uninstalled the driver - restarted and opened Cubase and was able to select ur22mkII as the audio device no probs…

what does the driver actually bring i wonder? Coz i can still manage buffer sizes etc without it…