Yamaha Studio Manager uses wrong instrument

I use a Yamaha S90XS, Cubase AI5 and when I add new MIDI tracks I select the new instruments for that track on StudioManager. - Multi mode.

Usually all works well, all the tracks play and record the correct instrument up to a point, then for some strange reason it seems like the Yamaha and Cubase communication get mixed up because the track will play the 2 instruments together.

Say for example, I have a piano on MIDI track 3 and Piano on StudioManager Multi part3. Now I add another MIDI track, no 4 and on StudioManager I select strings as the instrument on part4. What happens is track 4 plays strings and piano together on the Yamaha whereas it is supposed to play only strings. Even I have the part4 (strings) selected on The StudioManager window. And part 1 and 2 still play and record the correct instruments.

I’ve tried taking StudioManager offline and online, turn everything off and close Cubase, restart the Yamaha and restart Cubase but it still happens.

Why does everything work fine at first, and then at some point this confusion happens?

Another thing I noticed is that when I play on the piano keys at the bottom of the StudioManager window, the right instrument plays on the Yamaha, but when I press the keys on my Yamaha it will play 2 instruments together.

For some reason this happens only sometimes, usually I have no problems with the tracks and instruments, correct tracks and instruments for a while and then for some reason I don’t know, the new tracks I add can not play the correct instrument.

Even if I add more MIDI tracks and set the instruments on the new tracks, it seems to get stuck on playing 2 instruments together.

All MIDI tracks output is set to Yamaha S90XS Port 1.

I autosync Global and Current when StudioManager starts and use quick setup 1 on StudioManager. The Yamaha is connected to my MacMini with a USB cable.

Any pointers will be greatly appreciated!!

Problem solved !

Set Local Control = OFF on the Yamaha. (Page 19 - Getting Started manual)

Guess I lost that setting after doing some factory reset on the Yamaha.
:blush: :blush: