Yamaha USB Midi driver not visible

I have a Yamaha S90XS which came with cubase 5AI. :slight_smile:
The keyboard works fine and the midi settings set for the keyboard.
The cubase has been installed with the extra bits and pieces onto my Dell laptop (32 bit XP).
I have installed the Yamaha USB driver and run the setup.exe as instructed after the keyboard USB was detected.
The driver shows a connection both in and out with the keyboard, showing the flashing connections, so it must be the correct driver.
BUT, when I open up the cubase software, it refuses to see the Yamaha USB midi driver in the Midi Port Setup, under the Devices/devices setup screen.
I have reinstalled the laptop sound card driver and Yamaha driver several times, but cubase refuses to see it.
Without this I cannot record the keyboard midi output, which was why I bought it in the first place.
Has anyone any ideas? :frowning:

Did you turn on the Yamaha S90S before opening Cubase ? If you don’t, it won’t show up, even if you turn it on after opening Cubase.

If you haven’t found the solution yet, I would suggest deleting your Cubase preference files: Close the Cubase program and follow theses steps :

  1. These are hidden folders, therefore you should select “Show the Hidden files and folders” option in:
    Start Menu -> Control Panel -> Folder Options -> select Tab “View”

  2. Afterward, you will be able to find the “Cubase AI 4” and “Cubase 5” folders at the following paths:
    C -> Documents and Settings -> User Name (Your user name) -> Application Data -> Steinberg -> Cubase 5 (in the same folder you should find Cubase AI 4)

3)Now, when you have done the path I wrote above, you can delete the " Cubase AI 4" and “Cubase 5” Folders, your software will recreate it automatically.
If you have some particular setting that you don’t want to lose it’s enough you rename the folder “Cubase 5”

If that doesn’t help, let us know. I’m very happy with my Yamaha S90XS and I do some great work in Cubase. It’s a bit of a learning curve, especially when you start, but once you get going, there’s no looking back.

In case you have not solved your problem yet, try the above and also let us know whether you installed Studio Manager, S90XS Remote tools and S90Xs Editor.

Many thanks for getting back so soon. It is so good knowing that there is someone out there that has a working system.

  1. I have Studio Manager, S90XS Remote tools and S90Xs installed.
  2. I found the cubase AI 5 folder you mentioned and renamed it ( there was no version 4 there ). As you said, this was recreated when I started up my cubase, but unfortunately has made no visible difference.
  3. I ensured that I had the keyboard on and connected via the USB link, before restarting cubase, but unfortunately it still could not see the Yamaha midi driver.

I have spent ages trying to understand the inter-relationships between the different parts of the registry, as I suspect this is where the problem lies, but so far cannot see how cubase would link to the Yamaha driver.
As my attachment shows, all it can see is the Microsoft GS port.

I cannot wait to start the long learning curve with cubase and get some multi-track recording going, as this really is a fabulous keyboard.

Could I ask a favour? I have noticed that if I go to the Control Panel / Sounds and Audio devices / Audio / Midi music playback - all I have here is this same Microsoft GS Wavetable SW Synth (No Yamaha). Do you get the same, or do you also see the Yamaha device?

Many thanks for you interest and help.
Steve
midi_port_setup.jpg

A bit more information.
If I didn’t mention it before, if I open the Yamaha USB Midi Driver from the Control panel, and click on the “Send all note on” button, it sounds a note on the S90XS, so that side of it is working fine.
So I thought, maybe the problem lies with the Cubase software.
So I downloaded a trial version of CW Sonar X2, and the first thing I noticed here is that it cannot see any midi ports. Just to make sure, I reloaded the Yamaha driver and checked again, but still nothing, so whatever it is, is common to both these tools.
I really hope I don’t have to change my laptop as this is an expense I could do without right now. It is one I inherited from where I used to work, when I was made redundant, so don’t have all the discs to reload XP, which I am sure is what it needs.
Any good at how cubase uses the registry settings to find a midi port?
Steve

I think the next step is this :

On your Yamaha S90XS press : UTILITY - MIDI - ENTER

SET MIDI IN/OUT = USB
SET LOCAL CONTROL = OFF

EXIT - EXIT

Check now if you can select the S90XS in your MIDI ports.

A good guide for setting up your Yamaha can be found here :

http://www.motifator.com/index.php/support/view/usb_midi_quick_setup_windows_xp_cubase_ai4_motif_xs_editor

And remember, when LOCAL CONTROL = OFF, nothing will play on your S90 when you press any keys. It will only work together with Cubase. If you want to work on your S90XS stand alone, then set LOCAL CONTROL - ON.

Let me know if this helped.

Right, this is what I did…

Turned on the laptop and completely logged in.
Connected the USB from the keyboard to the laptop, then powered on the keyboard (local control ON)
Heard the blink blonk acknowledging that it had seen it (no message so knew it had a driver)
Turned the local control on the keyboard to off, then opened up Cubase.
No change.

So I left the keyboard as it was, closed down Cubase and restarted the laptop.
Went back into Cubase, but still could only see the MS connection.

Incidentally, have you found a way of getting this blog to email you when there has been a new posting on a particular topic, or do you just have to keep looking?

I will read through the USB/midi Motif article to see if it gives any further clues

Steve

OK - think I might have found something, I guess you are using Windows XP, have you updated to SP3? If not, you need to.

Then reinstall your USB driver and try again. I work on Mac so I can’t tell you what should show up in your Audio settings, but I read in another forum that if you can’t see your Yamaha in Sound - Audio or MIDI devices , you have a driver problem, nothing to do with Cubase. (Could be that you need SP3).

There was a lengthy discussion about the same problem here :

http://www.motifator.com/index.php/forum/viewthread/458275/P0/

At the end it turned out, install SP3 for XP and problem gone.

For future reference : When you post a query on this forum, please provide details of your system (Operating System, sound card, drivers installed, software installed), it might help you to get more responses from experienced users on the forum. I’m assuming you S90XS is connected to your laptop by USB cable, i.e not MIDI cables.

Have a look at that post on Motivator.com and try this and let us know if that was the problem.

Good luck and hope you get it sorted out soon !

Good news, I now have full connectivity between the keyboard and laptop (Cubase).

In response, you will notice in my initial posting that I had Windows XP, 32 bit and that I was using the USB connection (as per subject). My Windows was already up-to-date, at version SP3.
My feeling has been that the solution lay in the registry settings, having been changed over the years by many pieces of software being loaded and removed (a general problem with Windows). But despite much investigation into the registry contents, I have failed to get to the bottom of this inability for Cubase to see the Yamaha driver.

So as a last resort, I have reformatted my drive and started again by reloading Windows, Cubase and the Yamaha drivers, before any further corruption, and hey presto it works. :smiley:
Now to get into learning how this great keyboard can work with Cubase.

Many thanks to M Fox, for his help in trying to resolve this problem - if only I had an Apple, as I am sure this implementation would be more robust
Steve