Yet another divisi condensing question

In a segment of a piece where one section is divided into a solo instrument and two tutti parts, I want to be able to write both tutti parts, which are in rhythmic unison for several bars, on one stave labelled “gli altri” and the soloist on its own stave labelled “solo”, as occurs elsewhere in the score. However, Dorico will:

a) not hide the player group name when condensing is active; the staves are therefore labelled “Vc. Solo” and “Vc. 1 / 2”
b) if I try to change the name of one or both divisi sections to something more sensible, such as “gli altri” or “altri div.” etc., this becomes a problem when the two sections later separate onto two staves;
c) if I try to hide the section indicators altogether, it also hides the one marked Solo, which is in fact very important to keep;
d) if there is a way to create a vertically justified “gli altri” label for just the bottom staff/bottom two staves of the instrumental section, it’s apparently not being recognised;
e) for that matter, if there is a way to hide staff labels altogether and just fake everything with text, that’s also not presenting itself (I suppose I could create some text items that are just big censor boxes ███, drag them over the staff labels, colour them white, and then drag some text items to cover them, but I haven’t tested this yet to see if it actually works because it seems quite silly).

Is there a solution here? i.e., other than the old Sibelius workaround of notating the conductor score as you want it to look without any concern for the software architecture, and then exporting the parts to new files in order to separate out condensed staves. Which I’m happy to do, but it seems odd for that to still be the best possible option.

The only thing I can suggest is turning off Staff Labels in Layout Options:

I’d definitely like to have staff labels turned on for the rest of the flow, however. (I’ve also identified the problem on a more granular level: normally the staff label appears between the two staves of a divisi, and this is what it’s set to do in the options; this time, although there are only two staves visible post-condensing, it’s appearing in front of each stave. I want it to use the default behaviour, and it isn’t.)