Your version of Kontakt is too old....

Whole error message reads:" Your version of Kontakt is too old to load this file. Please update to the current version"

We know when we SHOULD get this message, but I get it when trying to almost any of my Kontakt libraries in Cubase. I normally run Kontakt from VEpro so have not had this issue come up, but today I needed some VST instruments just to run in Cubase itself. Of course all my libraries run just fine in standalone Kontakt.

Cubase 10.5.20
Kontakt 6.2.2
MacOS Mojave 10.14.6

At this point in time all these apps are the most current ones available. Anyone know what I can do fix this?

Have you re-installed your Kontact files onto another drive eg D drive. In my case I installed all the new Kontact VSTs etc onto the D drive but the old ones were still being picked up by Cubase on the C drive

The solution was to do a COMPLETE uninstall of Kontakt as per NI’s instructions here:
https://support.native-instruments.com/hc/en-us/articles/210291865-How-to-Uninstall-Native-Instruments-Software-from-a-Mac-Computer

Re-install Kontakt and all is well.

Thanks for your help!