‘Zoom Full’ results in totally different results

I’m having the same issue, I believe. I definitely don’t have anything super far away in the arrangement.
You can see that ‘Zoom Full’ results in totally different results. The audio clip (which is only a short recording) ‘Zoom Full’ leads me to 2544 Bars total. But in the normal arrangement window ‘Zoom Full’ leads me to around 160 bars. Which is correct.

The 2544 bar in the editor window is incredibly annoying and I cannot find out why Cubase would zoom out to this level.
Anybody here who can shine some light on this?

In menu “project setup”:
decrease project duration

And/Or in the lowerzone menu set zoom to “clip based zoom”


Thanks Delta, that seemed to do the trick! Happy to hear it was just a setting I missed and not some unique bug on my end.