Zoom g5n driver problem

My driver somehow out of nowhere will not work.It the latest version that comes along with the Zoom g5n multi-effects pedal.I contacted zoom support and so far have just gotten a fresh download of the latest driver and that doesn’t work. I have elements10 and le ai 8 and it says “the audio hardware using this diver was removed from this computer” in each daw when i try to choose the g5n asio driver that it has been removed from the computer.It is in my computer apps list and the windows device manager as being there.Any help? After trying literally dozens of fixes i think it best that i contact support…So if you need for me to communicate further to find the problem, let me know…thanks…


Zoom drivers are very unstable. I would recommend to use ASIO4ALL instead.

Can i rename the exe.?I could still try to trick the computer like i had done a couple of times with advice from this forum.

I have a zoom l-20 LiveTrak and the driver is the most stable I’ve ever had. ASIO4ALL is not one I recommend except when there is no asio driver or its for onboard sound.

The driver worked and it’s on my computer so i would think that maybe it’s something with cubase warnings-xmls., preferences or with Windows10 Pro. I would like to have it back the way it was the last time i used it.


You could try to reinstall the driver (make sure you will install it as administrator) and also Cubase (also as an administrator). It might be, any Windows update made something corrupted.

What Martin said. It’s unbelievable but windows update messes with permissions for drivers, reinstalling is often the solution.

I got it working…the vst system link was stuck and by clicking reset over and over it finally reset and recognized the driver thanks.


Do you need to use VST System Link?

yes to choose an asio and interface but again it’s not working properly…plus I’ve been asking around other forums and they have suggestions but none of them have work…like changing permissions…running troubleshooter…going into device manager and unchecking “exclusive use”…quite a few…just out of nowhere it started misbehaving…some people think that the windows 10 pro update had something to do with it…if i could send a picture of the warning i would but it says the images is too large…all my other interfaces work…uca222 …yamaha ur22mk11 they both work…i really could use the g5n though.


I would recommend to deactivate VST System Link. This is useful, if you want to connect 2 computers with 2 Audio Devices and sync them. Is this what you need?

Read more about the VST System Link here, please.

One desktop windows 10 pro… three or four drivers for the daw. One driver for the zoom g5n effects pedal doesn’t work properly…

Could plugging into the 3.0 usb port on my desktop have anything to do with damaging the ability of the g5n pedal to work in the cubase daw?

Did you reinstall the ASIO driver as admin or not ?

Yes i did run it as administrator…It does not load up in abelton live either…i tried everything everybody tried in this and other forums…complete fresh install of cubase also…it seems to me that in the studio or devices panel where you can reset the inputs-outputs etc. , that it doesn’t reset properly. I’ve had this happen before and i kept clicking over and over until it reset. But not this time…
It simply says"the hardware using this selected asio driver has been removed from this computer". Yet windows settings says zoom g5n is setup in devices. If i knew where the studio or devices panel folder or file or xml. was i could delete it and let cubase reload it upon restart .


If even Ableton Live doesn’t see the driver, I would expect the problem somewhere on the system level, not in Cubase.

Here’s something…i tried it out on another computer in abelton live lite and it worked…that in theory means that it’s something between the original new computer and cubase and other daws…they somehow can recognize the zoom g5n pedal but the popup still shows up saying “audio hardware using selected asio driver has been removed from the computer”…but when looking in the computer device settings it’s there and “working properly”…in the cubase daw everything in the devices or studio pane shows the g5n there inputted and outputted (loaded up)but ivstill get that popup and there no sound no level indicators moving…


I don’t know how Zoom driver is working, but could it be possible to ask the vendor, if there is written something in the Registry? Then I would recommend to uninstall the driver, clean the Registry (and everything), to make sure the computer is completely Zoom driver free. And then try to install it back.

I’m communicating with zoom on gmail for days now trying things…no luck…if i could locate in windows 10 file explorer where that “audio hardware has been removed from computer” is i could delete the folder or file or rename it with an x or something and have cubase re-create it upon reload…

I did that and it’s still the same. It’s a three step thing.delete the driver from windows settings-apps. Then go to the windows file explorer and delete download files. Then go to users -app data-roaming and delete then users-app data-local and delete those. Then finally go to the registry and find three different places there and delete anythi g zoom. It’s all on instructions i found on the internet.