Zoom in -> high CPU usage = audio drops

In Wave Window the more I zoom in (while playback) the dramatically higher CPU usage I get (starting with zoom factor cca 1:700) which leads to audible drops.
In WL 6 zooming has almost no impact on CPU usage at all…

The more display refreshing, the more CPU is spent redrawing. If you need that you need a fast machine, at least 2 core (4 is better).

My machine is fast enough (see my signature).
The display is not refreshing AT ALL meaning the waveform is static (=not moving) and only playback cursor is moving.
There must be something wrong within the program itself.

Then I have no clue. Maybe try to gather more information about when this problem occurs.

Well I did some experiments however the only hint I can give is that the problem must be caused by the Playback cursor itself.

I noticed that if in full view (e.g. the whole waveform is visible) I get already 20-30% CPU utilization while playback.
Now if I zoom in a bit (1:600) I get more than 50% CPU utilization causing audible dropouts already.
F activated e.g. “View follows cursor mode” is on meaning waveform is static and only playback cursor is moving.
NOW if I disable this and once playback cursor leaves the screen, CPU utilization immediately drops down to 00-01% CPU utilization! Activating F again (e.g. making playback cursor movement visible but keeping waveform still static) I get high CPU load again.

I don’t know how more deeply I could describe this issue but I am open to any experiments / tests you would suggest.
Let me accent that this issue simply prevents me from doing any serious work in WL 7…

Here on a 1920x1200 displays, the CPU used in the context you describe (cursor moving, waveform static), takes between 1 and 2 % of the bandwidth. For a 2.8GH processor, though.
What you describe is not normal, I think your graphic card must allocate too much bandwidth on your PCI bus, and the audio device suffers from this. Well, it’s a guess, but this is a performance issue of your hardware somehow, or a bad driver.

Well then how would you explain that in WL 6 (on the very same system) I do not suffer from these high loads at all and I get also 1-2% CPU load as you do with WL 7??
I will try to do some more testing…

Hi. I had a similar (ish) problem…
Playback fine C5 & WL6
Gaps in playback, using WL7 that seemed to be related to mouse movement.
Problem only happened when using my Motu sound device (playback via onboard soundcard was fine).

In the end, it turned out that the drivers for my video card were to blame
(though same drivers worked fine in WL6 !!)

http://www.cubase.net/phpbb2/viewtopic.php?t=140769

No playback problems have happened here since I installed those drivers.

(not the same videocard that you have in your sig … but worth a shot if you haven’t already tried different
video drivers.)

Did some more testing.

I tried to install the latest NVIDIA driver 260.99 (clean install, all setting to default).
I tried running my system as single-display only.
I tried both also in my XP partition (I use multi-boot solution on the same HW).

All in all no change hence IMHO it must be the playback cursor in WL 7.

In Win7 x64 when running WL 6 I get 00% CPU load while playback in full view, zooming in it’s about 01%, with ratio 1:16 I get about 02%, with 1:2 I get 10% and with 1:1 I get about 20% CPU load (22% maximum).

Now running WL 7 in full view I get about 13% CPU load (08% minimum, 40% peak), with ratio 1:1300 already I get about 25% (20% minimum , 49% peak), ratio 1: 650 I get about 42% (34% minimum, 49% peak) and getting worse.
49% CPU load means fully loaded 1 core of my dual-core processor.
Whenever I disable follow mode (F key) and the playback cursor “leaves” the screen, CPU load immediately drops down to about 10% CPU load.

The behaviour of WL 7 on the same HW with the same file (and different OS too) is SO different to WL 6 that the only cause I can think of must be within WL 7 program itself.

WaveLab 7 and 6 are different programs. To reduce cursor flickering, especially under Win7, WaveLab 7 does some more graphic memory transfers (more than WaveLab 6). The more you zoom, the more you get that (higher refresh rate). This being said, with a sane graphic system, this should never eat the bandwidth used for audio transfer. But this is what you observe on your system. Maybe increasing the audio latency could help.
Even with a CPU utilization of 100%, the audio should be fine on a dual-core system.

Hm so you mean that this high CPU load I experience is normal??

My graphic card is NVIDIA GeForce 7950 GT with 512 MB DDR3 RAM which is way enough even for decent 3D gaming so why is it not enough for WL 7??

But this is what you observe on your system. Maybe increasing the audio latency could help.

My Delta 24/96 is set to ASIO 512 samples which gives me at 44,1 kHz both input & output latency 13 ms. In Cubase 5.5.2 I can run projects with many WAVs, VST instruments & plugins and effects = all in realtime with no dropouts at all.
Now in WL 7 I am unable to reliably play even one simple WAV with no effects at all - only because I slightly zoom in - this is insane…
The only thing that helps a bit (temporarily) is indeed to increase ASIO buffer but this cannot be the solution!

Even with a CPU utilization of 100%, the audio should be fine on a dual-core system.

In my case it is not - as I wrote once CPU load gets near to 50% (e.g. 1 fully loaded core) I get audible dropouts (BTW WL 7 never gets higher than 50% from what I see in Task Bar when no effect is used).


Am I really the only one observing this strange behaviour?

Your graphic card in itself is capable (computing power), but memory transfer from the computer memory to the graphic card, is certainly the bottle neck. But I am not an expert in that.

Hm this is weird - I am running my HW setup for 4 years now with no performance issues at all.
My memory is 8 GB DDR 2 (4x 2 GB in 4 slots) with timing 4-4-4-12.

How big is your display? (the more surface…)
And are you using 32 bit colors? (you should).

My primary display is 21" Sun Microsystems GDM-5410 (Sony Trinitron) running 1600x1200 in 32 bit colors.
I tried to reduce the resolution and indeed the lower it gets the lower is the CPU load…

Again I must repeat that in WL 6 no problems of such type at all. I know you said that WL 7 is a different program however I cannot help myself but wandering what dramatic changes were made there compared to WL 6? Personally I was satisfied with the way WL 6 showed playback cursor and I am unable to observe any improvements of it in WL 7 - it only causes me troubles.

I am unable to check the status of this bug in 7.1 because I got (much) faster system meanwhile.
Has any change / fix been done?