Zoom lag is affected by ASIO load

-In a huge session, I noticed that the zoom is terribly slow and the UI lags and local video playback doesn’t work. It’s so bad I need to pare down some tracks. I guess this is to be expected, but I noticed that by switching to “No Driver”, effectively disabling the audio system, the program much more responsive now. It is still using 25% CPU at idle :open_mouth: . Also, toggling the visibility on 1000 tracks sometimes takes 5-10 seconds to take effect, but disabling ASIO helps this as well.

Is there any way to accomplish one of the following:

-Speed up the slow notched approach to zooming with the G and H keys.
-Make the UI more responsive under load? Is the laggy performance this just a symptom of CB trying to prioritize playback over the responsiveness of the UI?

Another observation:

In this session with ASIO disabled, deleting a track is quite slow, between 3-5 seconds unresponsive. Track selection takes about 1 second.

Have you ruled out corrupt prefs?

Are you actually on Cubase 8.5?

no 9.5.2 sorry