Zoom/Scroll and Selection Lag

I gave this a few days to see if anybody else reported the same thing, but I’ve seen no mention of this so far. Basically, Dorico is lagging when I zoom, scroll. change the selection of elements (i.e. when I click on something, or enter/exit Note Input mode.

I’d do one full scroll of the mouse wheel, Dorico will scroll with it, pause, and “undo” part of the scroll, bringing the screen slightly back the direction it cam from. This will happen with the SCROLL, SHIFT+SCROLL, and CTRL+SCROLL (zoom).

And it does something similar with selections. I’ll un/select something, and it’ll do the correct action, then reverse itself. Sometimes it’ll still be selected, but not show it; or vise-versa. Additionally, I’ve noticed when I exit Note Input mode, it exits, but then it shows the graphics (carat, ghost note of cursor, et cetera) as if I was still in Note Input mode, but then when I click, it goes away.

I thought maybe it was due to the large project I was working one, but I’m experiencing the same thing in my minute-long piano fugue.

Anybody experiencing this?

No, sorry. Is it exactly the same lag for both or just not quite as bad on the small one but still bad? If so, can you attach the small project?

I believe it is the same lag for both—and the lag varies.

Interestingly, though, I just attempted to recreate the issue with my laptop in “laptop mode” (I usually have it docked to an exterior monitor) and I can’t seem to recreate it now.

I’m wondering if my laptop is, like, working extra hard when it’s docked or something and Dorico suffers? I guess I’ll have to look into it more and experiment a bit.

That’s definitely a possibility. Are you on Windows or macOS? If you’re on Windows, watch out in particular for your power-saving settings. When working on large projects, Dorico would definitely benefit from being run with the highest performance power settings available on your system.

Hey Daniel,

Thank you for your input. Unfortunately, I just tried to adjust the power settings in two different ways (see attached photos), but to no avail.

I’m going to start adjusting my laptop (turned desktop) set-up and see if there’s a hardware issue somewhere.

It’s just strange, though, because I’m not having this issue when opening the same project in Dorico 4.

Screenshot 2024-01-12 113732


The issue stems from my laptop’s connection to my monitor.

Whenever my laptop is using the monitor as its (only) screen, the issue occurs. I’ve tried my VGA to HDMI cable connecting the monitor to the laptop directly, and I have tried my VGA to DisplayPort cable connecting the monitor to the dock which is connected to my laptop. With both setups, the issue occurs UNLESS the laptop “clamshell” is open. If I have the laptop open so that I can see two (duplicate) screens at once, then there is no issue. (Of course, that is not a solution, but a it is a lead.)

I suppose I can get a new monitor—one with an HDMI port to avoid the conversion cables—but I feel like there might be another solution.

It also still doesn’t explain why Dorico 4 didn’t have this problem.
Any thoughts?

Dorico 4 and Dorico 5 drive the display in different ways, due to changes in the underlying Qt framework on which Dorico depends; Dorico 4 uses Qt 5, which is essentially using OpenGL redirected through Direct3D, by way of an intermediate API called Angle; Dorico 5 uses Qt 6, which uses Direct3D more directly, through a Qt-specific set of technologies called RHI (Rendering Hardware Interface). This makes higher demands on your system’s GPU, and certain older or less powerful GPUs may have worse performance under RHI than under Angle.

We need to keep up with the latest Qt API changes in order to benefit from new features in the framework, better operating system compatibility, and so on, so over time Dorico’s dependence on GPU features will likely only increase.

Great to know, thanks! Do you think the GPU in a 2018 MacBook Pro would be an “older” one?

Completely understandably.

Thank you for all the info, Daniel!
I’ll try to make some adjustments and upgrades to my set-up to keep up with Dorico’s upgrades!

I believe the 2018 MacBook Pro has both an integrated Intel GPU and a discrete Radeon GPU. Even if the Intel GPU is a bit weak, I would expect the Radeon GPU to be up to the task. I can’t guarantee it, however, since all of this stuff is happening at a lower level than the Dorico application itself, so it’s not directly within our control.

Unfortunately, I have not had any luck in finding a solution to this issue. I’ve troubleshooted the heck out of this, but can’t find a fix.
I will provide more information I discovered in case someone else finds they are having a similar issue; or in the hopes that a tech guru comes across this and might be able to help.

The display lag creates an issues suck as [I scroll to a place and click something to select it, but where I clicked isn’t actually where I thought it was because the screen adjusts a half-inch and shows that I actually clicked on something else].

I honestly believe this stems from the connection between my laptop and an external monitor. Trying different connections and different laptops and monitors, I found…

  • The issue still occurs if I connect my laptop to the docking station, then connect the docking station to the monitor with a DVI-to-DisplayPort adapter.
  • The issue still occurs when I connect my laptop to a different monitor with the DVI-to-HDMI adapter.
  • The issue still occurs when I connect my laptop to a different monitor with a straight HDMI cable.
  • The issue does NOT occur when my laptop lid is open and the screens are duplicated. (Every previous occurrence has been when my laptop lid was closed.)
  • The issue still occurs when my laptop lid is open, the screens are extended (NOT duplicated), and Dorico is on the monitor.
  • The issue does NOT occur when my laptop lid is open, the screens are extended (NOT duplicated), and Dorico is on the laptop.
  • The issue does NOT occur on a different laptop using the same monitor and cable as mentioned before.

The specs of my laptop (below), as far as I can tell, surpass the recommended specs for Dorico 5.

This issue happens even on a new, blank piano project.

I am not having this issue on any other program—not Dorico 4, Musescore 3, Civilization 6, nor Overwatch 2.

I know, at this point, it’s a long shot and there’s probably some setting I am missing on my laptop that’s messing with the connection, but I’m hoping a solution can be found soon.

Specs Below


  • Lenovo ThinkPad P15 Gen 2
  • System Model: 20YQ003AUS
  • Processor: 11th Gen Intel(R) Core™ i7-11850H @ 2.50GHz 2.50 GHz
  • Installed RAM: 32.0 GB (31.7 GB usable)
  • System type: 64-bit operating system, x64-based processor
  • Windows 11 Pro
  • Graphics Card: NVIDIA RTX A2000 Laptop GPU Integrated RAMDAC


  • Acer G276HL1920 x 1080, 60Hz8-Bit bit depth


  • CPU: Intel i5 or faster
  • RAM: 16GB
  • Hard Disk Free Space: 12 GB (I have 165 GB free)

A thought. Have you considered your mouse might be the problem? (I mention it because I have mouse with a dodgy scroll wheel!)

I hadn’t considered that, but when I was troubleshooting on other monitors, I was using a different mouse and still experiencing the same issues.

Not to mention that the issue is more than just zooming and scrolling:
I would be in Note Input Mode, then hit Enter to exit Note Input Mode, but the carat, orange beat lines, and the gray note on the cursor will remain—the cursor note will be frozen in place while I can still move the mouse around—until another computer input occurs (like a mouse click) and then all that stuff disappears as it should have when I hit “Enter.”
It’s as if the display is one input behind.

I figured it out!

For anybody who might experience this issue in the future:

In the NVIDIA control panel, under “Manage 3D Settings”, there is a setting called Image Scaling. My laptop has this setting turned off, but when I turned it on specifically for Dorico, I am no longer experiencing this issue.

I turned Image Scaling back off and the issue came back, then I turned it on and the issue was gone again.

I’ll get back to my normal Dorico use and see if maybe the issue comes back later, but for now, consider this issue resolved!