Zoom while locating in time scale can't be turned off

Just upgraded to Cubase 8. I’ve always worked in Cubase with the “Zoom while locating in time scale” option turned off, simply because I think that function is annoying. I prefer zooming with key commands instead. Now, in Cubase 8.05 (Mac) it appears that this function can’t be turned off. The checkbox is unticked under Preferences -> Transport, but the zoom is still on. Any suggestions?

Apparently it’s been confirmed as a bug already… but wasn’t fixed in the 8.05 update :imp:
http://www.steinberg.net/forums/viewtopic.php?f=231&t=70679

It annoys me bigtime every time Steinberg all of a sudden messes up simple functions and workflow critical settings in Cubase, that have been there for years. This is not the first time.