[10.0.60 - not valid anymore] Enable Track: Mute button color not restored (and Solo button colors restore deceptively)

If you Mute a track, then Disable the track, then Enable the track again, the Mute button is not yellow anymore so you have no visual indication to why you get not sound out of the track.

So it does restore the mute status, but gives no visual indication of that.

Repro:

  1. Create an Instrument track, assign an instrument and some random midi notes.
  2. Mute the track
  3. Disable the track
  4. Enable the track

Expected result:

  • No sound (muted track).
  • Mute button should be yellow again to indicate the track is muted.

Result:

  • No sound (muted track) (OK).
  • Mute button is NOT yellow, so you can’t see that the track is muted (ERROR).
    You need to manually press the mute button again to get correct color indication.

UPDATE:
I also tested the Solo button:
Disable track -> Enable track ===> the opposite problem: the button colors restore, but the Solo mode in reality does not.
The track is instead quiet. It then takes 2 manual button clicks on the Mute button to restore to normal behaviour.

System:
Windows 10 (1909), Cubase 10.0.60. Somebody that can test in 10.5.20?

Hi,

This is a known issue on Cubase 10.0.x. Since Cubase 10.5.10, disable tracks are excluded from mute/solo.

Ok! I did a search before but didn’t find anything about it.

Thanks for info Martin!