10.5, Mojave required...

… does that mean the installer will not install on older OS? Or does it install and run but with no support?

I have the same question.
My Mac Mini is stuck on OSX 10.13, I plan to get a new music computer soon, but I’d also like to use Cubase 10.5 in the meantime…

Where do you see that Mojave is required? That can’t possibly be right. I see a mention of Mojave, but I think that’s just intended to mean Catalina is not supported.

https://new.steinberg.net/cubase/?_sp=fce9ce61-1351-421d-bb46-8e841a99d2c6.1570190347208

Scroll down, click ”Buy now”, read’n’weep.

Well, I bought and downloaded it immediately with out checking anything… :confused:
I’m on Hight Sierra 10.13.6. I just installed it, without any issues what so ever. :wink:

Thanx, Henry1970, that’s good news.
I bought SpectraLayers but the installer refused to install because of my outdated OS. Running Cubase Pro 10 without problems, though.
Oh well, new Mac coming in a couple of weeks.

I just installed 10.5 on 10.12.6 and no issues so far…

Great to know, I will upgrade very soon.
Thank You for the reports.

Here also, I’m on High Sierra and Cubase Pro 10.5 runs smoothly.
Oowww what a great release, by the way!

…then you have Catalina to deal with

You cannot work with some plugins in high Sierra for 10.5. Especially like waves. Some waves plugins will show blank gui, some opens with gui on first time, when you close and open it will also show blank gui. And some times it crashes suddenly while loading some plugins. But waves support high Sierra 10.13.6. Steinberg support team simply said because of high Sierra, 10.5 is only for mojave. Otherwise all will be fine.

“You cannot work with some plugins in high Sierra for 10.5. Especially like waves. Some waves plugins will show blank gui, some opens with gui on first time, when you close and open it will also show blank gui. And some times it crashes suddenly while loading some plugins. But waves support high Sierra 10.13.6. Steinberg support team simply said because of high Sierra, 10.5 is only for mojave. Otherwise all will be fine.”


Sorry, I don’t understand this reply. Above.

Are you saying Cubase 10.5 has this problem, but Cubase 10.0 does not have this problem?

Cubase 10.5 requires macOS Mojave 10.14 or higher to work properly. It will install on macOS 10.12/10.13 though, but the problems that might arise will be most likely graphics-related and no support will be provided under that combination.

Ah ok, no difference to the normal customer service then…

Had my first crash to desktop, while deleting a workspace in the organize workspace window.
Still on High Sierra, so reporting this issue has no use I guess?? (Time to update to Mojave then!!)

Just purchased and installed - installer didn’t halt on installation like SpectraLayer’s did because of a to old OS (10.11.6 El Capitan). Hooray!
Tried to start the program, was met by an alert saying the program needs 10.12 or later. Damn!

The latest adoption numbers I’ve seen show MacOS 10.14 (Mojave) is only used by about 40% of Mac users. Almost nobody using a Mac for music is running MacOS 10.15 (Catalina).

Will someone kindly point me to the first Steinberg link that stipulates 10.5 will run only on Mojave or Catalina…TIA
I’m wondering how i missed this information…?? Perhaps Felipe Garcia will chime in…

Maybe i didn’t miss it…??

Yes, exactly. And waves support high Sierra as well.