4.1 Bug reporting (changed title to avoid confusion)

Constantly losing the “Link” in the piano editor every time one zooms in or out. Basically “linked” can only be used at the one zoom the devs decided was good enough. Personally I rather work at maximum zoom (for details) and just click on the notes in the score to quickly navigate between areas.

Hope to see these, otherwise I feel Dorico 4 is still a step back from 3.5.

1 Like

Nice to see bug no. 1 is fixed! Unfortunately, no. 2 is still present. I’ll also add the one in my original review back in March:

  1. The mouse wheel scroll (CTRL+MW) refuses to go any further than this:

  2. When zooming in too much, you often just get a black screen and completely lose your place:

  3. Mouse scroll on the piano roll is too sensitive and jumps too much.

  4. Also, this is not very useful information:

    Twice I’ve input CC in the wrong instrument, because the “Link” keeps getting disabled (as in the 2nd bug in the first post). It would be helpful that somewhere in the editor, anywhere, we could see what instrument we are actually editing.


Another vote for these fixes

  1. I’m also getting that black screen when zooming in and out, I thought it was just me.
  2. Also the scroll sensitivity is too high for me.
  3. Losing the locked notes when zooming in and out has been an issue.

And another bug, trying to work on the CC11 on several instruments, closing and opening the lower piano roll panel. Every so often the editor reverts to velocity! Despite only working on CC11…

And yet another bug… Occasionally, when selecting CCs with “linked” on, the editor will jump to the beginning of the Flow.

Hi - I also raised these types issues with zooming, scrolling and blank areas of UI in the Key Editor, previously here:-
Elements 4.1 - Key Editor; 1st play impressions - Dorico - Steinberg Forums

Daniel indicated by his response there, they are aware and improvements will come in the next update.! :slight_smile:

1 Like

Thanks for the heads-up, more waiting I suppose… One day we’ll have the software of our dreams, just hope it’s in my lifetime!

Although I understand that it annoys you that the link button in the Key Editor toolbar is deactivated when you scroll or zoom, I just want to clarify that the current behaviour is as designed, and not a bug. However, we have heard the feedback on this loud and clear, and we have plans to rework this as part of the forthcoming set of improvements once the percussion and pitch bend editors are complete.

We also plan to make it possible to change which instrument you’re working on directly in the Key Editor, and to maintain which editor is shown when you change the target instrument (indeed we are planning to make it possible to stack multiple editors of different types below the piano roll, and maintain them as you switch between instruments, so you will be able to, say, show the velocity editor plus MIDI CC editors for controller 1 and controller 11, or whatever).

I know it’s frustrating to wait for these improvements. We are going as quickly as we can with this work, and you can rest assured that we are going to keep delivering updates that provide meaningful improvements to the Key Editor. Please stay tuned.


Always nice to know you are reading these (although I know you do), but please note the difference between what we think are bugs and what are just horrible design decisions e.g. the black screen on zooming and the editor jumping to the beginning of the flow, etc are definitely bugs.

Yes, of course I agree that things like being able to scroll sufficiently far in the piano roll such that no keys are available any longer are certainly bugs, and we will of course do our best to address them too.


Another bug: The new Tempo track cannot be set below 5, which is a must for things like fermatas and caesuras. Also, Spacebar and Enter get hijacked by the value boxes i.e. if you press Enter either on Value or Range max, playback begins and cannot be stopped except with the transport Stop.

1 Like

Minor bug, Dorico becomes stuck in certain zoom positions and it’s not possible to scroll.

Notice above how the horizontal scroll bar is at the end, but Dorico isn’t. In fact the bars go up to 96.

Try setting a hidden tempo marking to thirty-second note equals mm 5, and I am sure it will be long enough for whatever.

Also, Spacebar and Enter get hijacked by the value boxes i.e. if you press Enter either on Value or Range max, playback begins and cannot be stopped except with the transport Stop.

I can’t reproduce this: when I press Space or Return in the Range max. spin control, nothing happens: playback doesn’t start.

Thanks to you I discovered I can also just put the marking crotchet=1. The playback respects it, although in the Tempo editor still shows up as 5.

My bad, I tend to use the Enter on the NUMPAD, I’ll remove it from key commands.

An old bug has reappeared, when creating a new voice, playback for unrelated instruments is messed up. In this particular case I have a project with 6 instruments and multiple voices each. I create a new voice on instrument 1 (downstem voice 1) and upstem voice 1 for instrument 6 goes silent. If I fiddle with the velocities of the latter, suddenly it all pops back up. Even after removing the offending new voice, the issue persists…

Sorry, Claude, I can’t quite see what your video is showing. It looks like you’re selecting a note, then opening the Key Editor, switching to the Velocity editor, then dragging the velocity for the selected note (which appears to be zero for some reason), and when you stop dragging, the velocity editor updates to show the velocities for a different voice. Is that about right?

If you could please provide the project that would allow me to reproduce this, with the steps to follow, we will of course look into this. You can email it to me at d dot spreadbury at steinberg dot de. Thanks!

That is correct! The note/notes are not set at 0, but for some reason, as described above, they change to 0 after fiddling with a completely different instrument. If I then do what I did in the video, suddenly they all pop back up. The project I’m working on is huge. I tried separating the specific flow to a different project to send to you, but then I can’t replicate the bug.

This has something to do with me adding a new voice on the first instrument. Even after removing the new voice (which still appears in Play mode), turning off IVR, saving, closing the project, reopening and enabling IVR once more (with the new deleted voice completely gone from the Play window), the playback bug persists.