4.3: odd failures to load VSTs for playback in existing project

Since updating to 4.3, in an existing orchestral project using the BBC SO Pro template plus a mix of Kontakt players (using the old Spitfire Percussion library), the playback engine never seems to get to a point where it actually allows playing, and the instruments never finish loading in. That is: the play button never goes green, and clicking the Show VST Instrumentbutton never

Things I have tried:

  • Turning off playback and turning it on.
  • Just… waiting. I’ve given them up to 10 minutes, far longer than the ~2–4 minutes it sometimes took on 4.2.
  • Applying the silence playback template and then reapplying the BBC SO Pro template.
  • Even just applying the silence template and leaving it there—never gets to the point where the play button is enabled (obviously it wouldn’t be useful, but it’s notable as an oddity).

I have also checked for anything odd in Preferences > Playback, but all of that looks normal and unchanged. I have also gone so far as to fully reset the audio engine settings under Preferences > VST Plug-ins, to no avail. However, attempting to even open the Preferences > VST Plug-ins with this project loaded causes Dorico to hang. (A number of other operations have also caused Dorico to simply hang, but this was the only one I could consistently reproduce.) I followed that up with the usual dance of Force Quitting the VST Audio Engine, and trying these steps again; the only way I managed to get to do the reset was by doing it without the project open at all.

One other data point: the VST Audio Engine RAM usage per Activity Monitor for this project is substantially higher than it was under Dorico 4.2. For this project under Dorico 4.2, it topped out around 45GB RAM; on 4.3 it’s taking about 55GB RAM. :exploding_head: (I don’t think this is likely relevant, but at this point I’m also extremely stumped.)

When I create a new orchestral project and apply the BBC SO Pro template to it, things work fine after a bit.[1]

Any other things I should try? Can I… revert to Dorico 4.2 somehow? I’ve spent the last 90 minutes on this and thereby burned most of the time I had available for composing this week. :disappointed:

  1. There is another, apparently unrelated, oddity with that where the template loading the wrong instruments, but I am for the moment chalking it up to user error. ↩︎

Poking around at other issue reports on the forum, this summary looks like the same behavior I’m seeing (though the original report was of different issues):

I’m deeply sympathetic to the follow-on note there:

I’m very much at a loss at the moment, though—I suppose maybe I can try to recreate the project from scratch, adding in each of the flows, and copying and pasting over the materials?

You can certainly download Dorico 4.2 and try that version again:

The previous installers are listed at the bottom of the page.

1 Like

Ah, I had no idea that page existed. Thank you!

Can 4.2 and 4.3 live side by side the way 3.5 and 4.x can? Or is that something that only works for major versions?

Yes, they can live side-by-side. On Windows you need to rename the existing Dorico4 folder in C:\Program Files\Steinberg before you install the new version. On Mac you can rename the existing Dorico 4 application package before you install the new version.

1 Like

All right, with 4.2 installed and trying to load the project, I can now confirm this is not a 4.3 problem, and indeed it must be a my-project problem. Somehow this project worked fine in 4.2 two weeks ago but is failing to load in 4.2 today, in exactly the same way that it was failing to in 4.3. That’s good news for you all and terrible news for me!

(To be fair, once I have it fixed it’ll be good news for me because I’ll be able to use the new goodies in 4.3; it looks and feels substantially better in the playback area, which I’ve had lots of time to poke at while not being able to do any meaningful composing work in the last two hours.)

I will report back if I can isolate the issue, so that it can perhaps be useful to someone else. Thanks, as always, for the help—especially at nearly midnight on a Saturday! Goodness!

If you start with an empty project and rename your BBCSO Template, I think you should be able to load the project using the Default template, as it will think the required template is unavailable. That might allow you to recover your work…?

1 Like

Good suggestion; I’ll give that a try.

This was utterly bizarre: I had a chance to come back to this today, and I started by renaming the template (created a new project, renamed the template, closed the project without evening bothering to save it) and then opened the score I was working on… and everything just worked as before, using the renamed template and loading up in a matter of < 1 minute, RAM usage for the VST Audio Engine topping out at ~43GB instead of 55GB, etc.—just as I was used to before. :man_shrugging:

If anyone else happens to have this issue, I suppose one thing to try is to follow the same procedure. I’m baffled as to why this “fixed” it but I will content myself with it working and move on.

Annoyingly, today being the next time I had a chance to open this project, it failed again. One thing I’m considering is: applying the BBC SO Core template, and only pulling in the Pro samples for the couple instruments that Core doesn’t have. If that doesn’t work, I don’t know what I’ll try next, so if folks have other debugging tips—especially for big orchestra samples for big orchestra projeccts—I’d be very much all ears.

I managed to get things working by:

  • deleting the Core and Pro templates entirely (at which point the playback was obviously janky, but the engine was no longer getting stuck loading the instruments)
  • converting to use the HSSE template instead
  • saving in that state so I don’t lose my mind with this again :joy:
  • creating a new copy
  • re-importing the BBCSO Core and Pro templates
  • applying the Core template
  • hand-picking a couple of the Pro instruments to use where appropriate

As a bonus: the VST load with this config is around 16GB RAM instead of 43GB (BBSSO Pro is very heavy!), which makes it load and interact much faster.

Here’s hoping I’m done with this particular saga, whatever caused it.