8.5.10: "Dedicated video output device stopped working"

Anyone else getting this error after 8.5.10? Happens when I have my Blackmagic Intensity Pro selected as the video output device: https://dl.dropboxusercontent.com/u/8520185/c8.5.10_blackmagic.png

Completely random, cannot reproduce reliably, as sometimes it does work. But this happens like 70% of the time Cubase is trying to initialize the video engine here, and then you just have to restart Cubase and hope for the best. Never happened on previous versions.

Same here. Just updated to 8.5.1 and videoplay now disabled with the exact same warning as you.

Also have Blackmagic Intensity Pro.

System:

Windows 8.1 • i7 4770K • Asus Maximus Hero VI mobo • RME UFX • 16GB Corsair DDR3 Ram • Blackmagic Intensity Pro • UAD Octo PCIe.

Updated all drivers / softare for Windows, Steinberg, Blackmagic, RME, UAD, etc. Problem persists. And like you said, it does occasionally work - but I’m getting the warning / disabled video about 9 times out of 10.

This is no doubt a total “you’re banned from contacting tech support for life” move, but I copied “C:\Program Files\Steinberg\Cubase 8\Components\videooutput.exe” over “C:\Program Files\Steinberg\Cubase 8.5\Components\videooutput.exe” and it works now.

There’s a slim chance that this doesn’t actually break anything as the video processes are separate from the main application…

Not sure if it’s related (I will create a separate thread) but my 8.5.10 version issues a video service related warning on startup. I did not have this warning with the original 8.5.

Yes, got the same bug.
Exactly the same message:
videoerror.PNG
Happened on first boot of 8.5.1.

And you’re right. It’s random. Usually but not always.
Which in my opinion is better than always.

Is your videooutput.exe from 8.0 fix working consistently?

Hugh

So far no problems. I don’t know if there’s any inter-process communication going with the video service. If not, probably no issues will ever come of it. But even in the worst case scenario of there being some, and an edge case being met where the version mismatch causes problems (e.g. the other processes expect behavior that the old version doesn’t match) that I haven’t been able to produce, at best I think it’s going to result in a video service crash, which still doesn’t crash Cubase itself. So I’m pretty confident about going forward with this unless Steinberg specifically says otherwise.

My issue seems to have fixed itself.

After being intermittent it now boots fine every time . . . so far.

Fingers crossed.

Hugh

Spoke too soon.

It’s out again. Won’t come back.

Maybe a few more boots?

This needs a solution.

Hugh

Same here.Also have Blackmagic Intensity Pro.

OSX 10.2

This appears to have fixed the issue for me, consistently:

https://www.steinberg.net/forums/viewtopic.php?f=226&t=89764#p519150

Hugh