A strange problem with rendering parts of a file

I have a long file open in the edit window. I want to process part of it with RX4. I render the part I want to and save the file. I then want to do another part of the file. I open RX4 but nothing works it is like the plugin is bypassed. OK so I try Sonnox or Fabfilter and the same thing happens. I can use it once and then it stops working when I want to use it again. The only way I can get this to work is to close the file and close WL and restart it. Suggestions are welcome. Thanks in advance! I am running WL 8.5.3 but it also did it in WL 8.5.2 both in 32 bit mode.

We are doing a very large restoration project and this is really slowing us down. I still have WL6 on my XP computer and it works “normally”. I can render a section of the file and then move on to the next selection and the plugins continue to work. Not sure what is going on.

Do you render via the Render dialog, or directly through the render button in the plugin command bar?

Plug in command bar!

I love this version of WL. Thanks sooooooooooo much for the GREAT work! Now if I can get a few glitches solved I am in heaven

Do you mean the problem comes from the Plug in command bar, or do you mean you did not know that button?

I use the “render” button on the master section. Sorry if I was unclear.

So no one else is having this problem? Still waiting for some help.

I can’t reproduce the problem using Master Section render, or plugin window Render in Place on normal files, but you say it’s a long file? How long and what sampling rate / bit depth ? And it’s a Wav file? Does it happen on normal 5 minute files at lower sampling rate?

And you re-save the long file after each fix?

Actually, using “process in place” in the render dialog, I see what you’re talking about, if “bypass master section on resulting audio file” is checked in the render dialog: No plugin meters or plugin processing on the next try.
(unless you manually re-enable the “play through master section” button on the audio file itself).

The bypass behavior was used in Wavelab 6 too, but the plugins still metered even if bypassed, due to the location of the bypass point I guess. And it was obvious they were bypassed from the big lit bypass buttons. It’s not as obvious that the Master Section plugins are bypassed after doing this in Wavelab 8.

Could that be what you’re seeing in Wavelab 8? Do you have “bypass master section on resulting audio file” checked in the render dialog?

Let me know what you mean by “long file” (10 min, 40 min etc.) and I’ll test this on my machine in the morning. I have RX4 and I’m using OS X.

The file is 62 minutes long. It is at 44.1 kHz sampling rate and 24 bits and a stereo file. Yes I have “bypass master section on resulting audio file” checked. I think bob99 might be on to something.I will check it this morning. Thanks for the help so far.

Ok. Just post here again if that doesn’t solve the problem and I can test this today.

This is one reason why I wish Wavelab had more of an offline Pro Tools/AudioSuite style spot editor. It would make restoration work so much easier because in Pro Tools, you don’t have to manage which AudioSuite plugins are active on playback/master section and which aren’t. You can be sure that the audio playback never passes through the AudioSuite plugin and only the section you select is processed, and you can have multiple plugins open and once and not think about which ones are bypassed.

Combine that with the Pro Tools playlists feature for reverting to original audio in spots if needed and that is still my preferred way to do restoration work…then I bring into Wavelab for sequencing and mastering specific duties.

I updated my RME software drivers yesterday and have not had a chance to try things out with the update. If this continues I may have to go back to WL 6 on my Windows XP partition.

I still think that WL is the best DAW for mastering and restoration work but this is starting to bug me big time since I have a ton of restoration work and so far WL is not working in a consistent manner.

I really have a lot of admiration for PG and software designers in general because they continue to turn out the best software and at the same time have to have it work on so many different systems. A real mind blower for me…

Oh well back to the restoration work and hopefully things will get better…

When the problem occurs, would you say nothing is rendered at all (no undo possible), or the same data as the source is copied (undo is possible, but does not change the audio)?

Nothing is changed in the file. I never had this problem with WL6. If I process a part of the file and then save the file everything is OK. When I try and process another part of the same file it will not process until I quit the file and reopen it. Then I can reprocess the next segment. I have to do thus over and over again.

Thanks for any help in this matter.

When this happens, if you remove all plugins, and just change the level (Master Section faders), does it work or not?
Nothing happens at all, or you see some progress of something?

I just started trying to reproduce this but this brings up a few questions I’ve always had:

1). When you press the “render in place” icon in the plugin menu, does it “crossfade at boundies” like you can choose when using the render dialogue?

2). I would expect the “render in place” command to only render that particular plugin but it seems to render all plugins in the global master section (unless they are bypassed). I guess that’s what the S solo button is for that I’ve never really noticed.

It would be nice to know what other settings/attributes are applied when using the quick “render in place” option. Is it the same as what your render dialogue box is set to?

I’ve been spot rendering a 41 minute, 24/48 WAV file with RX4 DeClicker and haven’t had anything strange happen. I’ve been using both "“render in place” and the render dialogue box. Saving often. Master fader locked at 0.0dB

To follow up:

I didn’t run into an issue when only editing small sections using “render in place” or the render dialogue box.

BUT, I did accidentally uncover a bug that could be related. The bug is that if you cancel a render while it’s rendering (whether it’s “whole file” or just a long section that takes enough time to be able to cancel the render), and then try to render a section after that cancelled render, the next attempted render (of any kind) does NOTHING. However, if you simply try again to render that section it worked for me, no restart needed.

Here’s a video to show what I mean:

Maybe it’s related to the bug that Thomas is having. I only found it by accident because I didn’t notice I had “whole file” selected in the render dialogue box so I cancelled the render, and when I went to render a smaller section after canceling, I noticed that issue of no processing.

Thomas, have you had a chance to try with “bypass master section on resulting audio file” turned off (“un-checked” in the render dialog)? That was the reason for the plugins being bypassed (no metering or processing) when moving to the next fix point, when I tried it here.

Then for real work, leave “bypass master section on resulting audio file” on, but turn the “play through master section” button (bottom right on the audio file) back on before each subsequent fix. That would be the closest to the “Wavelab 6” way of turning the plugins back on after each fix.

When doing some types of restoration work, I always keep “bypass master section on resulting audio file” checked because when looking for ticks and pops, I want to hear the natural audio (not through the inserted plugin). Then I spot render those small sections that need the RX4 processing.

Even when "bypass master section on resulting audio file is checked, and “play through master section” is disabled, doing the process in place (or render in place) does affect the file time after time other than the bug I posted the video about.

Again, another reason why I do most of this type of work in Pro Tools because AudioSuite makes all this so much less complicated, and playlists make it easy to get back to the source audio if you change your mind in any portion of the song/file.

I upgraded my RME software on Tuesday but did not get a chance to try it out until yesterday and everything seemed better. I got a lot of work done and I had just processed a long file (80+ minutes) and the render took six minutes and I was just getting ready to save the file when the computer went into its “studder” (fast playbak of a short section over and over again) routine and I got a blue screen and the computer restarted. Not fun!

I tried tried turning off the “bypass master section on resulting audio file” check box (it was on) and I still had the same problem with not being able to do a process, save the file and then do another process on another part of the same long file. It seems to be a problem with WL thinking that you have already done something to the file so it does not want you to do anything again. The only way I an get around this is to close the file I am working on and then reopen it and everything is back to normal. I never had this problem with WL6. Maybe some changes in the basic way WL is configured to handle working files in 8.5? I hope this can get sorted out and soon.