Acustica Audio plugins crashes cubase

So, the devs released 1.5 and then it worked? How is this supporting your argument?

irrelevant to my point. My point was, there are thousands of plugins that no longer work in Cubase because the developers didn’t bother to update their plugins from 32bit to 64bit. Tha’ts not Steinbergs fault, nor their responsibility. The benefit of 32bit vs 64bit is not the point.

Apple sucks, every time they release something everything is broken. It’s not an engineering platform and it’s a travesty it became popular with audio engineering. Again, you’re not negating my point with apple regardless of their development ethics.

Not really sure what you’re getting at here. These are all false equivalencies. HiDPI is resolutions pushed by consumer standards - Steinberg have adjusted to it. Not really sure what you’re getting at with ARA and Eucon.

I think i put enough arguments based on previous practice and experience.
The whole point is that someone has to get down and fix the issue.
The topic issue (hanging on exit) is steinberg’s fault and majority agrees on that. Fixing by devs ONLY because of cubase i see as generosity and total care from devs.
The fact that steinberg doesn’t like to get down and fix their issues (even new introduced ones) is well known by everyone who using cubase more than 5 years.
Thats it.

1 Like

Again, this has nothing, nothing to do with VST standards or SDK rules, be it VST2 or 3. Nada.

As I wrote, the problem with the Acustica plugins is that they use an old version of VSTGUI (a graphics and user interface library for VST written bei Steinberg) that has a known regarding DirectX bug that produces the hang-on-exit error in Cubase (and weirdly, only in Cubase). This bug was definetely Steinberg’s fault, and they fixed it years ago. Acustica can’t or won’t update and decide to go JUCE. This will most likely take months or years.

The question still remains why Cubase is so finicky about this when all other DAWs aren’t.

how does that not have to do with VST standards or the SDK rules? lmfao

Because it is an issue with the graphics library DirectX from Microsoft that is used by VSTGUI, the bug is in the graphi routines, see the code here, especially the newly added use()/unuse() methods: fix too early unload of the D2D libraries when multiple frame objects… · steinbergmedia/vstgui@55d14da · GitHub
VSTGUI is not the VST SDK. You can create VST Plugins without ever touching it.

1 Like

it’s an old issue… that is resolved by the latest VST SDK standard.

Are you saying that Steinberg needs to fix an old issue by making Acustica work on the broken previous SDK despite it already being patched in the more recent SDK?

Trust me, without Jbridge I’d be using Bitwig exclusively because of the constant crashing. Try Jbridge and do what i said in the last post.

Well problem solved for me in the latest AA updates. However new problem started. RIP and export audio causes the FREEZE (as I should specify, it’s not a crash) unless I deactivate and reactivate all my AA plugins in a newly opened project first. Weird. But a lesser evil compared to the original nightmare. If I’m the only user with this new problem then I guess I’m King S##tluck.

Hi,
Problem is solved for me since the last acustica update !!
Greaaaat !!

Thanks you

All that bashing/finger pointing on Steinberg.

I think @LoveGames nailed it a while back.

Ok, for those who haven’t already seen it:-
Major bug warning for Acustica Acqua users - Page 2 - Effects Forum - KVR Audio

1 Like

The advice to use JBridge and bridge the VST2 versions of the Acustica plug-ins worked beautifully! I was having the same problems mentioned in this thread – plus, when I tried to freeze any tracks that had Acustica Aqua plugins on them, Cubase would just crash or quit spontaneously. Using JBridge – which luckily, I already owned – solved ALL of those problems. It’s kind of ridiculous that I should have to resort to a workaround like this – the plugins shouldn’t need to be bridged to function properly, after all – but this solution really did the trick, so thanks for the advice!

Best

Alan

You need to update your Aqua Plugins,with the latest version of Cubase,works fine!!

Actually, I had been using all of the most current updates of the Acustica plug-ins, and that didn’t help at all. In fact, the newest updates only made things worse, and I had to roll back to earlier versions.

There’s a lot of finger-pointing going on about the cause of the problems, with Steinberg blaming Acustica, Acustica blaming Steinberg… All I know is that the only thing that solved my freezes, crashes on exit, inability to freeze tracks – all of this occurring only with Acustica plug-ins – was JBridging the VST2 versions.
Note to anyone who wants to do this: It has to be the VST2 versions since JBridge doesn’t work with VST3 plug-ins.

Best,

Alan

Hi guys I just stumbled upon this thread, since I had the same problem. After trying jBridge which somehow didn’t work for me ( no nebula gfx ) I put the 3 Nebula files (N4.dll, N4.ENG, N4.xml ) into its own folder in my VST-Folder ( in my case it was …VSTPlugins/N4/ ). Somehow Cubase didn’t crash after that. I hope I could help!
All the Best
Alex