After using Z for Zoom why do all tracks shrink?

After using Z to Zoom a track, why do all tracks shrink? Why not back to normal (for you) size? Is this intentional? Is there something I miss here?
Zero

Yeah I agree that this is a disruptive behavior.
If you press Z once to zoom the focused track all the other “shrink” to make the maximum room for all your tracks, so far so good.

The problem is when you press Z again on a track that is already zoomed, the track is de-zoomed and all the other tracks stay as is: this breaks your previous layout.

In therms of user experience:
The view should be restored to the original layout
OR Z should only used to do a Zoom and not to de-zoom (so to speak not a toggle shortcut that does undo-redo but just the redo part).
And yes… I know that there might be users that user Zx2 times to fit their tracks to the minimum, but this is a side effect and not what the zoom is for, a dedicated shortcut (only devoted to do THAT operation) should be provided instead if ncessary.

@Martin.Jirsak (calling you in cause I know you love these topics :smiley: and of course in the sole interest to make the experience more enjoyable and more logic) .

1 Like

Could you please tag this post as feature-request and/or issue pls so that developers can look into it and decide if to listen to us or not :D?

What do you have Z assigned to?

Edit > Zoom > Zoom Selected Tracks (Z) -> I think it should be the default shortcut

(as the command name says one would expect to zoom only and not “hey if you run it again on a zoomed track we are going to shrink vertically all the tracks”)

Interesting and weird.

The menu command you refer to is displayed in the Key Commands dialog as Zoom Tracks Exclusive. I know that command, and want never to use it. But what you describe it doing is what it’s meant to do.

So it’s a typo, or it’s a bug if the wrong command it attached to the menu item, but I don’t know which command, since Zoom In Tracks does zoom the selected track.

Check out Enlarge Selected Track. I think it’s more in line with your expectations. A great way to learn what’s available is by reading the list of Key Commands. There are tons, since their market base is so diverse after 35 years.

Steve you know, I would never lie to you… this is Cubase 11:
image

By executing that command the current track will be enlarged and all the others are shrunk, by re-executing it immediately after shrinks all the rest of the tracks .

I know it is like that, was coded like that but it is misleading and makes you waste time to re-zoom back your tracks as they were before.

I never want to use this command either but out of the box is mapped on Z and in fact now i realized how I end up screwing my layout all the time when a project is slow and Cubase lags i press CTRL+Z to undo and instead I press Z by mistake wondering why my event got so big…

Also yeah Zoom in Tracks it’s CTRL + UP/ Down, that’s what I use normally, it grows or shrink only the selected track.

That was point of my post

Use ‘Undo Zoom’ instead of pressing ‘Z’ again.

YES, so annoying that “z” does not return previous zoom.
I have made macros and all sorts of workarounds, but that usually requires more keys. I can’t imagine anyone likes the way it behaves ?

1 Like

Why not just ‘undo zoom’?

I have it binded to alt-z, use it all the time.

Enlarge Selected Track does exactly what is being discussed here. Selected tracks change height, unselected tracks are untouched. Hit the command again, tracks return to previous height. The height of Enlarged tracks is saved.

The confusion started with the typo I mentioned above.

1 Like

Thank you @steve, even after all these years using Cubase. I would never have thought of changing that preferences option using key command. seems obvious now. And it even remembers an enlarged track height if altered when enlarged.
Bound it to “z”, and everything is as it IMHO should be.
Best Christmas gift yet :santa:

1 Like

:christmas_tree: :gift: for your :brain:!

Ok so can the default shortcut be swapped to Enlarge Selected Track so that users don’t have to reach out on a forum for something like that? Also can the old one be addressed properly so

  • gets back to the original size
  • is named correctly as “toggle xyz” ?

As mentioned in the link, I too find “Zoom Tracks Exclusive” absurd. But using “Enlarge Selected Track” by key command is still clumsy due to the constant notifications.

It’s also worth mentioning that “Enlarge Selected Track” lives under Key Commands>Preferences, but also under Key Commands>Edit.

I don’t know if someone put it under Edit hoping to spare us the notifications (of changing a preference by key command), but from what it seems it didn’t work. Both key commands are identical in function as far as I can tell, and both trigger the notification.

‘Z’ Zoom Exclusive to fully understand should be put in the context of selecting multiple tracks, or certain types of tracks and “exclusively” be zoomed into them.

Pressing Z again doesn’t return you to previous state, it instead returns you to a nominal track height state where no track(s) would appear to be exclusively zoomed and you have more of an entire overview of the project

.

Macro example Exclusive Zooming Solo’d FX Channels only

If you do want to return to previous state, use ‘Undo Zoom’.

So think of ‘Zoom Tracks Exclusive’ as a dual state feature… It’s not just zooming in that is the feature, it is having all tracks uniform so that the exclusive ones stick out.

This may have been intended to use with PLE, so that PLE for example selects all FX and Group channels and then ‘Zoom Exclusive’ in a macro. It also could have been designed more for use with controller-mixers and Nuage.

It could be nice if they gave us in preferences the ability to adjust the nominal track height in the Zoom Tracks Exclusive protocol.

Since Zoom Tracks Exclusive uses 1 row, you can make a macro (or several, for different track heights) like this:

better exclusive zoom

Just keep stacking Zoom In Vertically up to the desired track height.

1 Like