All good here with 8.0.20

Just noticing how comparatively small the population of people with negative reports is with this update as opposed to previous ones, and thought I would waste valuable time of the mods here by saying ‘thank you’. :slight_smile:

I myself have no issues at all now.


Good for you…

It could be that peeps are once bitten twice shy and have not implemented the update yet…my stuff is working ok and I don’t trust these updates enough to wantonly upgrade without seeing the problems they cause… :slight_smile:

seems good here too when is .30? lol :wink:

It’s always been risky updating Cubase , you never know if your going to be a lucky one or not but i agree , ive not had issues with the last 3 updates (including 8.00 ) . But for this we will be called fanboys and no doubt someone will jump on your feel good thread and piss on your parade .
Every update gets snappier and snappier , fast loading times . It’s never going to be perfect but it’s great to use

lucky you… :astonished: agree with modularnutter…best to wait a while

Working great here, rock solid.

Running fine here. But it is always a risk. We never know what is going to happen.

+1 Works perfect here.

Hi all

One or two very minor issues but overall more solid than before, in particular the main menu bar is now working properly for me, so generally its good update for me.

Best Regards


Rock solid here too. +1

I really do feel bad for those that are having issues. I couldn’t imagine having to fight just to load or close Cubase. I would friggen lose it.

I wish there was a formula to get others systems in line to work well…

Is it ever not, for you? :smiley:

Just teasin’ ya’.

Glass is full here, very happy.

+1 -

All running smoothly after updating. Very impressed with Cubase Pro 8.

All good here

so far, all seems fine. This is the first time I’ve actually said that :wink:

Same for me.
It’s running great on 3different computers (q6600 win7 64, i7 win 7 64, and even on my old Dell laptop, Latitude e5500, win8.1(Stretch test…:slight_smile:). Had to disable asiogard to get rid of “audiodropout detected message” on this machine, but now it runs fine… Thank you Steinberg, getting there at last…

No issues for me. Some of my key commands were lost during upgrade, but no biggie.

All good here too!