Amped Elektra not appearing

Brand new to Cubase…been using Cubasis, and decided to take the leap. Had the same issue with Amped Electra. Did a search on the computer to locate the file created by the download. In it was an executable file that completed the install of the software for Electra. Following that, the instrument simply needed to be added to the library. It’s an ok instrument, but I got spoiled by owning a half dozen Wurlys, …hope this helps somebody.

Thanks a lot for your very useful hints.
Clearly I had done something wrong during the installation.
Problem solved.
At least as far as Amped Elektra is concerned.
As to my occasional… blunders, the problem remains; and it’s even worsening, I guess. :]

We all learn most profoundly from our mistakes. It took me two days, off and on, to figure out most of these add ons, and I don’t have all of them functional yet. The process could benefit from a few instructions, which are blatantly absent. I suppose it’s meant to be an adventure! :rofl:

I’m having the same problem here! My voucher for Amped Elektra says “used.” And I remember registering it when I was installing Cubase 12, but then forgetting it until now.
I can’t remember if I downloaded the program or not though! If it’s in downloads, what would the file be called?

Thanks in advance.

I copied the code and tried downloading amp elektra via the Steinberg store. When I entered the code, it said “Sadly, the coupon is invalid.”

What can I do?

1 Like

Check if it’s installed by using the Steinberg Library Manager.

If you activated your download access code, it should also should show up under “My product downloads” and your MySteinberg account.

I couldn’t access Amped Electra till i did this:

Using Windows search look for Amped Electra. That search took me to an exe file (called Amped Electra).
Don’t recall where my computer put it, but opening the exe file completed the install to my computer. Following that, I was able to add it to the Steinberg library. Hope this helps.

1 Like

Please note that Amped Elektra has never used an .exe installer. It’s delivered as two .vstsound files:

  • ADD_SMT_819_Amped_Elektra_Presets.vstsound
  • ADD_SMT_820_Amped_Elektra_Samples.vstsound

They can be double clicked to register the library to the Steinberg Library Manager.

Definitely not in the Library Manager.
I’m definitely stuck!

If the license shows up in the eLicenser Control Center software, then you just have to download the library by using the Steinberg Download Assistant. Click “Open” when the download finishes to install it.

I won’t bother you anymore, thanks for making me feel so welcome. (That’s sarcasm and me telling you that is because you probably don’t get out much).

Your suggestion to search for the downloaded files makes sense, I’m just adding to it by clarifying what should show up on Windows search if you look for Amped Elektra. I’m sorry that it came across the wrong way.


Wow. You really can’t talk about anything around the web without someone getting upset!
As far as I can see, no one has said anything offensive!
Thanks for the suggestion,

Ahh… The Download Assistant doesn’t work on my PC. It’s a glitch that isn’t too uncommon and Steinberg know about. Any suggestions as to what I do next Romantique-tp?

Or anyone? I’d love to use it!!

I would recommend contacting Steinberg Support. They might be able to help you fix that issue or at least provide a direct download link.

Thanks Romantique-tp
I contacted Steinberg Support about 2 weeks ago but they haven’t got back to me yet.

Finally solved it by putting Steinberg Downloader on a different computer, then copying the downloaded files which went straight into the library.

After a couple of months of trying to solve why the amped elektra wouldn’t show in halion, double clicking on these files did the trick. Thanks for posting