Another thread about Android version Not Connecting to Windows 11

First of all, let me say I read the other threads where I thought I might find a solution for this.
I owned Cubase iC Pro before it was discontinued for Android, and now that it’s back I jumped on the 50% sale . Unfortunately, it’s not connecting.

Windows 11 (latest)
Cubase Pro (latest)
Android (latest)

My desktop PC is connected to the router via LAN.
The same router that is broadcasting my Wifi at 2.4Ghz and 5 Ghz.

Bonjour and SKI remote are installed.
SKI remote device is added in Cubase and the IP address given in the popup matches what I type in the IP Address field in IC Pro. In fact, it recognizes my PC by name… but when I click it, it just quickly highlights but nothing happens.

I’ve also checked the Firewall settings just in case. Cubase and Bonjour are there with proper settings. However there is no entry there for the Steninberg SKI framework. But I installed it, and I was able to add the remote SKI device in Cubase.

I’m just stuck with ICPro at the connection screen - clicking my computer name and nothing happening.

Looking to see if anyone’s got solutions before I open a ticket!
(and no, get a Mac isn’t a solution for me at this time lol)

Hi @Orlando74,

Thanks for your message.

Please check if our troubleshooting article is of help for you to resolve the problem:

Hope that helps!


Hi Lars,
As mentioned in my first paragraph, I’ve already looked at most of the threads related to this and read your linked article. Because I couldn’t find a solution that worked for me, I decided to post here.

In addition to what I mentioned in the original thread, I also tried resetting the router.
And I also tried enabling/disabling the 2.4Ghz and 5Ghz bands for the Wifi.
Interestingly, the Cubase machine name dissappeared completely from iC Pro when I turned off the 5 Ghz band. It looks like this is the frequency that is required for iC Pro to at least detect my computer (Connected to the router via ethernet cable).

However, I’ve exhausted all other options listed.

Should I open a ticket? Or are you able to assist any futher?

Hi @Orlando74,

Thanks for your message.
All known topics/recommendations are included in the article unfortunately.


My issue was the Apple Bonjour service never started. I changed the setting in the services window. That fixed it.

I wanted to check in here and say that I’m now able to use iCPro 1.2.6 with Cubase Pro 13. Not sure which update (or combination of the 2) solved it but I can finally connect and use the app. Only difference is that the computer name doesn’t appear in the app - so I just put in the IP address shown in Cubase’s SKI Remote dialog box and it works right away! :grinning:

1 Like

Hi @Orlando74,

Thanks for sharing your experience in the forum.
We’re glad to read, Cubase iC Pro works as expected for you.

Enjoy being creative,