ARA Plugin working in only 1 segment in Cubase 12

I usually record my vocals one line at a time, and process them with melodyne for pitch (I’m not a good singer, and this is for a class so I don’t care that much :)). With Cubase 11 my procedure was:

  1. Record vocals (one audio track armed, midi tracks playing for reference)
  2. In Extensions, select Melodyne
  3. Melodyne opens, with current and previous segments loaded
  4. Fix very bad singing

If I try the same in Cubase 12, I get the right behavior for the first audio clip but after that I don’t get new audio in Melodyne. I also tried setting Melodyne as an extension for the track (I loooooooooove this feature, but it doesn’t work for me). Same behavior in both cases. Just to be super clear, repro steps:

  1. Create Empty project
  2. Add an Audio track
  3. (Optional, but I do this) Create an Instrument track with a kontakt piano, import Midi and reference it
  4. Select audio track
  5. Assign Melodyne as the extension for the track
  6. Record first section of voice
  7. Open Melodyne by double-clicking audio clip. Correct.
  8. Record second section of voice
  9. Open Melodyne by double-clicking audio clip.

Expected result:
Both clips are represented in Melodyne

Actual result:
Only the first clip is there, and I can’t seem to find a way to get the second in


Hi @joaquinjares. Can I ask what mode you have your monitoring in preferences set to? Have you tried using ‘tape machine’ style? Your issue Might be related to a bug I am experiencing with exactly the same Workflow whilst recording using that tapemachine monitoring.


I’m on a different computer right now. I’ll test in a few hours and update here :slight_smile:

Just read your bug. I will still check, but it looks slightly different. In my case, all the audio clips are there. They are just not synced with Melodyne. It’s like using Melodyne as a VST instead of using it in ARA mode, in a way.

I tried. Monitoring is set to Manual. If I set it to Tapemachine, then Melodyne doesn’t pick any events at all, not even the first one. Reverting to Manual goes back to the previous behavior, even for already recorded clips.

Hmm that’s really interesting behaviour. Are you in the latest version of melodyne? I’d try u installing and reinstalling that first if you haven’t already. I’d be curious to know
If you have the same problem
Going into spectralayers? Or is it just a melodyne issue?

Sorry, ed, I don’t mean to be rude but I feel all this conversation is distracting from the fact that there’s an actual regression on Cubase 12 I need fixed to be able to use it. In Cubase 11, Melodyne could be applied to any audio event via ARA. There was a big change there in Cubase 12 to support ARA on Tracks (and that’s something that will make my workflow slightly but also significantly better) and now neither this new behavior nor my base scenario are working. I need to be aware if this is something that is happening to people or just me (which is unclear to me right now) and if it can be fixed soonish. The repro steps are very clear up there, and they are 100% repro for me.