Arturia Keylab Essential 61 Mk3 not opening or controlling VSTi's in Cubase Pro 13

Hi ,I have issues with the Arturia Keylab Essential 61 Mk3 and Cubase Pro 13,I can control Cubase no problem,all the transport buttons,channel faders,pans etc,all work fine,but I can not open or edit any VST instrument on the selected channel when I push the rotary encoder button down,I can see midi in activity when I push the button so it is sending midi but nothing happens,seems like no information is sent to the VSTi,I can not control any parameters on the VST instrument with,other than the Cubase Quick Controls,which has a few parameters generically mapped to 8 of the control knobs,but thats it,the keys on the keyboard don’t work on the VSTi either,can see midi in activity when I push the keys but it does not send any info to the synth,I am using the latest script from the Arturia Webpage(Arturia Keylab Essential 61 mk3),Cubase says controller is connected,I currently have the controller connected to KL Essential 61 Mk3 Midi for midi in and out on the vst instrument channel and in the midi port setup in studio setup devices tab all midi ports are active,besides the MCU/HUI ports which I deactivated as per the manual,nothing changes if I have them activated,have tried all midi ports no change,anybody out there have the same problem?Any help would be much appreciated.

Can you post screenshots of how the MIDI Remote surface looks now and also a screenshot from Studio->MIDI Remote Manager where it shows the MIDI ports it is connected through?

Thanks for the quick response

here is the midi port setup page

When I push the rotary encoder to open or edit a VSTi i can see Encoder:No Mapping and Push:No Mapping msg in the last touched control box on the top right hand side of the Midi Remote edit window surface

The ports look OK.

Something went wrong and it got accidentally unmapped, I guess.

Yes, this is what this script is designed to do. It doesn’t offer instrument quick controls which can be helpful since they’re not limited to the 8 focused quick controls.

For a start, close Cubase and go to your Documents Folder, then Steinberg->Cubase->MIDI Remote->User Settings.
There you will see a file like “Arturia_Keylab”. Delete this file.
Reopen Cubase and see if the jog push assignment is fixed.

Not sure this is relevant to the MIDI Remote.

Please check also the solution of another user, here:

Hi thanks for the advice much appreciated however nothing has worked so far, deleted the file,still have the same non response,still amazes that the keys on the keyboard do not work,can not play a single note on a VSTi,nothing comes thru on the Midi Editor when I play some notes,have also tried setting the DAW mode to both in the Midi center of Arturia ,and then selected KL Essential 61 mk3 MCU/HUI ports for midi on the VST Instrument channel and have it activated in Midi Port setup page,still no change,think I will have to return this controller as I bought it to control my VSTi’s under the advice from the store that it seamlessly integrates into Cubase and it cant play a note.

I wouldn’t do this, at least not immediately.

Give them a call, I somehow think that ports are a bit messy, the way you describe it, and most probably they could help you out with this.
For example:

This is not correct. MCU ports should be just for DAW usage. Controlling VSTs should be done with the other port.

Which other port are you referring as if i want to select HUI for midi in and out as per the other fix that you found,there is only the KL Essential 61 mk3 MCU/HUI port that has HUI as an option,the other ports available are KL Essential 61 mk3 ALV,KL Essential 61 mk3 DINTHRU,KL Essential 61 mk3 MIDI,the latter being the the port originally used.

Just wanted to check to see if you are aware that for Keylab Essentials MkIII there are DAW integration scripts on the website. There are actual scripts for Cubase, Logic Pro, FL and Bitwig,

However the script for Ableton Live is missing or none existent, there is just a doc file… Which brings me to the problems I have which seem to match those you experience. I have a new Keylab Essential Mk3 that I am using with Ableton Live 11 Standard and Analog Lab Pro with V Collection 9, all software is up to date. I find that the first preset I load into a session track sometimes shows on the Keylab screen and the sliders and knobs work initially but after that adding a new track it does not show the preset, only the instrument name, and that sliders and knobs descriptions are generic like Fader 1. This happens using Analog Lab plugin VST as well as using the individual Instrument plugin VSTs.

Have you used the Cubase Script?

Hi,I am using the Cubase script from the Arturia site,I did get the controller to open VSTi’s but I had to Program the rotary encoder to do that in Cubase’s midi mapping page,the script for Cubase mainly works for Cubase DAW and mixer controls ie. transport buttons, channel faders,etc.There is another mapping template in that script which is labelled device but it only has 8 knobs mapped to vst quick controls and the faders are mapped to Cubase selected channel send volume,and these are set permanently.To use the controller to its full potential with VSTi’s you have to map the faders and knobs on the controller in Cubase yourself with the midi mapping page and remote control editor on the VSTi’s functions drop down menu(black box top right corner of VSTi)Its definitely not a plug and play scenario like the Youtube videos from Arturia make it seem,.The display shows the selected track name not the VSTi and when I touch a fader or knob on the controller it shows which fader you are controlling.I am still unable to map the rotary encoder to scroll up and down presets or to scroll thru the channels in the project when using midi maps that I created(the controller does this fine with the Cubase mixer and device mapping page templates that come in the Cubase script)but when I assign the encoder to scroll channels it only seems to scroll one direction and can’t scroll the other way,does not seem to be a way to be able to assign 2 values to one encoder to be able to scroll up and down channels in the project,to use this function you need to select the mixer or device mapping page that comes in the Cubase script,quite annoying.

I have the, not opening Instruments with the push controller in Daw ,and Analog V.
Help desk said when opening ALab, hold pad 1 and push program button together and do the same for Daw Pad 2 program button.
That had things connecting and working much better.
No mention of that in the cubase script video or the cubase installation instructions, Hmmm
Controller showing no connection tho in the remote screen

Ah now Ive got the push working to open instrument window in Device and analog lab modes. In the midi remote editor it shows two options when you touch the knob. Encoder and push. Select the push and open the mapping assistant. Browse functions / Key commands/Edit/ Edit VST Instruments. Double click to save. Ive changed all the commands on the drum pads to something useful as well the same way.
Easy when spending days trying to figure it out.
I would say Arturia help desk was good, but I think their videos are very misleading, missing a lot of information.

1 Like

they are brutally bad and don’t listen to their customers in the right way like Steinberg or moog or Nektar etc do. have stopped buying Arturia hardware after Keystep pro. and will probably never buy from them again. as they have really poor quality of the hardware and do to earn as much as possible by giving as little as possible. even beatatep pro is better than keystep pro. even not all controls are usable in DAW. it’s a joke. and many come with ideas but there are never any updates, for that money you could have bought something that is better and can solve the link between a hybrid setup, with a clock and jotters when you mess with the hardware for an hour or 2.
But buy keystep pro for about 500€ with so meny fault and undune stuff and it took 1 year until the first update came. And im waiting for all the other stuff to and its 2-3 years now and nothing i happend… bought me a small Nektar LX daw controller, which is also crap but extremely good for the money, under €100. waiting for a good DAW controller to arrive that doesn’t skimp on the knobs and controls. type console mk3 together with NI new keyboard where NI keyboard and controller MK 3 are the same controls where controller MK3 is built into ALL THE EMPTY SURFACE that YOU have kindly left completely free without putting several knobs and faders etc.

to buy other things for it.

no, I hold the rooms because steinberg makes the ultomata daw controller that has CC121 NI keyboard new but bigger display and more push turn knobs and faders with auto script. and a compartment to put the dot controller mk3 nice and neat so it looks integrated :slight_smile: or do you make your own mo3 for cubase and all your products and third parties. It’s something I’m really looking forward to.

Hi everyone,
I have a problem with the Keylab Essential ML3 midi script : 3 keys are automatically assignated to “save as”, “undo” and “redo” …
I’ve changed the midi settings in Arturia Midi Control Center for DAw Mode, that I’ve put in “both” (as I’ve seen in another topic), and no change …
This is really annoying, because when I play, I have a redo, undo or save as that is activated …
Anyone has the same problem and the solution ?..
Thanks !

After some exchange of messages with Arturia support desk I have an acknowledgement that this is an issue being addressed by the Dev team ……
Hello Brian,

Thank you for the update, I’m glad to read that you found a workaround.

After digging into our log, I could find that this issue has been registered in the past for the Dev Team to fix it as soon as possible.

I’ll add your case to the log to increase priority.

Let me know if you have further comments.

Kind regards,

  • Arturia Support

Meanwhile I (Brian) have found one partial solution is if I make a Playlist in Analog Lab Pro that I am able to change tracks in DAW mode and then use the faders and nobs in Arturia mode with preset and device descriptions showing on the keyboard screen. This works once I try to use the faders or knobs after a short delay of a few seconds.

Does this problem only concern Cubase 13?
Does it work with Cubase 12?

I have the same problem. If you press and hold this Big Main button, the vst tool appears and hangs for editing. It’s a pity that I don’t have three hands). There was no such thing at 13.0.20. We need to ask Steinberg to make their own script for
KLE 61MK3.
I’ll try it in C12.

I just checked - at 12.0.70 the same problem

1 Like