ASIO Driver issue: Stutter after Win 10 1803 Upgrade

Hi,
After the Windows 10 upgrade to 1803, the Steinberg ASIO (v1.10.1) drivers of my UR44 were screwed up.

The audio coming from my UR44 (actually ANY audio, system sounds, various audio players, Cubase …) is stuttering like crazy.
It’s unusable. The audio from the mainboard works fine.
The ASIO drivers were working perfectly fine BEFORE the 1803 Upgrade.

I tried everything I could think of:

  • Reinstalled Yamaha Steinberg USB/asio drivers (latest version v1.10.1)
  • Reinstalled older version of asio driver (v1.7.3)
  • Installed latest and previous UR44 firmware (v2.12 and v2.11)
  • Re-installed Intel C220 series chipset and usb drivers
  • Increasing asio buffer sizes
  • Re-installed latest video driver of my Asus AMD Radeon HD7700 Series (v17.7)
  • Using different usb ports (usb2 and usb3)
  • Ran all kinds of windows “Trouble shooters”

The Device Manager does not show any obvious problems - none of the devices in the list were flagged with an error.

HOWEVER, the event log of the “Line (Steinberg UR44)” device showed the following:

Device SWD\MMDEVAPI{0.0.1.00000000}.{14e872cd-d3ae-46b2-8188-67fe715c76dd} was not migrated due to partial or ambiguous match.
Last Device Instance Id: SWD\MMDEVAPI{0.0.1.00000000}.{ba32da75-c9a9-4bf1-a1ee-2fbcaf04ae17}
Class Guid: {C166523C-FE0C-4A94-A586-F1A80CFBBF3E}
Location Path:
Migration Rank: 0xF00000000000F100
Present: true
Status: 0xC0000451

Even though the device status is “This device is working properly.” ?!?
I tried to troubleshoot the wired message in the device event log (see above), but couldn’t make it go away.
The message was not there before the 1803 upgrade?!

My system:

  • Win 10 Pro
  • Steinberg UR44
  • Mainboard: Gigabyte GA-P55A-UD4P, Rev. 1
  • Processor: i7 860 @ 2.79 GHz
  • 24 GB RAM
  • Graphic Adapter Asus AMD Radeon HD7700
  • Logitech UDB Camera (HD Pro Webcam C910)
  • Various hard drives
  • Old Belkin 4-port usb2.0 hub
    Granted, it’s an old system (8 yrs), but it used to be good enough for me :wink: … and it was working perfectly before 1803!!!

Eventually, after hrs wasted with troubleshooting I through the towel and restored to the previous Windows version.
The ASIO drivers resumed working fine again.

Did anybody have similar problems with Windows 1803 upgrade?
Any advice?

Thanks in advance.
Alex

https://www.steinberg.net/forums/viewtopic.php?f=157&t=142400

yes my friend, I have tried everything and even called support saying they would reach out…never did…no answer when pming support guys either…I have put in too many hours with no success. my presonus audio box just got in and works great. it’s a temp interface until I get an apollo. The Win 10 drivers are very flawed atm and it’s not your system. Don’t expect a fix anytime soon, sorry my friend.