Asio-Guard für mich unbenutzbar

Ich arbeite seit Cubase 8.0.20 zwangsläufig ohne Asio-Guard und habe deshalb gelegentlich Pops und Clicks. Der Grund ist: jedes mal, wenn ich den Asio-Guard aktiviere, friert Cubase ein, lässt sich also weder bedienen noch beenden. Selbst eine Zwangsschließung mit dem Taskmanager funktioniert dann nicht immer.
Wenn ich Cubase das nächste Mal starte, reagiert es extrem träge. Es dauert 30 Sekunden, bis die zuletzt geladenen Songs im Taskmanager erscheinen. Auf Aktion wie dem Klick mit der Maus auf einen Menüpunkt, reagiert Cubase erst nach mehreren Sekunden. Es ist praktisch unbedienbar. Das Laden eines Songs habe ich nach einer Viertelstunde abgebrochen.

Kann es sein, dass manche Audio-Interfaces nicht mit dem neuen Asio-Guard zurecht kommen? Ich habe ein Focusrite Saffire der älteren Generation (Firewire 400). Um das Interface unter Windows 7 zu betreiben, musste ich laut Focusrite den Firewire-Legacy-Treiber installieren. Mit dem ‘normalen’ Windows-Firewire-Treiber geht es nicht. Mit Cubase 7.5 hat es aberproblemlos funktioniert, auch mit dem damaligen Asio-Guard.

Irgendwelche Vorschläge zur Problembehebung?

So wie ich das verstanden habe.
Die Soundkarte hat nichts mit dem Asioguard zu tun. Es ist eine Sache der Plugins. Immer wenn die CPU wenig Last bzw. mit den akteulle Berechnungen fertig ist wird vorberechnet, so das schon Daten für den nächsten Durchgang vorhanden sind. Bei C7.5 konnte man Plugins im Plugin Manager davon ausnehmen. Bei C8 finde ich das nicht mehr.

Es ist möglich das ein Plugin Probleme macht.

Ist es tatsächlich so (erstens) das Cubase einfriert wenn du das Häckchen für den Asioguard setzt oder (zweites) friert Cubase ein wenn der Aisoguard aktiviert ist?. Und wenn zweitens, ist es bei jedem Projket so oder kannst du spezielle Plugins ausmachen wo das passiert.

OFFTOPIC
Und mal so nebenbei. Ich habe gerade zum ersten Mal den neuen Plugin Manager gesehen. Ok, ich komme damit klar. Aber mal ehrlich die Herren bei Steinberg, da fass ich mir doch an den Kopf. Wer denkt sich denn sowas aus. Der in C7.5 war dann doch übersichtlicher. Links unten ein “i” und ein Zahnrad mit dem man jeweils Fenster öffen kann in dem dann rechts oben die Einstellungen vornimmt.

Schließe mich Plan9 an, es sind eher Plugins die im Zusammenhang mit ASIO Guard Cubase zum Stottern/Einfrieren bringen.
Auch hier die Frage, triit das Problem bei allen Projekten auf oder nur bei spezifischen Projekten.
In Verdacht hätte ich eher VSTis, mit Sampletank 3 hatte ich mal Probleme, da fror Cubase für ne Minute ein.

Cubase friert ein, sobald ich das Häkchen setze. Das gilt allerdings nur für das Saffire-Interface.

Ich habe gerade Cubase mit einem anderen Interface getestet (USB-Interface von Line6). Damit funktioniert es auch mit eingeschaltetem Asio-Guard problemlos. Ich habe dann versucht, bei aktiviertem Asio-Guard zum Saffire-Interface zu wechseln. Ergebnis: Cubase friert ein.

Ich habe das Problem bei allen Projekten.

Wenn ich auf Asio-Guard umschalte, ohne dass ein Projekt geladen ist (und damit auch kein Plugin!), merke ich sofort, dass Cubase sehr träge reagiert. Das VST-Performance-Meter schlägt ständig bis zum Anschlag aus. Die Leistungsanzeige unter Windows zeigt ebenfalls heftige Peaks auf den Kernen 7 und 8. Das sind wohl die virtuellen Cores, die etwas mit Hyperthreading zu tun haben. Das kann also nichts mit einem inkompatiblen Plugin zu tun haben.

Nachdem das Stück geladen ist, beginnt es zunächst mit der Wiedergabe, bleibt hängen, ruckelt dann weiter, wobei die Hänger länger dauern als die Stellen, an denen Musik wiedergegeben wird. Das unerträgliche Stottern wird begleitet von einem Dauerfeuer von Asio-Peaks. Das Performacemeter steht praktisch immer auf Dauerausschlag. Sobald ich den Asio Guard abschalte, ist der Spuk beendet.

Ich habe eben in einem Projekt alle Plugins, die nicht von Steinberg sind, ausgeschaltet - einschließlich der VST-Instrumente. Es waren also nur Audio-Spuren mit einigen Steinberg-Plugins aktiv. Kein Unterschied. Nach wie vor unbedienbar und Dauerpeaks.

Wie gesagt: mit meinem USB-Interface läuft alles wie geschmiert. Ich glaube deshalb, dass es doch eine Rolle spielt, welche Hardware man benutzt, es liegt vielleicht auch an dem Legacy-Firewire-Treiber.
Nur: in Cubase 7.5 läuft dasselbe Firewire-Interface ohne Probleme (auch mit Asio Guard).

Ich fürchte, ich komme nicht um ein neues Interface herum. Fragt sich nur, welches. Zurzeit gibt es viel zu viele Standards: USB 1.1 bis 3, Firewire 400, 800, Thunderbolt, Ethernet, Rednet, dann noch auf Windows 10 -Kompatibilität achten. Kein guter Zeitpunkt für einen Umstieg. Dennoch vielen Dank für Eure Hinweise.

Doch das geht auch in C8, guckst du…
Asioguard.jpg

Also ich nehme ja eher an, dass da wieder mal die Prefs dran schuld sind.

Hatte das mal das sich bei mir die Hauptmenüleiste von C8 nur mit extremer Verzögerung bedienen ließ. Hatte da die Prefs mehrmals neu erstellen müssen bis es wieder ok war.

Probier mal mit dem Safe Start Mode und erstelle ein leeres Projekt mit Asia Guard An.

:blush: . Das habe ich auch gesehen allerdings hatte ich es interpretiert das das Plugin damit Aktiv geschaltet wird. Diese Funktion ist allerdings unten mittles CheckMark. In der Schule nannte man das wohl Flüchtigkeitsfehler. :mrgreen:

Danke.

Hab ich gemacht. Kein Unterschied. an den Prefs liegt es also auch nicht.

Ich habe aber eine Lösung gefunden:
Nachdem ich dem “Modus für optimierte Audioleistung” aktiviert habe, gibt es (jedenfalls im Augenblick) keine Probleme mehr mit Asio-Guard. Ich hatte diese Funktion bisher nie benutzt, weil ein Warn-Fenster geöffnet wird, dass erklärt, es würden bestimmte Windows-Einstellungen geändert, die zwar zu einer geringeren Latenz aber auch höheren Prozessorlast führen könnte. Im Manual bringt die Suchfunktion nach dem besagten Modus keine Fundstelle. Da ich nicht wusste, was Cubase mit Windows anstellt, hab ich das bisher immer gelassen.

Weiß jemand, was genau die Einstellung bewirkt?

Bitte :wink:

Aber wie ich schon mal an anderer Stelle schrieb…Asio Guard 2 soll hinsichtlich Multiout-Instrumente die permanent Sounds laden optimiert worden sein. Ein abschalten des Asia Guards bei solchen Instrumenten bringt von daher nix…war bei C7.5 noch anders.

Aber das soll und kann natürlich jeder selbst auf seinem System testen…steckt man ja nicht drin :wink:

Es unterdrückt zb die Stromsparfunktionen und setzt den Prozessor auf Höchstleistung…deshalb geht bei einigen das Ding los wie ein Staubsauger…die Ventilatoren laufen halt dann auch auf Highspeed :smiley:

Ist aber alles nicht schlimm, also keine Angst, und wenn das jetzt damit läuft, dann ist das doch ok.
Und sollten bei dir die Ventis auch durchdrehen, dann kannste das auch im Bios regeln.

Interessant was so alles helfen kann.
Dennoch würde mich dieser Workaround nicht richtig zufrieden stellen.

Ein vernünftiges Audio-Interface mit sehr gut gepflegten Treibern ist immer empfehlenswert.
Das RME Fireface UC bspw. ein sehr gutes USB-Audiointerface läuft bei mir seit Jahren wie am Schnürchen, null Probleme mit dem Interface.
Updates gibt es auch alle Monate, die hier und da Kleinigkeiten verbessern oder auch Windows 10 Unterstützung anbieten etc.

NIcht von der Hand zu weisen sind natürlich PCIe-Interfaces nochmals deutlich geringere Latenzen möglich, und erweiterbar etc. Bspw. wäre das RME HDSPe AIO eine sehr gute und sehr performante Karte.
Erweiterbar mit allem was das Herz begehrt, und eben auch stabil.

Danke für die Info, HBB. Ist das eine dauerhafte Einstellungsänderung oder wird es nur beim Cubase-Start gemacht und beim Beenden wieder zurückgesetzt? Ich höre beim Ein- und Ausschalten keine Änderung der Lüfterdrehzahl.
Wie auch immer: ich lasse es mal bei dieser Einstellung, auch wenn mir nicht klar ist, warum das bei meinem PC notwendig ist, um den Asio-Guard zu benutzen.

Was ich auch ganz erstaunlich finde: ein leeres Projekt, gestartet im Safe-Modus ohne Spuren und Plugins lässt sich bei eingestelltem Asio-Guard nur bedienen, wenn der Modus für optimierte Audioleistung aktiv ist. Da stimmt definitiv etwas unter der Haube nicht. Ich vermute aber eher ein Windows- oder Hardware-Problem. Der Workaround stellt mich auch nicht wirklich zufrieden.

Ein neues Interface wird auf jeden Fall bald fällig. Das Fireface schaue ich mir mal an, whitealbum.

MIST!!! Zu früh gefreut: während ich mich gerade im Netz nach Audio-Interfaces umschaue, merke ich, dass ich im Firefox kaum noch scrollen oder Tabs umschalten kann. Alles reagiert unglaublich zäh. Im Hintergrund ist immer noch Cubase geöffnet und wieder mal eingefroren (trotz aktiver Audio-Optimierung). Also mal wieder mit dem Task-Manager abschießen, Windows neu starten. Cubase starten und hoffen, dass ich den Asio-Guard dann wieder ausgeschaltet kriege. :smiling_imp: :smiling_imp: :smiling_imp:
Ich gebe es auf. Das Ding bleibt jetzt deaktiviert.

Hallo Rolander,

ich nutze ebenfalls die Audio Interfaces von Focusrite. Zu Hause ein saffire pro 24 DSP und im Proberaum ein Pro 40, mit beiden habe ich keinerlei Probleme. Welche Safire MixControl Version nutzt du? Bei läuft aktuell die 3.6 findest du allerdings nur beim Pro40 im Download Bereich, funktioniert aber mit allen Saffire Geräten. Ich hatte aber auch mit den Vorgänger versionen noch nie derartige Probleme. Ich meine auch, auf der Focusrite Seite mal was gelesen zu haben, das sich die Sache mit dem Legacy FireWire Treiber erledigt hätte.
Ich bezweifle den Zusammenhang deiner Asia Guard Probleme und dem Interface, evtl. FireWire Karte defekt?

Gruß Dirk

Hallo Dirk,

die Probleme habe ich ja nicht mit Cubase 6 bis 7.5 gehabt, sondern sie sind erst seit Cubase 8 (ich glaube sogar erst seit der Version 8.0.20) aufgetreten. Wenn es an Treiber, Software oder Firewire läge, wären sie schon früher aufgetreten, vermute ich wenigstens.
Das Interface ist das erste Saffire-Gerät, das je herausgekommen ist und hat mir lange Jahre gute Dienste geleistet. Legacy-treiber ist leider bei dem alten Gerät Pflicht. Der Treiber wurde schon seit Jahren nicht mehr aktualisiert. Ich habe bei Focusrite nachgefragt: ein update ist auch nicht geplant. Die neue Mixsoftware soll angeblich damit auch nicht laufen.
Eine Firewire-Karte habe ich nicht. Der FW ist auf meinem Mainboard integriert.
Da FW angeblich auf dem absteigenden Ast ist, wird mein nächstes Interface wohl auf USB setzen.

Hallo Rolander,

an dieser Stelle möchte ich kurz einwerfen, warum ich meine damalige Saffire vor einiger Zeit wieder verkauft habe: es ist bekannt, dass die Treiber ziemlich gewaltig rumzicken (können!) und sporadisch Fehler auftauchen (können!). Pekas und Aussetzer hatte ich auch. Die Foren sind zudem voll damit, es ist gut nachzulesen.
Nun werkelt hier eine gute RME, mit USB, das wäre so meine mindeste Empfehlung. RME hat mit die besten Treiber die man finden kann, nie Ärger gehabt damit, trotz extremer - und wild multirecordeter - 24/7 Nutzung. Hätte zudem auch nie gedacht, dass Firewire durch USB gut zu ersetzen ist. Es klappt hervorragend.
Auch wenn dir das jetzt nicht wirklich helfen mag, ich weiss.

Gruss,
Central.

Danke Euch allen für Hinweise und Tipps. Im Augenblick komme ich klar mit dem Energieprofil von Steinberg (optimierte Audioleistung). Als ich das letzte Mal geschimpft hatte, dass Cubase wieder eingefroren ist, habe ich festgestellt, dass ich das Häkchen offenbar wieder deaktiviert hatte.
Aber spätestens beim möglichen Umstieg auf Windows 10, den ich allerdings bis zum letzten Moment hinausschiebe, wird ein neues Interface fällig. Es wird definitiv ein USB-Interface, auch wenn ich dann vielleicht eine Millisekunde mehr Latenz in Kauf nehmen muss. USB wird es bestimmt noch viele Jahre geben und bisher ist die Abwärtskompatibilität auch nicht schlecht. Wichtig sind für mich gute Mikrofonvorverstärker, Line- und Instrumenteneingänge, mindestens 4 Ausgänge für 2 Paar Monitore und zwei Kopfhörerausgänge. ADAT brauche ich nicht. In der bezahlbaren Preisklasse dürfte das wieder auf Focusrite hinauslaufen. Die Interfaces haben einfach ein unschlagbares Preis-Leistungsverhältnis. Ich mache ja keine großen Produktionen. Die Fireface-Interfaces sind mir einfach zu teuer oder passen nicht ganz in mein Anforderungsprofil.

Sehe ich auch so…das Preisleistungsverhältnis stimmt da nicht so ganz(wie bei Apple). Gibt ja einige gute Interfaces auf dem Markt, mit denen man auch nie Probleme hat. Und mit den Latenzwerten wird ja gerne mal das ein oder andere Defizit ausgeglichen. :wink:

LG
HBB

Aus reiner Neugier hab ich jetzt auch mal gestöbert was es interessantes im USB Bereich an Interfaces für mich gäbe.
Da ich mich in der letzten Zeit mit Live Recordings (Konzerte mit Schlagzeug, Gitarren, Schreihälsen etc.) beschäftige und meistens mangels freiwilligen auch den FOH Mixer gebe, ist mir das Motu 828 mk3 Hybrid bzw das 896 mk3 Hybrid ins Auge gefallen.
Bisher hab ich das alles über Cubase geregelt, 16 Kanäle über Firewire (Focusrite SAffire Pro 40 + ein Behringer 8 Kanal ADAT Gerät) mit einer “alles in allem Latenz” von unter 10 ms ist kein Problem. Sogar mit ein paar Plug-Ins (EQ und Kompressor) auf den einzelnen Kanälen habe ich keinerlei Performance Probleme!
Mir ist aber das ganze Geraffel mit PC, Maus, Tastatur und Bildschirm etwas zu viel Schlepperei und Aufbauerei, alles mikrofonieren und verkabeln ist schon Arbeit genug. Deshalb will ich für diese Zwecke auf ein Laptop umsteigen und TADA bezahlbares Windows Laptop mit ausreichend Leistung UND Firewire gibt es nicht!
Deshalb das Interesse am Motu, mit der CueMix FX Software (DSP Effekte für jeden Kanal EQ, Kompressor, Reverb) den Saal beschallen und mit Cubase (oder AudioDesk) recorden, das ganze über USB. Das sollte dann sogar mein billo Laptop schaffen, da die Effekte ja im Interface per DSP “erschaffen” werden.
Für den Preis (828 knapp 900,- Euronen das 896 für um die 1200,-) und den gebotenen Features erstmal seeeehr interessant!
Hat einer Erfahrung mit den Motu Teilen?

Hi Finne,
wenn Du darauf achtest, dass dein neuer Laptop ein PCI Express-Kartenslot hat, könntest Du Dir auch einfach ne Erweiterungskarte für Firewire zulegen.

Keine Ahnung ob das dann auch mit ner Soundkarte reibungslos funktioniert, da müsstest Du Dich mal schlau machen, aber vielleicht wäre das ja ne Option für Dich. Dann könntest Du Dir zumindest ne neue Soundkarte sparen…