ASIO Guard Overload But Cpu is fine

Hello
I’m Working in Cubase 12.0.50 and i’m working on project’s that not so heavy and still sometime when i get asio guard overload but when i check my cpu performance in task manager when the project is on play it’s only uses 15-20% of my cpu so how does asio guard is still peaking and my project is glitching and stating to stuck? anyone else?
My spec:
AMD Ryzen 9 5900X 12-Core Processor 3.70 GHz
32 RAM
Windows 10

Thanks Alot !

1 Like

Task manager’s CPU load indicator measures things differently and pretty much ignores “realtime” problems. Cubase meters focus on the audio path. That’s why they’re typically different. Same with other DAWs.

So it’s doesn’t matter what % i see in the task manager?
And do you know what can i do about those peaks ?

Well if the CPU is at 100% in the task manager then the CPU is 100% used, pretty much. So that matters. It’s just that if it says something lower than that it could still be a problem.

You can probably find a good thread or two on the topic where people giver recommendations. Typically increasing the regular buffer helps the CPU. If you have a very long signal chain and/or a signal chain with heavy processing then that’s going to be hard on the CPU in terms of glitches because it tends to hit a single core.

As annoying and tedious as it may seem I would recommend just going through the different settings in Cubase and take notes on how your project performs. Use the same project every time, and play the same section - one that you have problems with. And make sure you test just one difference at a time when you start testing, so that you know what setting makes a difference if you see a difference.

image

I’m talking about the above.

Other issues that you can have on the computer side of things is things like Wifi and Bluetooth which can mess with realtime performance. They can be turned off in BIOS.

PS: I wish I could give a better answer but I don’t have high demands on realtime performance since I do sound-to-picture… though I have the same CPU as you.

1 Like

First of all thank you alot !
So you saying i should try change the asio guard level and check?
and what do you mean in this sentence:" signal chain with heavy processing then that’s going to be hard on the CPU in terms of glitches because it tends to hit a single core"

And sorry about the lack of knowledge in computers lol . but BIOS is when i turn on the computer and press f12 ? i should turn off bluetooth from there ?

Several of those settings make a difference. I recommend you go to the section in the manual that describes what those settings do and then try it out. As you can see I don’t even have ASIO-Guard on since I don’t need it, but if you need it you may want to try different levels. And if you run Cubase using 64 bit float you can try 32 bit float. And so on. Change one parameter at a time and test again and look at how performance changes to see if it helps.

What buffer size are you currently using?

What I mean is that if you have one heavy plugin in one insert on each of 12 tracks that’s (probably) going to hit all of your CPUs 12 cores. The processing will be mostly parallel. But if you take the same plugin and put 6 in series on one track’s inserts, and the other 6 on inserts of your master output, then all 12 instances of that plugin will run in series. One insert has to complete calculating before the next insert can start and so that ends up landing on one core of your CPU.

So if your CPU can boost up to 4.8GHz for example then it won’t be needed for the parallel workload because it’s all spread out. But in order for your audio to be completed before your buffer is emptied you could have a problem if the plugins are all in a row, in series. Because then those 4.8GHz might not be enough.

But it depends on what you have going on in your project. Heavy plugins and heavy VSTi can be tough on a CPU. For me it’s not a problem since I use many tracks rather than long signal chains.

Hope that makes sense.

No worries. Yes, I’m talking about what you get into by hitting a key when the computer is booting. But if you’re new to that and feel uncomfortable doing it then I recommend trying other things first.

What is your motherboard and what is your interface?

It’s worth noting that if you look at the CPU usage in task manager, the default settings aren’t very useful as it shows only a global percentage. If you switch to a per-compute-thread view (right click, change graph to logical processors or so), you get the the usage of every single logical processor. If you see one that is close to 100% whereas others are a lot lower, you are in the exact situation that @MattiasNYC described, too many cpu hungry plugins in serial and no configuration changes will help you there.

If that is not the case, do you have an antivirus scanner on your system? If yes, you should definitely add an exception for Cubase there or disable the scanner while using Cubase.

MotherBoard: ASRock - X570 Taichi
PROCESSOR: AMD Ryzen 9 5900X 12-Core Processor 3.70 GHz
I built this spec to handle those kinds of project (heavy)

And i didn’t understand really well:
If i have plugin x (which is heavy for instance) and if i put it 12 time over 12 pre insert of audio a then it will “attack” my cpu cores in the same time.
But if i put the same plugin X in 6 pre inserts of audio B and audio A it will first finish processing audio a —>the audio b ? and this will put less pressure on the cpu ?

*I’ve tried to change ASIO Guard from low to high and nothing helped,i even changed cpu setting so that it will use all of my cpu cores.
And really thank you for your help !

How do i check if i have an antivirus scanner?
I doesn’t have any antivirus

And where exactly do i need to press the right click to see “logical processors”

Thanks !!

No, lets say you have 6 cores and 6 tracks. Add one plugin per track will result in a small load of x% on all cores. Add 6 FX to one track will add a 6X% heavier load one 1 core. Using bussing can make it worse.

Just think of this as the CPU being a room and each core being an office worker. The job of each worker is to calculate some number. Each worker is equally good at calculation, and all of the calculations are of the same type, for example multiplication, and it takes them all exactly 1 minute to calculate what they get. Now I am in control and I manage 12 workers in that room.

In this first example I have one piece of paper with a series of calculations that have to be done. There are 12 lines of multiplications that have to happen, but each line ends with an answer and that answer is the first number of the next line. I give this to one worker. It takes him 12 minutes to finish, because each line takes 1 minute. I can’t “cut up” this piece of paper so that each line is a small paper, and then give one paper to each person, because then they will just sit and wait until the first line has been calculated by whomever has that piece of paper. And then the second person can continue but the other 10 people still have to wait. So I just give it all to one person.

In the second example the multiplication does not depend on other multiplication. I have 12 pieces of paper. They can be calculated independently. Nobody needs to wait for another person. So they all start at the same time and it all takes them 1 minute each, but since they work at the same time it only takes 1 minute in total. They work in parallel.

The first example is plugins in a series - for example 12 plugins on one track, or 6 plugins on one track and 6 plugins on the master output.

The second example is plugins in parallel - for example 1 plugin each on 12 tracks.

1 Like

Ok much more clear .
Buy if i want to work on sound A i can’t just split the plugins .
I Need all the 12 on this same track so they will process sound A , or is their any other way i can still process my track with 12 vst’s with less load on my cpu ?

Nope!

1 Like

Like vinark wrote, no other way really.

(sorry I basically said the same thing as you vinark, just with a bunch more words. I missed your reply somehow)

Unless you have specifically disabled it, every Windows system is running the Microsoft defender:

You could try disabling it temporarily while working with cubase.