ASIO4All "Not Connected 1" Cubase Pro Problem

This is killing me. It used to work but for no apparent reason I cannot get ASIO4All to work with Cubase Pro properly anymore. I needed a new port activated for some Bluetooth headphones but it wouldn’t show up despite me activating it in the ASIO4All Control Panel so I clicked “Reset” and now I just get this. The output ports just say “Not Connected” instead of listing all the actual ASIO4All ports available like it used to. I have restarted my entire computer and still the issue remains. I cannot get any output from ASIO4All and it makes no sense.

I cannot use the Generic Low-Latency driver because it has some bad interaction with this laptop’s Realtek integrated sound and it’s unlistenable; everything crackles and jitters horribly.

Does anyone have any suggestions for fixing this? I’m just at a loss here. Why won’t the port names come back?! And no, it’s not just a name thing, they do not work and there is no sound. And yes, I do know I have to open the “Audio Connections” dialogue separately and assign the ports to an actual monitor. Still doesn’t work.

System Specs
Windows 10 Home 22H2 (19045.3086)
Ryzen 5 5600H + 16 GB RAM
Cubase 12 Pro (12.0.40 Build 317)
ASIO4All V2.15


Maybe this? The official ASIO Driver for Realtek Sound Devices (Dell, HP, Lenovo, etc.) – Jan Baumann (

Or maybe this one if you are not Dell: How to Download Realtek Asio Driver (Windows 11, 10 & 7) | Mos Tech Tips

I tried to use that driver package – it appeared to have installed properly, but could not be configured, because I was unable to open its control panel. It would be interesting to get it working though.

I’m using an Asus MB with Realtek audio.


Asus has so many safeguards on it’s PCs so there may be something going on there. Maybe contact Asus for a workaround. They are heavy into Gaming, but not DAW work me thinks.

1 Like

I have the Realtek ASIO Driver and actually it’s the worst of the bunch, I can’t even get sound out of it. I might try seeing if there’s a newer version.

I reinstalled ASIO4All and that made all the ports show up, but then Cubase crashed and continued to crash the moment I tried to start it up thereafter so I literally had to completely uninstall ASIO4All to even get Cubase running again.

So far the only solution where I can at least get work done is to use the Generic Low-Latency driver and Bluetooth headphones. Don’t ask me why but that works fine. It’s when I try to use the 3.5 mm port with my nice studio monitor headphones that the Generic driver sucks and is horribly choppy.

So I can compose and make adjustments at least but it wouldn’t be wise to try to EQ or do any serious mixing on Apple Airpods, unless that’s my target audience I guess.

EDIT: Just FYI for anyone reading this, it’s a pure coincidence that another person named Steve replied to this thread and it also happens that I too am using an Asus Laptop so I thought this was a response to me (I was scratching my head trying to figure out how you knew I had an Asus with only my screenshots).


I cannot praise the Realtek ASIO driver enough. It has the best latency of all of them:

Ok, I don’t get any sound at all, but who cares? I assume the drivers is so fast the sound is already gone when it is time to play it back.

{/sarcasm off}


To OP: did you see This?

Yeah and when it works I pretty much have all the same settings but you can see from my screenshots that the “Ports” section in Studio setup is messed up and doesn’t list the ports.

Reinstalling ASIO4All brings them back but then everything was jacked up and Cubase wouldn’t start without crashing. I have a feeling that if I completely uninstall ASIO4All, restart, reinstall from scratch and reset again then maybe it will work. My issue is that activating new ports on ASIO4All is a crapshoot because half the time they won’t update in Cubase so either ASIO4All or Cubase needs some serious update.

I think the issue is ASIO4All; you can’t even access the control panel unless another program is using the DLL. The Generic Low Latency driver works 90% of the time it just doesn’t appear to like Realtek on-board audio, but only specifically the heapphones and built-in speakers because it works perfectly if you’re using bluetooth headphones… honestly I’m thinking of just buying a second audio interface and carting it around because Cubase works flawlessly with a USB interface it just hates everything else (If only we could use MME like Adobe Audition).

Did you try FlexASIO?

No I will have to look into FlexAIO.

So far the solution for this problem was to just completely uninstall and then reinstall ASIO 2.15 any time this happens (restart after uninstall and after reinstall). I think it might be a good idea to switch back to ASIO4All 2.14 because the “Offline” option was removed in 2.15 and this seems to have something to do with where ASIO4All stores info about ports. In 2.15 you can only even access the control panel when a program is using the DLL so I have no idea where any of the info persists.