ASIO4ALL - nothing happening

Hi all. My normal setup is a SaffireLE via f/w but I also have a preinstalled SB X-Fi Xtreme which I have hooked up to some “cheap and nasties”. Both sit happily side by side and I swap between them in Cubase or Winamp with no problem. This is so I can test my mixes through a consumer setup.

In Cubase, the SB only works with the “ASIO DirectX Full Duplex Driver” but the latency is a little high so I thought I’d see how ASIO4ALL managed. But although the driver has installed, Cubase has picked it up and allows access to the control panel, where I can see that the SB has been detected and the Line outputs are working properly, there is no sound.

In fact, there’s no audio meter activity at all, although cursors and MIDI meters are moving as you’d expect.

F4 panel shows ASIO4ALL with the right outputs selected.

Think I’ve missed something so wondering if anyone else has experience with this combination. I might be relevant to mention that I’ve never managed to get the “Generic Low Latency ASIO Driver” working either.

Cheers,
Crotchety


SOFTWARE
Windows 7 Home Premium 64-bit
Cubase 6.0.5 64-bit

  • Device Setup: Steinberg Audio Power Scheme ON
  • Device Setup: Multiprocessing ON

HARDWARE
Focusrite Saffire LE (FW400) v.1.5
Dell XPS 8100 Desktop

  • CPU: Intel i7 860 @ 2.80 GHz (HT OFF, C-State OFF, SpeedStep ON, TurboBoost OFF)
  • Chipset: Intel H57
  • RAM: 4 x 2 GB DDR3-1333 MHz
  • HDD: Non-RAID, 2 x 1TB Samsung HD103SJ (7,200 RPM; DTR: 250 MB/sec; Latency: 4.17 ms)
  • Grafix: ATI Radeon HD 5700 Series

What buffer have you set in the ASIO4ALL control panel?

DG

Thanks for your reply. Here’s a screenshot of the ASIO4ALL Control Panel launched from within Cubase:
ASIO4ALL Control Panel.JPG

Try a higher buffer than 512.

DG

Fraid not. I’ve now tried buffer, latency compensation and buffer offset all on max, also Pull Mode (although I’m not clear whether to expect anything from it).

Have you checked VST connections again? When switching audio interface, Cubase probably can’t pickup all the new ins and outs automatically.
Note how you can save presets in VST Connections, to make swapping easier next time :slight_smile:

Have checked the connections and they’re as I would expect (I was going to say “okay” but decided that was pushing it a bit…). I have several times encountered the phenomenon you mention - changing audio driver drops the VST Connections - so was pretty sure I had checked this but there was no harm in checking again.

As far as the Connections go, I can change between ASIO4ALL (A4A) and ASIO DirectX (ADX) and they will keep their port assignations. ADX only has the stereo pair but A4A uses 1+2 from the full complement of 8 Line-Outs (all tried).

What’s selected as the track and main out buses on the individual channels?

The outs are labelled “Stereo”. They don’t change on switching.

The Creative ASIO driver for the Blaster doesn’t show in Device Setup? A screenshot of Device Setup, VST Connections outs and the Mixer with routing views would help narrow it, I’m thinking.

I’ll sort some screenshots out. In the meantime…

No, I don’t get any Creative driver in the list and don’t think I ever had. I wonder why?

You’ve got all the Device Setup in the preceding posts and the VST, come to think of it.

Not sure what you mean with the routing view for the mixer…

One more thing - Although the MIDI tracks play fine, there is no MIDI being received by the VST Instrument.

Did you enable Monitor on the MIDI tracks? MIDI Thru checked in Prefs? MIDI Filter, only SysEx checked? Said it a lot lately, but have you Trashed Prefs?

Thanks for the thoughts but I don’t think it’s any of that. Cubase finds the driver, the driver sees the card’s ins and outs but then zip. I wonder if your observation that there is no Creative card listed in the Devices menu has got more to do with it…

Having the same problem Cubase Studio 5 PC i/o2 interface but can’t get any audio from mic into Cubase. Using ASIO4ALL but in VST connections don’t see i/o2 listed there. About as frustrating as it can get. Any ideas folks Cubase were promoting the i/o2 interface but it don’t seem to work correctly, at least for me anyway!

You should be using the ASIO driver for the device, not ASIO4All. Device needs to be powered before starting Cubase for it to show and the correct ASIO driver selected in Device Setup.

Are you saying that ASIO4ALL isn’t?

Isn’t what?

4ALL! :smiley:

You might like to keep an eye on this thread I started at Creative:
http://forums.creative.com/showthread.php?t=696882

If he’s talking about the Alesis iO|2 ASIO4All is the recommended driver for that device. Personally I don’t think I’d be buying anything that uses a generic driver. Maybe it works fine if configured correctly, though :neutral_face: .

http://www.alesis.com/io2