AsioGuard spikes? Remove the VocalChain plugin

I upgraded from 11 to 13 this week, and have also removed 100% of my third party plugins to work with only stock Cubase ones. I have three computers - two are Xeon 4 core and one is a laptop 17 4 core. They’re older computers but have been working fine from Cubase 6 through 11. I haven’t had a dropout in so many years I actually forgot it was a thing.

The new VocalChain plugin looks like a great tool, so naturally I wanted to play with it. However, before I could get into it, I was confronted with the AsioGuard spikes and dropouts that people have been complaining about in 12 / 13.

Because these are older computers, I thought maybe I just needed to do some performance tuning. In the end, however, all of my spike / dropout problems were traced back to VocalChain. I made no changes to my computers.

I do classic rock, so my mixes use relatively few types of plugins - just the typical dynamics, eq, reverb, delay, etc. EZ Drummer is the only virtual instrument I use. My projects typically have no more than 50 tracks, often well below that.

When fighting the spikes, I experimented with silly choices just to see where the problems were, and had several plugins on each channel, including the master bus. No spikes, no dropouts. Adding a single instance of VocalChain immediately caused spikes. Even after removing all the other plugins, leaving nothing but one VocalChain instance.

Once I realized this, I just quit trying to use it and went about the business of stripping out the third party plugins (now physically uninstalled and removed from my computers), replacing them with stock ones, and working on my mixes. And having quite a bit of fun with 13.

No spikes, and I actually forgot about the problem altogether until late last night. I opened a mix and immediately got spikes. There may have been profanity. However, I quickly realized that this was one I’d added VocalChain to earlier in the week and had just now come back to it. I removed VocalChain and immediately the problem disappeared.

There are a lot of things to love about 13, and I’ve been enjoying the upgrade. It’s disappointing that the audio problems in 12 / 13 are also present in VocalChain as it clearly needs some work in this area before it’s usable by many people.

I’m sure in future patches they’ll get it sorted out, but for now if you’re fighting with AsioGuard spikes and you’re using VocalChain, remove it and see if it brings you back to normal. It might be the only thing you need to solve the problem in your particular environment.

There are doubtless other third party plugins, computer issues, etc. that can contribute, but in my case this was all I had to do and now I’m back to normal.

The purpose of this post is not to complain about the plugin. It’s new, and new software tends to have glitches. My intention is to offer what might be a quick fix for some of you who encounter this, as it’s what got me back on track. I hope it helps.

1 Like

There is more related to it. Which OS? Which generation of Xeon?

I’m running Windows 10 and the Xeon computers are ancient.

That said, the point of this post wasn’t “how do I get VocalChain to work,” but rather to offer a potential quick fix to maybe a few people who were running just fine before but are now having audio spikes.

In my case, Cubase worked fine in 11, and in 13 it was initially unusable because of the spikes (because I immediately added VocalChain), to the point where I was considering reverting to 11. This one change solved my problem, so perhaps this will help a few other people.

I can still use the VoxComp, BlackBox, etc individually, and those aren’t causing spikes, so blacklisting VocalChain is a small tradeoff for returning my system to its previous stability. I will continue to audition VocalChain with each maintenance patch they offer, and if it’s ever sorted out I’ll certainly use it, but for now I’m happy just to have my stable systems back.

You can try to disable processing blocks in VocalChain.

And, can you add the issue tag? Please?

Hi, Steffen,

I’ve added the issue tag. I’m also happy to do a little testing if that helps the cause (I develop software for a living). I’m not sure what you mean by “disable processing blocks,” so if you can elaborate I’ll follow your suggestions and report back with my results.

I’m perfectly fine with just blacklisting VocalChain, but if it helps the devs I’m happy to do some diagnostics.

On the left side is a list with processing modules.
You can deactivate them. Pitch will need more resources than the filters.

Yeah, once I got back in there I realized what you were talking about. So I’ve done some additional testing.

[Insert your favorite profanity here]

I am completely unable to reproduce the results that I got yesterday, or the previous few days. The last project I got into last night where VocalChain was still active and immediately started stuttering was 11 PM. I worked for another hour and went to bed. Unless elves came to tinker with my machine in the wee small hours I have no idea what’s changed.

In my current stress test, I added the standard compressor to 18 tracks (plus a Reverence and delay instance). I then added a VocalChain instance and turned on every single block (don’t care how it sounds, just monitoring the AsioGuard meter). From there I alt-dragged VC for a total of 7 instances, all blocks on. This put the meter right up to the edge, but no dropouts. On the 8th instance of VC the meter pegged and there were dropouts.

If you count VC as 16 plugins, that works out to 132 plugins of of varying demand and still no dropouts, though right on the edge. For my Xeon system, this is perfectly reasonable and pushing it much harder than I normally would.

This was on the control room Xeon (Processor Intel(R) Xeon(R) CPU E5520 @ 2.27GHz, 2261 Mhz, 4 Core(s), 4 Logical Processor(s)) using the Yamaha TF5 (buffer size 512) as an audio interface.

On the other Xeon (Processor Intel(R) Xeon(R) CPU W3565 @ 3.20GHz, 3200 Mhz, 4 Core(s), 4 Logical Processor(s)) station using the Scarlett 2i2 (buffer size 480), I was able to increase VC instances from 7 to 11 with no dropouts.

I have no explanation for the difference in what I’m experiencing today versus yesterday.

The problem was consistent on both Xeons and also the laptop. I did run many uninstall programs on them to remove the third party plugins, and rebooted each machine afterwards. However, the problems continued after the reboots, none of the machines have been rebooted since yesterday, and there are no pending Windows updates. Last night the problems were consistent across all three machines. Today they’ve magically vanished.

The only X factor that I can think of is that this week I’ve been porting the 11 projects with third party plugins to 13 projects using only native ones. My steps have been:

  1. Uninstalling all third party plugins on all three computers.
  2. Making a backup copy of an 11 project
  3. Opening the 11 project in 13
  4. Removing all references to third party plugins (frequent flyers were lots of Waves, Arouser, MicroShift)
  5. Opening the 13 project to verify no more errors due to missing plugins
  6. Proceeding with mix changes
  7. Experiencing AsioGuard pegging after adding a single instance of VC with ~8 blocks activated, including the pitch.

I am, of course, happy that I can now play with VC, but I’m concerned about a major performance problem that magically disappeared overnight. Mysteries are never a good thing with computers.

Do you have any thoughts on this?

This is usually called bug, not elves.

Yeah, that’s certainly been my experience with my own code. :slight_smile:

I’ve been able to consistently reproduce the problem in another project. I followed the same steps porting it from 11 to 13, removing all plugins, rendering EZ Drummer to audio and removing the virtual instrument.

The project now contains only audio files, no virtual instruments or other plugins. It has exactly one plugin, VC, which defaults to enabling blocks for EQ I, EQ II and Imager.

VC is installed on the lead vocal group, which routes to stereo. There are background vocals in a separate group, which also route to stereo. I have a marker at the measure before the background vocals (three mono audio tracks) come in. The moment they do, if VC is enabled (and remember it’s not on the background vocal group), it drops out. With VC disabled, it doesn’t. I can consistently reproduce this.

Since I was able to add 7 instances with all blocks on in another project a few minutes ago (but last night it glitched on only 1), I have no idea what the difference is, but the project I just reproduced it on is consistent in makeup with the other projects this week that have been giving me the dropouts.

I would be happy to zip up this project and send it in if that would help to reproduce the problem, but I don’t know what the procedure is for doing that. Could you advise?

Just cleaned up and zipped the project. It’s 340 megs.

I really appreciate you posting this information. I too, use a Zeon and my mixes are very close to what you describe.
I plan to upgrade from 10.5 to 13 so this information is heaven sent. Wish me luck please.

Hey, guys.

Per the conversation below, I’ve found VocalChain to be a problem with AsioGuard spkes, but it turns out to be inconsistent. I was finally able to reproduce the problem consistently and have a sample project to share, but I don’t know how to get this to the Steinberg devs.

Could someone let me know what the appropriate procedure is?

Open a ticket via the support page, or ude the forum.

Thanks, Steve.

Wasn’t trying to break protocol with the second topic, thought “how do I post a bug report” was a separate question.

The sample project is a few hundred megs. Should I attach that to this thread, or is that too big?

Hmm, I don’t see a way to even attach a file to a forum post. Is that even possible?

I don´t have issues with Vocalchain but it´s a plugin that included many plugins so it intruduces a remarkable latency, did you try to disable asio guard for that plugin in VST plugin manager?

Overall, my upgrade from 11 to 13 has been going well and I’ve been enjoying the release. Other than the problem with VocalChain, it’s now smooth sailing. And even with the bug, I can still just insert individual instances of VoxComp, etc. to get the same effect.

Some observations that might be relevant to you coming from 10.5…

They obviously still have work to do on the audio engine as spikes and dropouts have been a common issue for many people since 12. While the problem is obviously on their end (assuming no other changes, if it worked in 11 and doesn’t work in 13, it’s clearly Cubase), it seems like there are ways to mitigate the spikes until they get it sorted.

If you encounter problems, the first thing I’d look at is your third party plugins. Whatever they did with the audio engine, it’s causing some plugins to no longer play nice. If you’re getting drop outs, make a copy of your project so you can be ruthless in your experimentation, and then just start removing third party plugins (don’t disable, get rid of them entirely to remove all doubt). I would do this on a plugin per plugin basis, i.e. remove all instances of Waves Rcomp first, test the result, then all instances of Rverb, test, etc. If there is a particular plugin that’s causing problems, this is a way to identify it.

As you saw in my earlier discussion with Steffan after VC magically started working properly, I then experimented with finding the wall on AsioGuard. I added 18 instances of stock compressors, then started adding VC instances until I finally redlined AsioGuard.

Overall, the random bugs with VC aside, I found that the limit was well within the usable range for the kind of music I do. And of course, your experience will vary a great deal from mine based on what you do, how many and which virtual instruments you use, same with plugins, etc. If I was doing modern pop production that leans so heavily on plugins and effects, my current system might not be up for the job. Fortunately, for me I use Cubase as a glorified tape machine on steroids.

Of course, the other thing that will likely be different in our experience is that I removed 100% of my third party plugins and now just use the stock ones. Naturally, that simplifies my environment immensely, which was the point. Plus, it allows me to really benefit from the no dongle nature of 13. If I still used Waves or iLok products, I would have to continue my practice of moving dongles from one machine to another. Honestly, I’m finding not having to fool with that to be much more enjoyable than I had anticipated.

Most of what I’ve mentioned is probably obvious stuff you already know, so here’s one more. Make a copy of your 10.5 project before opening and converting it to 13. If for whatever reason it just doesn’t work for you, you can still go back to 10.5. If you save 10.5 as 13 and don’t have a backup, then you can never go back. As always, with computers paranoia is your friend.

Personally I’m really enjoying 13 and am glad I made the jump. There were adventures, but that’s just life with software. Hope your experience goes well!

I wasn’t aware of the fact that you could disable AsioGuard on a plugin by plugin basis. How do you do that?

That’s a cool tip, thanks!

Well, I tried to do as Steve suggested and contact Steinberg Support to file a bug report and share the sample project, but My Support doesn’t work so that’s as far as I can go in trying to help.

If any Steinberg devs are reading this and want the sample project to help debug VocalChain, contact me and I’ll get it to you.

Found the bug in the support page link, accessed it, and have emailed the bug report to support.

Select the plugin in the manager and you´ll see an info window at the bottom.

Cool. Thanks, man!