Audio driver error

Connected to a performer today but we could not select his sound device…He uses a Presonus interface…
When VST Performer is loaded up at his end and Connect at my end, his Audio device says generic ASIO…at both ends. When I try to change it to the Presonus driver it reverts back to generic. When the Performer tries he gets - Audio Driver Error. Could not open audio device asio Presonus!"

He tested his card with various recording software and everything is fine…we rebooted his computer and also mine a number of times but came up with the same error. he checked his drivers - Says audio drivers are Upto date and working properly. All his other software works fine with his interface so the problem seems to be with VST Performer/Connect.

the session had to be canceled.

Does anyone know how this can be resolved?

I would double check with the performer: Is the Presonus driver in use by another application?

That’s the first thing I asked, and then asked him to reboot his computer which he did - but no joy… he said he can access the sound card drivers ok until he loads up VST Performer.
I recorded him last week and everything went fine, neither of us has changes anything?

I would try deleting the performers VST connect prefs, they’re in the Steinberg user settings folder. See and search VST Connect preferences

I could see in my Connect the driver we needed but as soon as I selected it it just reverted back to generic asio. When the performer tried to select it from within VST performer he got the Audio driver error.
He rebooted but still the same. He opened his sequencer and the driver was loaded and working, so it seems VST performer is possibly the problem.
I’ll try and do what you suggest tomorrow and fix up another session.

If the problem persists, pls let us know the Performers’ system and which specific interface used.

I don’t have - C:\Users<me>\AppData\Roaming\Steinberg and there, any of the VST Connect .ini files that apply. on my windows 10

If I go to C:\users all that is in there are two folders - Public and studio No files with my name, no AppData etc…
How can I delete the ini files from Connect?

Managed to Unhide folders and got to (theres no Me folder) C:\Users\AppData\Roaming. but no Steinberg folder is there.

I have a session booked for 13:00 today Please help some one How do I delete the Connect ini files.


are you on the Performer’s computer or your own (Studio) PC ?

I’m on my own computer,
Session starts in 30 mins -

found it - users/studio/appData/Roaming/Steinberg - I have now deleted both Pro and SE ini files and am about to start day 3 of my yet unsuccessful session…fingers crossed.

Same thing I’m afraid. The performer is using a PC with Windows 10. He has a Presonus FireStudio interface (just purchased) with the latest drivers installed.

When he boots up VST Performer (4.0.180) he gets a pop up saying -‘Cant open Audio device’. If i got to the performer section in my VST Connect it says Generic ASIO. If I select ASIO PreSonus FireStudio from the dropdown list it goes straight back to Generic. If the Performer tries to select the correct driver from within his VST Performer it shuts down my Cubase…

He has been recording at home this morning using the PreSonus FireStation with the correct drivers without any issues. The problem seems to be with VST Connect/Performer.

On the performer’s machine, not yours.

ah, I deleted the ini files on my computer.
I will contact him today and see if I can talk him through it etc… \

Deleted the performers ‘ini’ files and tried it again but it’s still the same… neither of us can select the correct driver through VST Connect or VST Performer.

Not sure what guidance to give now, with the information at hand, sorry.

My band member (sax player) bought the presonus interface (he uses a PC) and I purchased VST connect Pro so that we could continue with our recording commitments during this pandemic… the setup worked once but doesn’t anymore. I’m having to record the bass parts myself as VST connect will not connect to my bass players Mac system for more than a minute…then we have to reset (we had to admit defeat).
I don’t need to continue with this text for you to understand how we feel. : :blush:

anyone help?

it’s really difficult to diagnose hardware errors remotely as you can imagine.

I don’t know the PreSonus FireStation interface but can you check that obvious things like sample rate are the same as you have in your project - there should be some kind of driver setup software on the performer PC to check all this.

Have you tried changing to the Presonus driver before connecting to the studio ? If the performer is not technically adept can you try using something like teamviewer to take a look

I suspect this is an issue for Presonus support I’m afraid - VST connect just uses the driver provided by the manufacturer.

I find this comment odd:

are you saying that Cubase crashes on your studio PC ? is there a crash file (.dmp) or any error/warning message ? anything in the windows event log ?

There’s no crash file - Cubase just disappears off the screen… I then have to reboot my computer.

We checked the sample rate etc and everything matches…his driver is activated until he loads VST Performer then it changes to Generic ASIO. On my VST Connect it shows two red lights (sync, perform)… I try to select his drivers from the drop down as it is in there but as soon as I select it after a second or two it reverts back to generic ASIO. This worked ok when he first bought the fireStudio interface last week, and he insists that he has done nothing other than use the presonus software that came with the interface (it uses the same drivers)…and he needs to use this as we are having to record and share via Dropbox.
That software is not open when we try to connect, so that has been ruled out…really desperate (and frustrated) about this.

At first I was thinking the problem had to be with his Presonus drivers etc… but he says it works perfectly with everything except VST performer?

Not sure I’ve got this right - do you have both the Presonus and a Generic ASIO device on your machine…? Or, are you only referring to what devices you see available on the Performer machine…?

Can either of you (or both of you.?) uninstall the generic ASIO driver(s) and try again…?

I find this switching of drivers, when your colleague launches Performer on his machine, very strange…

Another thing:- what’s wrong with working with a Generic ASIO anyway…? Does the Presonus device not like it at all…? For example, why the need to switch…? I know native ASIO should be best… this is just an experiment to try.

Just thinking out loud…