Audio Engine Blues and general weirdness

Hi all-having difficulty with Dorico 4 in several ways…
In the middle of a project recording-playback just stopped working, and I couldn’t do anything and had to close out the program via task manager. When trying to open it it does the hang on audio engine thing. Only a restart will-well, restart. The specs:
Dorico 4
Windows 11
Audio Interface - UA Volt 4 (this is pretty new, and at first it didn’t like the driver, but that seemed to sort itself…until now…)
VST in this particular project - Pianoteq Standard 8 (just doing some lead sheets, so just need to hear generic piano notes for input)

I am really trying to move to Dorico from Sibelius but this is not helping. Any great thoughts appreciated. Thanks!

Have you tried swapping out the UA Volt USB audio interface for your older one? Does the interface work fine with Sibelius?

How are you off for RAM?

If you kill Dorico it will hang when restarting as its relationship with the audio engine process is upset.

Are you on an Insider Preview of Windows 11? This can sometimes cause obscure issues.

And neither are your complaints [helping]. Are you suggesting these problems did not happen with Sibelius? But they did they happen with Dorico and UA volt4?

I don’t possess UAVolt4. But Dorico works just fine for me (and with Pianoteq8).

Hey. Thanks for your response. The Volt works fine with Sibelius, Studio One, etc. 32 gig of RAM. Regular ol’ Windows 11 for quite a while. Thanks for the clarity on restarting. Just trying to figure it out. :slight_smile:

1 Like

Hmm…thanks for the response (I think…could do without the snark…). The transition between the two is a bit of a mountain that I am eager to climb, so just stating a fact and trying to figure it out, but not necessarily complaining. And to answer your question, I am not suggesting, I am outright saying that Sibelius, my DAW, everything else works fine with the UAVolt4.

There’s no snark…
… and I have no skin in the UAvolt4 game!

You just have to kill the audio engine manually before attempting to start Dorico, you shouldn’t have to restart your PC. Open Task Manager and shut down the VSTAudioEngine process, then try starting Dorico.

Thank you for the tip. It got me past the audio engine, but Dorico is still crashing on the recovered project. I will explore further in the morn with a fresh boot. Thanks again.

1 Like

Could you please do from the menu Help > Create Diagnostics Report and post the corresponding zip file here? Thanks

Dorico (516.6 KB)


Thanks for the data. According to the logs the audio engine quite often does not shutdown as it should. Then it lingers on and Dorico can’t connect to it any more on next start. As FredGUnn mentioned, make sure that the VSTAudioEngine process is killed before launching Dorico.

But that shall not happen in first place and I wonder why it does. In the diagnostics is also one crash dump contained, but it is of zero length and therefore useless. Could you please have a look in your Documents folder? There is a Steinberg subfolder and in there the subfolder Crashes. Is there only one file contained and that is of zero length?
If there is more contained, please zip up that folder and also post here. Thanks

And one note on Pianoteq. The plug-in is high quality for sure, but I also see quite often crash dumps where Pianoteq is bringing down the audio engine. What I want to say is, not every audio engine trouble is to be blamed at Steinberg. But we still have to find out in your case…

Are you using the actual UA Volt ASIO driver?

Unscientific, but on Windows sometimes uninstalling and reinstalling fixes issues.

Thanks again for the help. There are two crash files, but both are zero. I know to kill the VST process now, even tho last time Dorico started but crashed again.

While I recognize the possibility of Pianoteq behaving badly, a couple things have pointed to Dorico for me. One was that Pianoteq has not had a problem in any of my other software. And pre getting Pianoteq involved, Dorico was not happy when I installed the UAVolt4. It would not recognize the ASIO driver, instead showing a generic one, and would crash when I tried to change it. Somehow that part sorted intself. All that said, I can certainly try a VST other than Pianoteq.
Dorico 4 AudioEngine 5.5.0 64bit 2022.12.1 (456 Bytes)

Smells to me like the UA Volt ASIO driver. Did you uninstall?

I’d uninstall and reboot (to make sure all is purged). Reinstall, then check driver is available in Dorico. Do you have Cubase? If so, can you check the UA Volt ASIO there?

Many users have Pianoteq, with no issues. I’d would hazard a guess that far fewer people have the UA Volt 4 interface (which having looked at the device appears to be a very fine piece of hardware).

Many users use a different ASIO driver other than the one for their hardware. I’m a big fan of Voicemeeter as it sort of magically makes a bunch of Windows audio stuff work, so I’m using the Voicemeeter Virtual ASIO currently. A lot of users have had good results with FlexASIO and I used to use it too. In any case I have fewer issues with the Voicemeeter Virtual ASIO then I did with my actual DAC ASIO (“SPL USB Audio Interface”) so I’ve stuck with it.

I have not reinstalled, but will give it a shot. I do not have Cubase.
I think you are spot on regarding Pianoteq vs. Volt as it is pretty new. And, aside from this, I am indeed pretty happy with it. Right now things are behaving as I drag my Sibelius brain thru some Dorico input. I am getting there. Away Sibelius brain! :slight_smile:

Thanks so much…I will definitely look into those. :slight_smile:

1 Like

I’d also make a point of updating the UA Volt 4 firmware, or at least checking.

As an example of how your mileage may vary, I have attempted to use a paid copy of Voicemeeter Potato over and over again. quite a few times, over a couple of years, but on both my Windows 10 and Windows 11 machines it completely wrecks so much of the Windows audio system and drivers that it is somewhat astonishing something can do so much damage. Worse, it’s really really difficult to uninstall and eradicate it. Why this is I cannot explain, as I am sure there are thousands of happy and content users. Just another one of those complexities of modern life.

Sure wish I could get it to work as it can provide sidetone for headsets with microphones, which are almost all missing it (another mystery to me).

While we are here, it’s curious that Steinberg invented the ASIO protocol and yet there remain lots of issues with various ASIO drivers in Dorico - you see topics here all the time. Of course the party line is most likely that the developers may not have implemented the standard precisely. But still… Perhaps Steinberg has no certification program for ASIO.

As an aside ASIO always amuses me, as an Australian, since ASIO is the Australian Security Intelligence Organisation, our spy bureau. :slight_smile: