Audio Engine not loading

I have a project that uses NotePerformer64 and play_VST_X64. Play is supporting EW’s Silk library. The problem is if I load the project when I first open Dorico 4, the splash screen hangs with ‘Auto Engine Loading.’ If I close the splash and stop Dorico in the Task Master, and re-open Dorico again, nothing happens. Here’s where it gets odd. Restart my PC, open any project that doesn’t use Play, and everything works fine. Close that project and open the ‘problem’ project, and everything works. What appears t the ‘non-problem’ project is loading the audio engine, and the ‘problem’ project takes advantage of it. Any idea what is happening and how to fix it?

Edition Windows 10 Pro for Workstations
Version 21H2
Installed on ‎2/‎12/‎2021
OS build 19044.2251
Experience Windows Feature Experience Pack 120.2212.4180.0

|Processor|Intel(R) Xeon(R) E-2286G CPU @ 4.00GHz 4.01 GHz|
|Installed RAM|128 GB (128 GB usable)|
|Device ID|71366C4C-CAB0-46D9-9EB9-A3DFEC47C483|
|Product ID|00391-50000-00000-AAOEM|
|System type|64-bit operating system, x64-based processor|
|Pen and touch|Pen support|

If Dorico crashes, then the VST Audio Engine process stays running, which will prevent Dorico from connecting to it when you try to launch Dorico again.

Make sure that the VST Audio Engine process is killed before restarting Dorico.

did not worked … i have tried so many times … :frowning:

Hi @odhot , could you please start Dorico and from the menu choose Help > Create Diagnostics Report and post the corresponding zip file here? Thanks

Thanks for the prompt response Ulf, however I cannot even start Dorico … I am on Mac, Monterey.

Can you please have a look at this thread and download the mentioned script file, unzip it, open a Terminal window and execute the script? Thanks

here you go ulf,

It looks like you’re still running Dorico 4.0.31, but Dorico 4.2 has been available since July. I would recommend updating to Dorico 4.2 as soon as you can.

It does also appear that the problem is related to the audio engine being either unable to start or caught in some kind of hang situation.

Are you absolutely sure that if you open Activity Monitor, find VST Audio Engine in the list of processes and end the process, then find Dorico 4 in the list of processes, and end that process too, then try running Dorico 4 again via its icon in Applications, that it does not start up successfully?

Hm, comparing the last logs of both Dorico and the audio engine, then one can see that Dorico actually starts up the audio engine, but somehow they can not communicate with each other, so to me it appears to be an IPC problem.
@odhot , if you type in a Terminal window the command

ls -la /tmp/

could you please post the output of that? Thanks

@benwiggy, Dorico isn’t exactly crashing. Rather, it’s hanging.

When I open the Task Master, what do I look for? I don’t see “VST Audio Engine”. Even when I get the ‘Problem project’ to work, I’m not seeing the process.

@dspredbury, I’m running and still seeing issues when I go to the ‘problem’ project first.

Hi @pkennedy , when Dorico is hanging, that means that most likely the audio engine crashed. Therefore, please do from Dorico’s menu Help > Create Diagnostics Report and post the corresponding zip file here. It will contain crash and log files that will help us identifying the problem. Thanks

Dorico (2.5 MB)

How’s this.

Hi @pkennedy , thanks for the data.
Now, all but one of the audio engine logs are incomplete in the sense that they don’t show that the audio engine did shut down properly. But since there are no crash dump files, it must be that the audio engine somehow deadlocked itself.
Please do restart your PC, then launch Dorico and load the problematic project. Can you then find a VSTAudioEngine process in the Task Manager or even better in Process Explorer? (Process Explorer is a free tool and can be downloaded from here.
If the audio engine shows as not responding, please do a right click on it and then choose from the pop-up menu Create mini dump and post the corresponding dump file. Thanks

When starting Dorico and it hangs on “Audio engine: Waiting for connection”, there is an instance of VSTAudioEngine listed in the process. If you select VSTAudioEngine and End task, then do the same for Dorico, Dorico works okay with all projects. VSTAudioEngine does not start up when I restart Dorico. It seems I have a workaround that doesn’t require me to restart the PC.

I’m going to install the update and see if that makes a difference.

1 Like

@Ulf, Moving to 4.3 seems to have fixed the problem. I’ll keep a watch on the issue and let you know if it comes back.
Thank you

1 Like