"Audio engine process died" every single time with Dorico 4.3

Hi forum. I’m getting the “Audio Engine Process died" error every time I try running Dorico 4.3. I’ve tried the usual first-aid solutions, including rebooting and re-installing Dorico and Halion multiple times.

I had no problems with Dorico 4.2 (no longer on my system) and 3.5 (still on my system) runs just fine. Other audio apps are running fine. I’m on OSX 12.6.1.

Has anyone run into this issue with 4.3, and if so were they able to resolve it?

I wonder whether it could be a licensing issue? Do you have the most up-to-date version of Steinberg Activation Manager installed? Is your Dorico Pro 4 license correctly activated?

If you can’t get Dorico to start all the way up, you could try using the scripts in this thread:

to generate an ersatz diagnostics report that you can upload here, and we can then take a look and see if we can figure out what’s going on.

1 Like

I’ll give all of the above a shot! I was able to re-install 4.2 which works fine, so there’s no immediate crisis.

If you have 4.2 now running you can also create a diagnostics report with that one. Dorico keeps the logs of the last 10 runs, that should give us still enough to look at.

I have the very same issue - no matter what I tried, 4.3 wouldn’t start. First it hung at “audio engine process died”, then, after updating the Activation manager it instead started hanging later in the start process. Reinstalled 4.2 and all is well. 4.3 appears to be a dud version! (I’m running it on a late -17 imac, with Ventura)

Hi @enor,

no, Dorico 4.3 runs fine on many many other machines, so it is not a general issue.

But could you also please post a diagnostic report as it hopefully contains still logs from your attempts to run 4.3.? Thank you very much

Sure, here you go!


Dorico Diagnostics.zip (1.93 MB)

Thanks very much. There is a crash file of the audio engine when you were on D4.3, so I will analyze that one and come back…

Hi @enor, so the audio engine crash is actually in Groove Agent.
Could you please confirm that Dorico 4.3 runs fine with you without Groove Agent?

You can have Dorico 4.2 and 4.3 installed in parallel. Simply make a copy of the Dorico.app in the Applications folder and rename it to e.g. Dorico4.2.app. The remaining Dorico.app you then can upgrade to 4.3 and voila, you can start one or the other to get the wanted version.

Before running 4.3 move temporarily the Groove Agent bundle out from /Library/Application Support/Steinberg/Components (e.g. to your Desktop) and see if it starts up then.

Yes sir, starts up normally without Groove Agent!

Thanks, gonna throw GA away, I don’t know when I last used it anyways.


This is great. I returned to this thread to find that someone else solved my problem with no work required on my end. If only life were like this more often.

1 Like

I just transferred a license of Dorico over to my new computer, and am now getting the “Audio engine process died” message on the startup too. It hangs indefinitely until I force quit, after which the next attempt to launch is usually successful. So basically, it takes at least two attempts to launch Dorico every time. Whether I open Dorico on its own or by double-clicking a Dorico file, it’s the same result. I’m used to having to force quit Dorico on a regular basis, but having it happen right out of the gate seems excessive. It’s a new installation on a new Mac running 12.6, if that helps.

I tried to follow the solution earlier in the thread by removing “Groove Agent”, but I don’t even have it to begin with (there’s no /Library/Application Support/Steinberg/Components folder at all on my machine).

Any suggestions welcome. Thanks!

It’s the user library if I remember correctly. You need to press Alt while clicking on the Go to menu in the Finder to make it appear.

Thanks for the suggestion, Marc. I looked in both the user and system library folders before posting, and neither contains a “Components” folder. Maybe this is part of the root problem?

There really will be a Components folder, because that’s where e.g. HALion Sonic SE is installed. To make sure you find the right place, in the Finder choose Go > Go To Folder, then paste in:

/Library/Application Support/Steinberg/Components

and click Go. The folder you’re taken to should contain at the very least a file called HALion Sonic SE.vst3.

Hi Daniel,

Thanks for the reply. I’m not sure what to tell you… I’m in that folder, and here’s a direct copy of all the paths found within it. All are subdirectories except for the last one, which is a file.

/Library/Application Support/Steinberg/Dorico 4
/Library/Application Support/Steinberg/Activation Manager
/Library/Application Support/Steinberg/Content
/Library/Application Support/Steinberg/dependencies
/Library/Application Support/Steinberg/Download Assistant
/Library/Application Support/Steinberg/Install Assistant
/Library/Application Support/Steinberg/MediaBay
/Library/Application Support/Steinberg/MediaServices
/Library/Application Support/Steinberg/Steinberg Library Manager
/Library/Application Support/Steinberg/VST3PresetCompatibility

I performed a search within the folder itself (both through the Finder and using Terminal) and there’s nothing called “HALion Sonic SE.vst3”, and nothing with the word “Components” in it anywhere.

I assume you’ve not installed HALion Sonic SE and the sounds because you don’t intend to use them? If you are hoping to use them, you should probably install them!

But in the meantime, we should check out what’s really going on. Can you try running the shell script linked to in this post in the FAQ thread and uploading the resulting zip file?

I installed everything that came with Dorico 4, per your instructions from an October 2022 thread, and indeed went through the HALion Sonic SE installer, which claims to have completed successfully.

I appreciate your willingness to look into the diagnostics, but honestly, I’ve been dealing with bugginess and workarounds in Dorico for too long now, and the fact that it won’t even install properly on a new computer is the last straw for me. Thanks anyway, though.

I’m sorry for the inconvenience caused, and I hope you will persevere. I’m certain we’ll be able to solve this if you’re able to provide me with the logs, so I can see what’s happening.