Audio Engine Timeout, Dorico won't start

Hello,

I just recently got an email back from support containing my trial activation code for Dorico. I installed, setup the eLicenser, and was ready to go. The splash screen comes up but hangs on “Initializing Audio Engine.” Eventually, it timesout saying “Audio Engine Timeout” and continues to hang until I force-quit Dorico and VSTAudioEngine in Activity Monitor. There are also several instances of vstscanner running.

I’m on MacOS 10.13.4. I’ve ran the cleanup_prefs_and_engine script mentioned in another thread. I’ve also tried restarting the machine several times. I’ve also uninstalled and reinstalled Dorico. I’m at a loss of where to go next. Attached are the Activity Monitor screenshot, VST prefs folder, and Dorico prefs folder.

Thanks in advance for your help! I’m really looking forward to trying Dorico. I’ve followed Daniel since around Sib3, and can’t wait to see the product of the team’s hard work!
Cody


VSTAudioEngine.zip (4.84 KB)
Dorico.zip (6.88 KB)

I’m having similar problems. I think a fairly reliable workaround for me is to force quit Dorico (and the VSTAudioEngine process if running), start the VSTAudioEngine separately (by using the search (Cmd-Space), typing “VST” and hitting Enter when it finds it), and then start Dorico again. Seemed to have worked for me in the past.

Thanks, that actually works.

Interesting that you guys found a workaround, but I wonder…

Do you have to do this workaround every time you want to start Dorico?
If not, how often? Every now and then or frequently?

This makes me uneasy, because it should work without fail every time and I want to find out more about it.
Unfortunately, the log file of the audio engine that Cody posted is completely empty, so that does not give me any hint.

If you have Dorico running, could you please choose from the main menu Help > Create Diagnostic Report.
That creates a zip file on your desktop, please send it to ‘u dot stoermer at steinberg dot de’.

As I say, I’m really curious and want to find out more in order so we can make it more reliable.

For me this happens occasionally. Usually, if this happens, Dorico will start and show me the hub window, and if I click a recent project to open it, it will get stuck at 60%. I think I had it just once that Dorico wouldn’t even get to the hub and stall at the loading screen.

About to send that your way, Ulf. I’ll also include another (current) copy of the VST and Dorico folder zips.

In case it helps, the only time this has ever happened for me is in an earlier version, when - as we know - the VST had stalled.

I guess I’m suggesting that the phenomenon could well be VST-specific???

Cody and Stephan,

thanks for the data. I had a look through but could not find anything obvious so far. In the fault case the audio engine log just breaks off at some stage, which suggests that the audio engine process crashed.

If you go to /Users//Library/Logs/DiagnosticReports are there any VSTAudioEngine_*.crash files?
Please send them to me. If there are many, then just send the most recent 5.
The crash files will give us the best insights.

Many thanks.

Thanks Ulf, I updated HALion Sonic SE to the latest version, as you instructed via email. So far no hang-ups have occurred. However, ever since, my MacBook doesn’t go to sleep mode anymore if I close the lid, and the VST Audio Engine process is constantly using 25% CPU memory once I have Dorico open (and actually input something). This worries me a little. :frowning:

Hi Stephan, when you say “25% CPU memory”, do you mean 25% of the cpu performance or 25% of the RAM? The usage of RAM depends on the size of project you are working on, i.e. how many players are in the project and how many HALion instances are loaded. The CPU usage depends on what you are doing. If you are not playing back the audio engine shall not use more than 10% of the cpu, but during playback this can go up to any number. However, once playback stops this shall go down after a few seconds again.

Regarding the sleep mode, same should have already happened before your HSSE upgrade. If Dorico is in the foreground, the audio engine will keep the computer alive, because it is derived from Cubase’s audio engine. In an audio workstation you don’t want your computer to fall asleep while you are in the middle of a recording session, so we prevented this. Try pushing Dorico into the background before closing the lid.

Dear Ulf,
I regularly find it to be much more than that - often between 25-40%, even when Dorico is running in the background without any form of activity. As I write this post, the audio engine is using 39% CPU on a 2017 MBP with 2,8ghz i7 processor. If I disable all VSTs in Dorico, it goes down to 10%.

Because of this, I never let Dorico run in the background. I hope this is something that can be improved in the feature.

Sorry for the confusing terminology. So, I just opened a project with 27 players and haven’t touched anything (no note editing or whatever), and the CPU tab in the Activity Monitor shows about 25% CPU usage by the VST Audio Engine process. Another project with 32 players shows a constant CPU usage of 42–45%, even when I’m not doing anything.

I have a 2012 MacBook Pro with 8GB RAM and OSX El Capitan (10.11.6).

Hm, I’m usually a Windows guy and use my Mac not so often, so I switched it now on to have a look.
And yes, even on my iMac with a Core i5 and a large project with 4 HALion instance I have a base load of around 30% for the audio engine.
So I dare say your figures are quite normal.

Was it that much different when you used HSSE2? Or did you maybe just not notice?

On my iMac I switched back to HSSE2 and get the same, if not slightly higher base load compared to HSSE3.

I’ve only noticed since installing HSSE3 that my computer is getting warmer than usual – and the sleep mode thing (but it might be coincidence that I never had Dorico in the foreground when closing the lid before). And closing the lid is basically like deliberately forcing sleep mode so I don’t quite see why it should prevent sleep mode in that case.

Because the audio engine has it in it’s genes, i.e. it has code that actively prevents the computer to “fall asleep”.
On the other hand, I don’t have a MacBook, just an iMac, but when I choose Sleep from the system menu then it does go to sleep even if Dorico is in the foreground.

Yes, that’s true. And closing the lid should be the same as actively choosing sleep from the System menu. But we’re digressing; that would perhaps be a subject for a different thread.

How do I switch back to HSSE2? By uninstalling HSSE3?

Uninstalling HSSE3 is not trivially simple because it’s a shared component, but if you delete HALion Sonic SE.vst3 from /Library/Application Support/Steinberg/Components/ and then run the “Dorico Playback 1 – HSSE” installer from Steinberg Download Assistant, that should restore HSSE2.

Note that we do plan to ship HSSE3 with the next version of Dorico since HSSE is a shared component used by all of our products, and HSSE3 is included with the current version of Cubase, so you will get HSSE3 back in due course anyway.

Yeah, Ulf told me that already in an email recently. I just wanted to see whether the performance differences are real or I’m just imagining them.

Stephan, sorry, I forgot to mention something. In the Dorico Preferences, choose General and scroll down all the way to the Play section. There, tick the option “Suspend audio device in background”.
You can also check in a terminal window, type ‘pmset -g assertions’. That shows you the status of PreventUserIdleSystemSleep and below in the list of owning processes, which one is preventing the sleep. With “Suspend audio device in background” PreventUserIdleSystemSleep will change to zero as long as Dorico is not in playback.

Ah, thanks Ulf, much appreciated. :slight_smile: