Audio engine waiting for connection/attached to audio engine

Hi,

Dorico was working fine and now suddenly I only get as far as the first screen where I either get the message - ‘Audio Engine waiting for connection’ or ‘attached to audio engine’

Nothing then happens until I get a audio engine timeout message.

As I say it was working fine and I am not aware of changing anything.

I have tried rebooting a few times - no difference.

I have tried a couple of other programmes - Audacity and Spotify and they both work fine through my steinberg UR44. I have checked that there are no other programmes running that might be using the audio engine.

I have downloaded the script from the frequently asked questions section and attempted to run it (not something I am that familiar with) but get syntax error. (I copied the txt into the script editor and then pressed run)

The only other ref I can find to this problem mentions Wave plug ins that I don’t have.

System details
macOS Sierra ver 10.12.1
processor 4 Ghz intel coe i7
Memory 32 GB 1867 MHz DDR3
Start up disk Mac HD
Graphics AMD Radeon R9 M395X 4096 mb

Update,

It seems to be working again,

The only thing I have done is disconnecting my ethernet connection (to broadband router and NAS). And then tried relaunching Dorico - I don’t know if this is coincidental, or for some reason would make a difference.

Update,

Now the I’m getting a message that it isn’t recognising the licensing software.

Too be honest I think I will take a rest from dorico for a while until there have been some updates,

Could you take a screenshot of the error message you are seeing and post it here?

Same problem for me…
Screen Shot 2017-10-19 at 10.23.16 AM.jpg

If it gets stuck in that state try looking for the ‘VSTAudioEngine’ process and killing it and start again. If that doesn’t fix it then try killing the Synsopos process if that’s running.

Dear Paul,

SOLVED - Restarting the computer solved this issue.

Same problem here on Mac today. Instead of restarting I opened the Activity Monitor, searched for VST (audio engine), then force quit the process. I was able to start Dorico normally after that.

Yes this is still also a frequent (and nasty) issue with me. Would be awesome if you could come up with a fix for this.

Yes this is still also a frequent (and nasty) issue with me. Would be awesome if you could come up with a fix for this.

If this is happening to you then that means that Dorico or the audio engine are crashing on your system. In the Help menu choose Create Diagnostic Report which will create a file DoricoDiagnostics.zip on your desktop. If you attach that here then we can try to isolate what is causing the problem.

I’m afraid I’m getting a similar issue. My system is hanging five or six times every startup for about 30 seconds a time (both before the initialisation screen has appeared, and during ‘Audio engine: waiting for connection’). It’s been happening since I have been running 2.1 and Noteperformer 3, don’t know if that’s part of the issue? I’ve made the diagnostics file, where would be the best place to send it? Cheers. :smiley:

Hello

I tried to launch Dorico 2.2 trial version on a MacBook Air 2015 running on Mac OS 10.14. almost a month ago on my brother’s computer and reinstalled it today.
I didn’t installed any sound library from the Steinberg download assistant.
I uninstalled e-licenser and downloaded the latest version on Steinberg Website.
I installed the e-licenser latest version and performed a maintenance operation. E-licenser was working properly.
I killed VST Audio Engine using the Activity Monitor.
I restarted the computer several times.
I have the same error message when I start Dorico (Audio engine waiting for connection) and get stuck there.
I have no way to perform a diagnostics for I never pass this error message.
Since the installation of Dorico 2.2 was made almost one month ago, and I never passed this error message, the trial version ends on December 30th 2018 (tomorrow).
That’s sad for my brother might never be able test it even if I told him many praises about Dorico.
I tried contacting Steinberg, but they told me it’s not their problem.
If you could fix this problem and give my brother an other trial version, he would be very grateful.

Best regards

Cyrdup, jonathanspacey, have you both tried the following? It’s been suggested in a few threads…

  1. Restart computer.
  2. Run eLicenser Control Center. Leave it running.
  3. Start Dorico

Cyrdup, I very much doubt that anybody at Steinberg would have told you that this is not our problem. I imagine you may have misunderstood something that my colleagues told you. I will send you an additional 30-day trial code that you can use to extend the trial on your brother’s computer via private message. I agree with Leo’s advice that you should run eLicenser Control Center and leave it running on your brother’s computer; you should then hopefully find that Dorico can be started reliably.

1 Like

Please send the diagnostics to ‘u dot stoermer at steinberg dot de’ with a link to this thread.

Dear Dorico team.
I have encountered a problem, and I would appreciate it very much if you could help me as soon as you can, as I need to finish and print a piece for the first rehearsals coming up very soon.
After upgrading my macbook to 10.14.6 (I don’t know if it is related to that, though. It has happened earlier also), Dorico hangs on “Audio engine: Waiting for connection”. Sometimes it, after some time, gives a message saying “could not connect to coremidi. you should restart your system”. And then usually, Dorico starts and works. I am attaching the zip-file i have seen you ask for some other places.

Let me also use the opportunity to say that I am indeed very happy with the program. It is my first notation software – I have always written by hand, and thought I would destroy the computer of frustration if I started with a notation program. But even now when am in a bit of trouble here, I still have good feelings for Dorico. So you must really have done something right!

Best regards,
Håkon
Dorico Diagnostics.zip (562 KB)

Update: I connected the usb-licencer, and then I managed to open Dorico.
But some messages were coming. I attach screenshots of them. And then the pointer turned into the watch, and everything was stopping. I had to force quit, and then it was again hanging at “Audio Engine: Waiting for connection”.

Here is a new zip-file also, now that I managed to enter Dorico.

Please, please, if someone can help me I would appreciate it very much. I have a rehearsal tomorrow and need to get out things from Dorico. I am in a bit of trouble here, actually.

By the way, I never use the audio in the program. I have set everything to silent. If this can have something to do with anything, or if there is some way of using the program without having to connect to the audio engine, please tell me.
Screenshot 2019-08-13 at 22.11.06.png
Screenshot 2019-08-13 at 22.02.33.png
Dorico Diagnostics.zip (401 KB)

Dorico has to connect to the audio engine, yes. Even if you aren’t using it.

Thank you! Do you have any advise for me?