Audio engine waiting for connection/attached to audio engine

You’re welcome :smiley:

Issue was an iLok issue for me. iLok wasn’t showing up due to a funky USB port. Changing ports fixed everything.

Hey Fellow Dorico Users -

I was having this problem too, and solved it myself with some troubleshooting. I thought I would share the information here just in case it’s useful to the team/other users:

Short version: Somehow, other libraries are slowing the loading of Dorico down, as least in my situation. So, another thing to try is: Put just the Dorico license on a USB Key and then take all your other keys out, and try again. In my case? Loads in <20 seconds.

How I figured this out:
I was experiencing slow load times, up to 2 minutes, when updating to 3.5.12 I think? So, I tried everything I could: Roll back, etc. I even tried fresh install on a new computer. Same problem?!

Then, on a lark, I tried an old key I had with an ‘All product Demo’ license: ZOOM.

Then I tried again with my keys - slow.

So I moved my Cubase, Dorico, Groove Agent keys to their own separate key and tried it: SLOW.

Removed my keys that are packed with probably 70% of everything VSL ever sold (Synchron and VI) - ZOOM. Loaded in seconds. I was then able to put those keys back in, and access those libraries.

So: Steinberg - what’s up here? and fellow users: If you have keys loaded with libraries accumulated over years, and are experiencing slow load times with the ‘Audio engine/waiting for connection’ stall? Try moving your Steinberg app licenses to a new key and see if you still have the problem.

Happy composing,


Hi Eric,
how are your VST2 search paths set up? Also please do ‘Help > Create Diagnostics Report’ and post the corresponding zip file here. Thanks

Hi Ulf - sorry for the long delay in replying. I’m not a professional musician, so my day job was calling…

My VST’s are a mess - it looks like I have duplicative paths:


Dorico (2.2 MB)

Is the duplicative paths my problem? We’ll see if this image pasted or not…



I also see du
image plicates of, say, Vienna Instruments plugins…

Hi Eric, 2 problems you have. First, your VST2 search path is too general. You search the whole Program Files folder with all its subfolders. You need to be more precise and specific about the search location.
Second, about the double listing, some plug-ins come in two flavours, i.e. VST2 and VST3, e.g. the Vienna Synchron plugs. You have installed both flavours and also whitelisted the VST2 versions, thus they appear twice, once the VST2 and second for the VST3 version. Have a look for the doubly entered plugs and remove them from the VST2 whitelist. You shall always prefer the VST3 version.

Hi There!
Wow! Too many replies! I couldn’t really read all of them. My Dorico 4 waiting for connetion FOREVER! It won’t open! Is there a defitly solve for his issue?
Thanks all

1 Like

@Mi_Barbaro , yes there is. If you are on Mac take a look here. If on Win, do the same as proposed in the other thread, but search for components in C:\Program Files\Common Files\Steinberg\Shared Components

1 Like

Hey Ulf,
I had Dorico 3.5.10.
I tried to install Dorico 4 till I had to learn that my system (OS X 10.13.6.) is too old.
Then I installed the update at least.
All good so far.
What happens now is: I can start Dorico 3.5. exactly 1 time. I can’t close it anymore. If I force it to close, I can’t open it again (‘waiting for connection’) before I didn’t restart the computer. Then again the same: Open it 1 time, force to quit, restart my computer, and so on…I tried to run it during the eLicencer was open: no improvement.
in attachment all files which maybe could help you.
I can’t upload /ApplictaionSupport/Steinberg/Dorico3.5 because it is too big
I really hope you’ll find a solution.
Peer (1.5 MB)
Dorico 3.5 (332.9 KB)

btw, I always get: ‘waiting for conncetion’

And this is what the crash-report says which I could send to Apple - don’t know if that is of any help

CrashReport.pdf (1.5 MB)

I found the DiagnosticReports with the problems of today: (3.2 MB)

@Jazzisfaction , sorry to hear about your trouble. I know what it is, the problem is HALion Sonic SE.
Because you installed Dorico 4, you also got the new HSSE 3.5 with it, but unfortunately that one is not compatible with Dorico 3.5 anymore (It’s a bug, we will hunt down).
In the meantime, you have to uninstall HSSE 3.5 and revert to 3.4 which you can still download from HALion Sonic SE 3 updates and downloads | Steinberg
To uninstall simply go to /Library/Application Support/Steinberg/Components/ and throw out HALion Sonic SE.vst3
After that run the installer for 3.4 and it will be fine again.

Ulf, you are a genius…thanx so much. It works again perfectly.
Thanx so much for your FAST help. Super !!!

Btw: sorry to say that, of course it’s great to have Dorico 4, but it’s a pity that it doesn’t run on the old MacPros anymore. I’d like to buy a new one but I have to wait till they finally can implement the M1 into the MacPro.
So now I have Dorico 4 on my Laptop and have to work with 3.5 on the MacPro…but of course you guys can’t take all that into consideration.

1 Like

Damn…I was too early…when I try to open I file which I tried to open when HALion 3.5 was still on my computer, I have the same problems. Is there a sth like a cache which you can empty?
But for all other files everything works perfectly now…so it’s just a minor problem.

I’m ready to quit steinberg and Dorico as much as I love it, if I can’t get into it what good does it do me. I’ve updated, I’ve rebooted (I came close to just BOOTING it) and I get S far as the audio engine and it stops, nothing more, it’s a lovely screen.

Funny/not funny. Right after I sent that, for some reason it got all the way in, I was thrilled, got 2 and 1/2 measures of ONE PART, in and……it stopped, and now it’s mocking me with the same old audio engine message. Why can’t this be fixed if it’s a problem?

Welcome to the forum @pthompson1 .
Do you maybe have HALion Sonic 7 installed?
There is a known issue with it and a workaround described in this thread.
If you don’t have HALion Sonic 7 installed, please reboot your machine, start Dorico until the hub window appears and then do from the menu Help > Create Diagnostics Report. The corresponding zip file please post here. Thanks

Where is said help menu? I’m computer literate but too often I have to be a programmer to work with your program.

The Help menu is in Dorico itself: it’s the last menu along in the menu bar in the Dorico project window.