Audio Hardware Setup! Now it's there, now it's not!

I’ve just experienced this with my UR28M and the most up to date version of cubase 9.5.21. I upgraded straight from 8.5. It has happened twice. The first time I was able to get the audio hardware option in the Devices menu back again by removing and reinstalling completely the Yamaha tools and drivers. Let me also mention that the hardware rack also dissapears from the rack panel visibility menu making it impossible to use the dsp mixer and FX for monitoring…
The second time, I tried to do the same, and even though the Audio Hardware option now appears on the device/studio menu, and the audio hardware window appears with all its common options when selected, still having issues with showing the hardware rack correctly on the mixer. I can still select the hardware rack to appear on the rack panels, but when I click that actual rack panel on the mixer, its like it is stuck and wont display the usual routing diagram. What I mean is that the panel won’t scroll down to allow me to see the usual diagram configuration… Just found this thread, the fact that it goes all the way to 2016 is a little bit discouraging. This software and hardware should really work seamesly…

Yes, it should.

This has caused me so many issues that most of the time I’m now back to using C7.5, where it works!

The workaround is working for months now for me. Delete the file under C:\Program Files\Steinberg\UR824\plugins. It will be automatically created a new on next Cubase start up.
On startup of Cubase, it pops up a box asking to remember the Audio driver. Do not check the box to remember.
You will have to confirm that box on every Cubase startup but the Hardware Menu is working.
There is also another workaround with an old Tool called Push the Freaking Button.
You can use it to confirm that dialog automatically. I found an old version of Push the Freaking Button on the web some time ago but I do not use it.
I just confirm the Dialog on Cubase start up by hand.

Same here. It’s stable with the workaround on 9.04 PRO

A little late, but just saw this thread and have been battling this issue for months. When you say say “delete the file under”… what file exactly? I use an MR816 interface but figure it should look the same,…just making sure I don’t screw things up more.


Sorry. There is a misspelling. There is only one file if you go to:
C:\Program Files (x86)\Steinberg\UR824\plugins

This file will be created automatically again when starting cubase

Sorry, but are you saying to delete that entire path? Will this not screw up the plugins?

I haven’t done the “delete” yet for fear of more damage. I did update the “Tools For MR” to the latest version and sure enough, I at least now have “audio hardware setup” available from the “studio” drop down. The problem is now I do not have the “hardware” showing in the mix console, and subsequently can’t use reverb while tracking, which is a major issue.

I can load a previous project that did have the hardware in the mix console, it’s still there and I can still use reverb on input channel. When I load a new project now, as stated, I do have the drop down hardware setup available, but even when I launch it, and select “cue 1”, for example,… then select reverb for cue 1, I still cannot get the reverb to work.

Any clues at all? This is maddening for sure. Is there a way to get the “hardware” to show up over the input channels in the mix console?


I don’t actually know what file he is talking about. There is only one dll there on my system… you could move it somewhere else and see what happens.

OR…try this IF YOU DARE-
launch Cubase without yout MR816 powered on… it should prompt you for some other driver.
Choose whatever.
Shut down Cubase.
Power on your MR816
Re-launch Cubase… it should re-prompt you!

Now you have completed the cipher. Never tell it to ‘remember this audio device’.

Has this issue been fixed yet?? I’m running cubase Pro 9 with a UR242 interface and I have the exact same issues as outlined in this thread.

Sometimes it’s there and sometimes it’s not. I have a MacBook pro.

Could someone tell me where to navigate to delete the plug-in file so that next time when I boot up cubase, I get the interface selection pop-up?? I had accidently selected “remember this choice” initially and hence the pop-up doesn’t appear anymore.

I’ve been having this issue for the past 3 years and finally found this thread!!!


I just started Cubase without the interface turned off, forcing the pop-up to appear. I’ve experienced no problems since - about a couple of years. Other than having to click “yes” in the pop-up each time on startup, but that’s a minor thing.

This doesn’t work for me! Also tried this:

Is THIS bug persistent in Cubase 11?

(honestly eliminate just ~one~ of my workflow annoyances and I will upgrade)

Cubase 11 Pro with a new UR44C and I don’t have the hardware rack. WTF?!

My previous UR44 had crackling and popping from eventual wear on the solder joints in the jacks. Tried to have them professionally fixed but no. The input jacks (1/4" or XLR) are also Yamaha specific. But wait, there’s more! So I spend an hour on the phone finally getting to the parts warehouse in CA where the person had a horrible time trying to find the part numbers, then learned no one ever set them up as an inventory item. So these $300-$400 interfaces, that have been sold for years in the US have NEVER needed these jacks replaced?! Of course covid AND holidays were happening so I had to wait 2 weeks for the part number to be set-up when people were back to work. . .it was never set-up. I had to buy a new interface and really wanted to not get something Steinberg again, but I got the UR44C. Once the parts were set-up, it would take 8 weeks to arrive in CA by ship. So 3/4 of a year later, I finally have the jacks to fix my UR44 to keep as a spare or sell. But wait, there’s more. In the DSPMix software, I have to constantly go into the software and Solo the DAW because unwanted signals and don’t know how to stop them. I’ve spent months (hours) trying to figure that out! The UR44C manual, page 5 shows you can click a button under Studio-Studio Setup-Steinberg I/O-Steinberg UR-C which says “Load scene data from project file”. But I can’t find anywhere that tells you where, in the project file, to assign a “scene”. I’m not totally sure I understand what a scene is or how to save it in the DSPMix software. After more research, I saw a vid, with older Cubase where he brought up the Hardware Rack and I thought, AH-HA! Maybe that’s the place. Since there’s no freaking Hardware Rack, I guess I’ll never know.

I don’t know if the DSPMix is removing the DAW Solo button I click after computer reboots, Cubase reboots, different projects or just randomly. Nothing would surprise me.

The other day I made an hour available to sit down and play some electronic drums, using Superior Drummer 3 and Cubase. Instead, I spent an hour troubleshooting some other issue that came up. I’ve lost track of the times I’ve needed to jot down ideas and lost them because I run into some kind of issue. Then there are the hours lost when I don’t have an idea, I just want to know how to do something that has a chance of being simple but instead turns into months of experimenting, reading, watching, posting and giving up. Seriously Steinberg?!!!

PS - I haven’t read through all the previous threads or tried any of the solutions yet. I just don’t have it in me after the 1.5 hours of messing with this.

So…it sounds like the bug IS persistent in v11?

So Cubase 11 Pro and the UR44C still have this issue.

I’ve tried deleting the file under C:\Program Files (x86)\Steinberg\UR-C but now there are many folders and files so I didn’t know which one to delete:

So, I uninstalled the Tools for UR44C. I unplugged the unit, rebooted, started up Cubase with an empty project. It asked me to select a driver but there wasn’t a checkbox to always use this driver.

I unplugged it again and started Cubase and chose the Generic Low Latency ASIO Driver. Opened a project template. Still no Hardware rack. I chose the Yamaha Steinberg USB ASIO driver and got this message:


I chose to switch. Still no option to check a box to always use that driver.

I have another laptop with Cubase and tried the same things, but no Hardware Rack comes up.

Update on my UR44C. I’m partially at fault for what I thought was the hardware rack missing on the mix screen. I must’ve re-read the manual a million times but somehow my eyes always skipped over the one, standalone sentence saying the hardware rack for the URC has moved from the mixer to the Project Window under the Inspector Tab.

As of now though sometimes it appears and sometimes it doesn’t, in the same project if I click on different tracks. I’ll attach pics of one audio track having it and another doesn’t.


Has it:

I’ve recently learned there are YouTube Cubase Livestreams on Tues & Fri at 1 pm on Steinberg’s channel. The host Greg Ondo does a fantastic job of answering questions like this from the live chat or e-mail.

1 Like

been searching hours for this answer! Thanks for sharing :slight_smile:

No problem! Glad to pay things forward. I’m glad you responded as I forgot to post the last thing I learned…If the track doesn’t have the UR44C as a bus, the hardware rack won’t appear for that track. It makes sense, since if Cubase doesn’t have an interface defined, and people use several interfaces, it wouldn’t know which one to list and it would be good to list them all. Hope this helps!