Audio Hardware Setup! Now it's there, now it's not!

Another frustrated user.

I’ve come to the conclusion that the hardware rack settings are also written in the project file itself. Couldn’t get the hardware settings to reappear following everyone’s instructions above. But I was always opening an old project, created originally pre-Cubase 8.

So instead, I did the ol’ driver changeroo, and instead, created a new project. And the hardware settings were there.

Next, I went back to the trouble project. Audio Hardware Setup WAS in the device menu. BUT, there’s no hardware option in the racks list! And I have not managed (yet) to find the magic to bring that back on this project.

When I got the racks back, I created an empty project, and in the racks, opened up the Hardware section, and saved it that way. So far, that project always opens up OK. But, when I open up a trouble project, they are still missing.

The real frustrating part is that I would be better off if I was using a non-integrated non-Steinberg interface. Not a good message…

Any news on this?

How can you work when the Hardware-Setup appears just randomly?


Cubase 8.5
Windows 10

Pls see my post above. I offered a workaround for this that gets the menu back every time you start Cubase.

Hello rtorstrick. We are back again. DEL GRIN also read along after his comment :wink:

Thanks rtorstrick. The Workaround works.

Still this procedure feels like an inconvinience to me, which I want to be fixed.

Thanks to Funk Master, too. He noticed what happened when it was present, I just figured out how to satisfy that condition when starting Cubase. I agree that this should be fixed. It would seem that a simple fix (maybe not an elegant one) is suggested by our workaround. It should be easy enough to just force Cubase to rescan the driver each time it opens, even if the user doesn’t see it happening. But then, I’m not a programmer.

I’ve had a recurrence of the mix console display problem after the most recent Windows 10 update. A new project did not show the Hardware tab in the mix console. To solve this, I opened the Audio Hardware Setup dialog box (always available now after the workaround noted above) and on the Settings tab I switched the assignment of the Morphing Channel Strip to the Digital I/O. Suddenly the Hardware section tab (closed) showed up in the Mix Console. I then switched it back to the Mic/Line I/O and it disappeared again!

I repeated this a few times. Once, it appeared as expected only to disappear when I simply clicked on it to open it! Eventually it opened up with the channel strip open and I was able to use it normally. Once the Hardware tab is fully open in the mix console, I have found the entire tab section to disappear completely upon closing, tab and all!

This is certainly bizarre behavior. And unpredictable. Sometimes it behaves as it should, and at other times it plays the hide and seek game.

Please, Steinberg, we need some attention to this issue. Is anyone listening to us?

I have the same problem, and it’s been reported to Steinberg support.

Just for information, if you end up with the option missing having ticked the “don’t ask again” box when Cubase first asks if you want to use the MR you can get it back by editing the defaults.xml file in the %USERPROFILE%/AppData/Roaming/Steinberg/Cubase 8.5_64 folder. Just remove this section …

         <string name="Group" value="YamahaService"/>
         <member name="Values">
            <int name="PJ-ASIO" value="1"/>
            <string name="PJ-DATE2" value="DATE: 10-15-2016 TIME: 16:56:18"/>
            <int name="SETUP-PJ-ASIO" value="0"/>

This saves having to reinstall drivers and stuff like that.

This is on a PC - no idea about the Mac version sorry. As always, back up the file first in case things go wrong!


G’mornin’, Gents & Ladies… Does anybody know whether this issue has bee resolved in Cubase 9? I’m on Cubase 8.5.2 with a MR816x, and have been plagued by this bug for quite some time. Would gladly purchase Cubase 9, if I knew this “feature” is reimplemented.

Unfortunatly not. In fact the problems came back to me no matter the workaround i had gone before. But i found a new solution and alternativ than reinstalling the driver. If You install the 64 bit driver all the UR Stuff is listed under programmex86 on windows maschine. But only one File not. Go to the folder of the UR under Programms (64bit) rename the .dll file in there. Then Cubase will configure the driver again. I had to do this because reinstalloing the driver didn’t helped anymore. I use an old version of the Tool named PushTheFreakingButton for a workaround. I guess this is written somewhere above here. Just don’t check the box for remembering the driver which pops up on cubase startup. I Use The PushTheFreakingbutton Tool to press OK on the Pop-Up window on Cubase-Start-Up automatically.

As rtorstrick was kind enough to mention in the other thread about this topic, there’s a new driver available for the MR816, which (so far) seems to have solved this issue. Just figured you guys might benefit from that info! Get it at the Steinberg download page, and have at it!!

Hi, I was also experiencing the same issue with my system. it was very frustrating. thankfully I recently upgraded to Pro9 and it is now working as it should. Likely they knew of this issue and fixed it.

Same problem with UR824, it’s clearly some sort of bug. Used the 824 forever with no problem, then as soon as I checked that “do not ask again” dialog when Cubase starts, the hardware-specific options quit showing in Cubase. I’d have never figured out the cause if it wasn’t for this post.



I also purchased Cubase Pro 9… but this bug still is showing up on my system. I raised a ticket at Steinberg and hope they do fix it soon.


If it’s any help, I discovered this last night: If the hardware panel isn’t showing, exit Cubase, power down the audio interface then turn it back on, then go back into Cubase. I’m using a UR824 but I had the exact same problem.


Since I connected the 824 to a USB3.0 port on my computer the problem vanished and the system works as it should. It looks to me the latest USB driver V1.9.9.1 is the cause. So you could downgrade the driver to V1.7.3 or use USB3.0 port. (btw. I still use the ‘old’ USB cable… not a 3.0 type)

Okay, I’ve just about had it with this thing. I can’t get the Audio Hardware Setup or the Hardware rack now in Cubase Pro 9.0.20. I tried running Cubase as admin. I uninstalled and reinstalled the MR Extension. I even tried the rename extension dll, start Cubase, rename it back and start Cubase again trick. Nothing is working. What is the deal Steinberg? Why is this still flakey since 8.0? None of the other extensions (CC121, SKI for iC Pro, even my Panorama P6) have any trouble.

A Solution is still there. I posted it time ago here. Don´t check the box to remeber the Audio Driver at cubase startup. If you rename die extension.dll don#t rename it back. A new one will be created at the next cubase startup

I’d just like to add in- thank you guys for the workaround.

I have been just using the UR824 without the onboard effects since I got it… so I only recently realized I have this same problem under Cubase Pro 9.0.1. I am sure I had it under v8, too… I just never noticed.

I have totally replicated the workaround as above-
Do not Check the box “Dont ask me again”… and I always have Devices>Audio Hardware.
On FIRST start of Cubase after a power Cycle of the UR824… I have the Hardware Rack in the MixConsole. It is persistent for me until… some unknown condition. Then if I power cycle the device I am back to normal.

This is TOTALLY suboptimal behavior… but I, for one, only USE the hardware rack when I want to record using Direct Monitoring with onboard effects.
All this time, the device had been working fine with Direct Monitoring on by default… just no onboard effects. Which, is usually fine by me. . . until it isn’t.

Cheers for figuring out the workaround, though! You guys rock.

I’ve just setup my UR824 today - and I’m also missing the HARDWARE option in the MIXER console…but I do get the Audio Hardware Setup option in Devices.
That is until I went to the burger button (next to the Configurations dropdown in the bar at the top)
and then deselected inputs, and re-selected inputs - hey presto! I cba to down the reinstall crap as I’d only just installed it. Haven’t tried this with the default ‘Yes’ option remembered… Does this work for you?