Audio output similar to system output possible?

Is it somehow possible to tell dorico to use the system output on a mac by default? Every time I use my headphones on the road and start Dorico after pugging the headphones in Dorico is using my internal speakers. I have also similar issues with different audio interfaces. It is really anoing and time consuming to change it in the preferences again and again. Logic and other software has no problem with that. Why is Dorico so complicated in dealing with the audio driver?

If you go to Edit > Device Setup and then press the Device Control Panel button, the CoreAudio Device Settings window does pop up. In there, is the option ‘Automatically Configure Devices’ ticked with you?

yes it is

it is switching while it’s open and I plug/unplug the headphones but not when Dorico is not running while I plug in my headphones.

I think Dorico should be able to read the system output and setting it’s output to it on startup…

Well, on my 2017 iMac Dorico behaves the way you want.
E.g., Dorico plays out via speakers, quit Dorico, plug in headphones, start Dorico again and it plays out via headphones.

It definitely doesn’t do it on my computer 16 inch mac book pro 2019 with OS-X 11.3 (Big Sur). I tried untagging it, closed it, tagged it again, no change…

I tried it over and over, than Dorico even froze. It does it even more often when I plug/unplug my external RME interface.
Most annoying is it when I work with Dorico with headphones, close Dorico, unplug the headphones and then reopen Dorico (which could be even after having the computer on sleep for hours). Then there will be no sound at all, because the external speakers stay untagged in the device control panel window.

After the Dorico restart after it got frozen, Dorico will not play any sound although everything in the device control panel is tagged right. I have then to restart the computer.

I will soon get an M1 macMini soon and revisit the case. A little patience please.