Audio performance Asio

Audio Performance meters are peaking in elements 11 ,no vst instruments have been loaded ,I am using Mac Studio Ultra fully-specced , and if I opened any project the pops and clicks like crazy , I tried all the possible options in the Asio guard / buffer setting without any hope, what might be the cause for this !

If you click right under “audio system” where it says “Scarlett solo usb” and then on “control panel” you will find a setting related to the buffer size.
When you increase this the performance will get better.

Too low like 64 will stress the system. Too high like 4096 will add latency.
Find your sweetspot or adjust by your needs on every project.

I usually record at 64-128 and mix 2048-4096.
But this is always related to the power of each machine.

but I tried to change the buffer size same issue .

So what’s the buffer size on the screenshot for example?

the meters are changing constantly , and always clipping

Hm, any other processes/apps running simultaneously? Latest drivers on Scarlett?

I could be wrong, but his input and output latencies are already at something like 15 seconds, which means, at 44.1 kHz thet he/she probably set the latency at at least 256 samples (it depends of the driver also…).

I suspect something else : wifi, USB settings, power scheme, or any other system process that can go in the way…

nothing is running , all performance are good in the activity monitor Mac speaking

I am thinking about this too and I asked about drivers but I think mac doesn’t even need drivers for scarlett, not sure.

all drivers are up to date , its weird , I tried to change everything related to buffer or in the audio option , nothing …

as @cubic13 said are there any power or performance drawbacks on system settings?

what do you mean by system settings, I mean when it comes to power ?

That’s why I suspect a more or less ‘real time’ system process that could run in the background. I was about to suggest installing and running LatencyMon, but it seems that it’s Windows only. Don’t know if there is an equivalent for MacOS…

1 Like

If you go to system preferences is there any energy saver enabled or so?
Also can you try disabling the multi processing to see if it gets better?

1 Like

no, there isn’t

maybe in laptops it might affect , but in Mac Studio I don’t think , I tried to search for that option as well but nothing

Tried disabling the multi processing in Cubase?

yes same issue , I tired whatever in this box of audio , from low to high ,on off , nothing

Banging my head, out of ideas, give me some time maybe I come up with something.