Authorize Steinberg Activation Manager

I would appreciate any advice on how to allow my browser (Google Chrome) to open Steinberg Activation Manager.

You should find that when you load the page (or when you click on the Try Again button) you get a dialog from the browser asking you whether it’s OK for the Steinberg Activation Manager to handle the URL rather than the browser. For example, in Edge it looks like this:

image

Do you not get that at all?

Yes, I ticked this option, but nothing happened.

You clicked it and pressed “Open”, or clicked it and pressed “Cancel”?

I’m in the same boat. I received the, This site is trying to open Steinberg Activation Manager. I ticked the checkmark to allow it, the notification disappeared, and now nothing happens. I’ve refreshed the page and hit try again about a hundred times, and nothing happens. What do you recommend?

Gotta ask: have you tried restarting? (Or resetting cookies? Although this latter would have repercussions for other websites.)

I am not a Chrome user myself, but I believe you can view/edit the custom protocol handler settings as follows:

  • Select the Chrome menu on the browser toolbar
  • Select Settings
  • Select Show advanced settings
  • In the Privacy section select Content settings
  • Locate the “Handlers” section

@Richard_Lanyon I have allowed multiple permissions in the “Handlers” section. I have allowed Pop ups, redirects, and automatic downloads. Is there another option I should be following/allowing? Also @Romanos401 I did both resetting cookies and restarting the computer.

Are you logged into your computer as “admin”? We have had many issues in the past when people were not installing dorico at the root level of the machine.

I clicked it and pressed “Open”.

Yes, I am logged into my computer as “admin”.
Yes, I’ve tried restarting and resetting cookies.

Can you try changing your default browser to Edge (just temporarily) and seeing whether it works there? Just to determine whether it is browser-specific.

Peter is reporting to me that the Steinberg activation manager will not launch for him, even if he clicks on the program separately. (New user/limited posts)

Same behaviour in Edge and IE.

Is it that SAM doesn’t run at all, or that it runs but seems to hang?

For Peter it’s the SAM

Milos, the other thing worth checking is whether the protocol handler itself is set up in the registry. If you run regedit you should have a registry key that looks like this:

Where the actual command is "C:\Program Files\Steinberg\Activation Manager\SteinbergActivationManager.exe" --redirect "%1"

Same problem here. To solve the problem I have to finish SAM in Task Manager or restart my computer.

I would suggest Peter reinstalls SAM from here Steinberg Activation Manager | Steinberg

Ah, sorry Milos, I didn’t realise SAM wouldn’t run for you even if you started it manually.

One thing worth checking - if you find that you need to kill SAM in Task Manager then you may also need to kill another process called “Steinberg License Engine” at the same time. That may make a difference.